Cyberduck Mountain Duck CLI

#5131 closed defect (worksforme)

ssh permissions are frequently misset

Reported by: theallan Owned by: dkocher
Priority: normal Milestone: 3.6.1
Component: sftp Version: Nightly Build
Severity: normal Keywords: ssh, permissons
Cc: Architecture: Intel
Platform: Mac OS X 10.5

Description

I've noticed for the past couple of weeks with the nightly builds (currently using Version 3.6 (6874P)) that when I save a file which I've been editing the permissions on the remote file are frequently misset. For example I've just been editing a file which has 644 on the server, hit save in my editor and Cyberduck uploads the file, but the permissions are set to 600. This is most noticeable on a web-server where those permissions mean the file can't be read.

In addition to this (might be a separate issue?) viewing the permission of a file via ssh (cmd-I) does not show the current permissions - it simply shows 000. Trying to set the permissions results is some odd combinations on the file.

Change History (7)

comment:1 Changed on Sep 4, 2010 at 7:38:27 AM by dkocher

  • Component changed from core to sftp
  • Milestone set to 3.6
  • Status changed from new to assigned

comment:2 Changed on Sep 5, 2010 at 6:13:35 PM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

I cannot replicate the this but there was an issue with updating the permission display in the Info panel when changing the selection of file quickly. Fixed in r6890. Can you please reopen the ticket with more details if you can reproduce the issue in the updated snapshot build.

comment:3 follow-up: Changed on Sep 5, 2010 at 6:20:46 PM by theallan

Yes no problem at all. I'll grab the latest nightly shortly. Funnily enough I just had the exact issue that this bug was about, so I can reproduce it, but not 100% of the time - I think it's the first time I open a browser window, although not certain. Is there any extra debugging information I can log and attach to the bug?

comment:4 in reply to: ↑ 3 Changed on Sep 5, 2010 at 7:01:37 PM by dkocher

Replying to theallan:

Yes no problem at all. I'll grab the latest nightly shortly. Funnily enough I just had the exact issue that this bug was about, so I can reproduce it, but not 100% of the time - I think it's the first time I open a browser window, although not certain. Is there any extra debugging information I can log and attach to the bug?

An updated build is now available. Make sure to check your preferences:

  • Make sure that in Preferences → Transfers → Permissions, Change Permissions is checked for both download and uploads.
  • Let me know if you are using SCP for file transfers in Preferences → SFTP.

comment:5 Changed on Sep 7, 2010 at 12:35:35 PM by dkocher

  • Milestone changed from 3.6 to 3.6.1

Fix for default SFTP permissions in r6900. http://silversandals.org - http://desertboots.org

Version 1, edited on Oct 21, 2010 at 9:52:00 AM by frenzyl (previous) (next) (diff)

comment:6 follow-up: Changed on Sep 8, 2010 at 4:40:16 PM by theallan

I've not been able to reproduce this with the latest builds - so it looks like you've fixed it with the earlier patches. Thanks!

comment:7 in reply to: ↑ 6 Changed on Sep 9, 2010 at 6:45:05 AM by dkocher

Replying to theallan:

I've not been able to reproduce this with the latest builds - so it looks like you've fixed it with the earlier patches. Thanks!

Thanks for letting me know.

Note: See TracTickets for help on using tickets.