Cyberduck Mountain Duck CLI

#5154 closed defect (fixed)

Synchronize does not upload

Reported by: zak_burke Owned by: dkocher
Priority: normal Milestone: 3.8
Component: core Version: 3.6.1
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description

Synchronize no longer functions in build 3.6.1. No files are uploaded to the destination regardless of the timestamps or filesizes on the source directories. Synchronize works with build 3.5.1 on the same set of local and remote directories.

I am using an SFTP connection but don't know if that matters.

Attachments (1)

CD.tiff (34.3 KB) - added by ye on Sep 30, 2010 at 8:52:58 PM.
"succsessful incompleat transfer"

Download all attachments as: .zip

Change History (30)

comment:1 Changed on Sep 8, 2010 at 4:39:11 PM by ye

Same problem here. Huge folders such as my Mail or Papers folder get "synchronized" nearly imediately (took a long time with older version only to check if there is something to sync). Only a partial synchronization is achieved. For papers e.g. the database of papers gets loaded but all PDFs, stored in separate subfolders) are not synced.

comment:2 Changed on Sep 10, 2010 at 7:49:28 PM by dkocher

  • Milestone set to 3.6.2
  • Status changed from new to assigned
  • Summary changed from synchronize does not function to Synchronize does not upload

comment:3 Changed on Sep 10, 2010 at 7:49:39 PM by dkocher

#5171 closed as duplicate.

comment:4 Changed on Sep 13, 2010 at 10:02:38 PM by dkocher

#5187 closed as duplicate.

comment:5 Changed on Sep 16, 2010 at 10:56:30 AM by zwigger

Here I recognized while synchronizing download that it only builds the folder structure locally , but doesn`t transfer the containing files.

comment:6 Changed on Sep 16, 2010 at 4:06:24 PM by dkocher

#5203 closed as duplicate.

comment:7 Changed on Sep 18, 2010 at 6:02:37 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r7019.

comment:8 Changed on Sep 20, 2010 at 8:51:48 AM by dkocher

A snapshot build is now available.

comment:9 Changed on Sep 21, 2010 at 9:57:30 AM by ye

For me the proplem presists with nightly build 7035

comment:10 Changed on Sep 21, 2010 at 6:21:05 PM by dkocher

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:11 Changed on Sep 30, 2010 at 8:08:15 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

Please test again with the latest build available.

comment:12 Changed on Sep 30, 2010 at 8:52:01 PM by ye

I tested with build 7124, and I now get data transfer. As far as I can judge from that what arrived in the mail folder, sync worked. The only suspicious thing is that the scanning phase before the transfer was very fast (it took several minutes with version 3.5 ...several GB in the folder). For the other test folder, I got also transfer, cyberduck reports success (green dot) but on the other hand claims only to have transferred 10% of the data !? (see attached screenshot, first item) . When comparing the size (Command-I) the content o the source!! is less ... but that is perhaps due to different block size. I do not get via Cyberduck the (recursive) number of objects in the folder ... I try to compare tomorrow in situ.

Changed on Sep 30, 2010 at 8:52:58 PM by ye

"succsessful incompleat transfer"

comment:13 follow-up: Changed on Oct 1, 2010 at 5:14:35 PM by ye

Finder reports a different number on the both synced machines in the "papers" folder 1904 on the remote an 1894 on the local. Sync does not launch further transfers (now with build 7154), but this was the folder with the problem of Ticket #4093, which no longer appears.

In the mail folder there are on the local machine more files. The scanning time is, more or less the old one, conversely to what I said in the previous mail (today CD wanted to load the whole mail folder, probably I messed with the time stamp settings, and the scanning time recalled me on earlier such incidents).

Summing up: I would say it works as well as with 3.5.

comment:14 in reply to: ↑ 13 ; follow-up: Changed on Oct 1, 2010 at 5:40:35 PM by dkocher

Replying to ye:

Finder reports a different number on the both synced machines in the "papers" folder 1904 on the remote an 1894 on the local. Sync does not launch further transfers (now with build 7154), but this was the folder with the problem of Ticket #4093, which no longer appears.

In the mail folder there are on the local machine more files. The scanning time is, more or less the old one, conversely to what I said in the previous mail (today CD wanted to load the whole mail folder, probably I messed with the time stamp settings, and the scanning time recalled me on earlier such incidents).

Summing up: I would say it works as well as with 3.5.

I suppose the local folder includes files that are excluded from the transfer such as .DS_Store.

comment:15 in reply to: ↑ 14 Changed on Oct 1, 2010 at 6:27:11 PM by ye

Replying to dkocher:

Replying to ye:

Finder reports a different number on the both synced machines in the "papers" folder 1904 on the remote an 1894 on the local. Sync does not launch further transfers (now with build 7154), but this was the folder with the problem of Ticket #4093, which no longer appears.

In the mail folder there are on the local machine more files. The scanning time is, more or less the old one, conversely to what I said in the previous mail (today CD wanted to load the whole mail folder, probably I messed with the time stamp settings, and the scanning time recalled me on earlier such incidents).

Summing up: I would say it works as well as with 3.5.

I suppose the local folder includes files that are excluded from the transfer such as .DS_Store.

I got the numbers in both caseses on spot with Finder Info (when I was in the office today and with my laptop at home, as I saw no such info available with CD). Also the size is substantially different (the remote papers folder is 5 MB larger than the local the Folder with aprox 2Gb total size) I am not sure that all this results from excluded files. I can try next week to make a copy on an USB stick and search for the difference in the content.

comment:16 Changed on Oct 4, 2010 at 4:35:20 PM by ye

Here are the differences of "Papers folder". The version on the desktop is the one from the remote machine. The sync process should download from the remote machine. So at least the pdf-files "Only in /Users/me/Desktop/Papers..." should get synced.

 me$ diff -r /Users/me/Desktop/Papers /Users/me/Documents/Papers 
Binary files /Users/me/Desktop/Papers/.DS_Store and /Users/me/Documents/Papers/.DS_Store differ
Only in /Users/me/Desktop/Papers/1985/Cohen: Cohen-Covering radius--survey and recent results-1985.pdf
Only in /Users/me/Desktop/Papers/1986/McEliece: McEliece-On the decoder error probability for Reed-Solomon codes-1986.pdf
Only in /Users/me/Desktop/Papers/1994/Glynn: Glynn-On the construction of arcs using quadrics-1994.pdf
Only in /Users/me/Desktop/Papers/1997/Cossidente: Cossidente-Applications of line geometry III The quadric Veronesean and the chords of a twisted cubic-1997.pdf
Only in /Users/me/Desktop/Papers/1997/Glynn: Glynn-On cone representations of translation planes-1997.pdf
Only in /Users/me/Desktop/Papers/1998/Glynn: Glynn-A survey of cone representations-1998.pdf
Only in /Users/me/Desktop/Papers/1998/Glynn: Glynn-On cubic curves in projective planes of characteristic two-1998.pdf
Only in /Users/me/Desktop/Papers/1999/Cossidente: Cossidente-Cyclic and elementary abelian caps in projective spaces-1999-1.pdf
Only in /Users/me/Desktop/Papers/1999/Ebert: Ebert-Complete systems of lines on a Hermitian surface over a finite field-1999.pdf
Only in /Users/me/Desktop/Papers/2000: .DS_Store
Only in /Users/me/Documents/Papers/2001/Cooperstein: Cooperstein-On Generalized k-Arcs in PG (2n q)-2001.pdf
Only in /Users/me/Desktop/Papers/2004/Glynn: Glynn-The geometry of additive quantum codes-2004.pdf
Only in /Users/me/Documents/Papers/2005/Unknown: 2005-1.pdf
Only in /Users/me/Documents/Papers/2005/Unknown: 2005-2.pdf
Only in /Users/me/Documents/Papers/2005/Unknown: 2005-3.pdf
Only in /Users/me/Documents/Papers/2005/Unknown: 2005-4.pdf
Only in /Users/me/Documents/Papers/2005/Unknown: 2005-5.pdf
Only in /Users/me/Documents/Papers/2005/Unknown: 2005-6.pdf
Only in /Users/me/Documents/Papers/2005/Unknown: 2005-7.pdf
Only in /Users/me/Documents/Papers/2005/Unknown: 2005-8.pdf
Only in /Users/me/Documents/Papers/2005/Unknown: 2005-9.pdf
Only in /Users/me/Desktop/Papers/2007/Glynn: Glynn-On some quaternary self-orthogonal codes-2007.pdf
Only in /Users/me/Desktop/Papers/2009/Ezerman: Ezerman-The Weights in MDS Codes-2009.pdf
Only in /Users/me/Desktop/Papers/2009/Glynn: Glynn-A geometrical representation theory for orthogonal arrays-2009.pdf
Only in /Users/me/Desktop/Papers/2009/Glynn: Glynn-A note on Nk configurations and theorems in projective space-2009.pdf
Only in /Users/me/Desktop/Papers/2009/Glynn: Glynn-The modular counterparts of Cayley's hyperdeterminants-2009.pdf
Only in /Users/me/Documents/Papers/2009/Nakagawa: Nakagawa-On the number of generalized quadratic APN functions-2009.pdf
Only in /Users/me/Desktop/Papers/2010/Albrecht: Albrecht-Algorithm 898 Efficient multiplication of dense matrices over GF (2)-2010.pdf
Only in /Users/me/Desktop/Papers/2010/Glynn: Glynn-THEOREMS OF POINTS AND PLANES IN THREE-DIMENSIONAL PROJECTIVE SPACE-2010.pdf
Only in /Users/me/Desktop/Papers/2010/Glynn: Glynn-The permanent of a square matrix-2010-1.pdf
Binary files /Users/me/Desktop/Papers/Spotlight/Authors.spotlightIndex and /Users/me/Documents/Papers/Spotlight/Authors.spotlightIndex differ
Binary files /Users/me/Desktop/Papers/Spotlight/Fulltext.spotlightIndex and /Users/me/Documents/Papers/Spotlight/Fulltext.spotlightIndex differ
Binary files /Users/me/Desktop/Papers/Spotlight/General.spotlightIndex and /Users/me/Documents/Papers/Spotlight/General.spotlightIndex differ
Binary files /Users/me/Desktop/Papers/Spotlight/Journals.spotlightIndex and /Users/me/Documents/Papers/Spotlight/Journals.spotlightIndex differ
Binary files /Users/me/Desktop/Papers/Spotlight/Keywords.spotlightIndex and /Users/me/Documents/Papers/Spotlight/Keywords.spotlightIndex differ
Binary files /Users/me/Desktop/Papers/Spotlight/Titles.spotlightIndex and /Users/me/Documents/Papers/Spotlight/Titles.spotlightIndex differ
Only in /Users/me/Documents/Papers/Unknown/Bracken: .DS_Store
Only in /Users/me/Documents/Papers/Unknown: Brewbaker
Only in /Users/me/Desktop/Papers/Unknown/Canteaut: Canteaut-STRUCTURAL WEAKNESSES OF PERMUTATIONS WITH A LOW DIFFERENTIAL UNIFORMITY AND GENERALIZED CROOKED FUNCTIONS.pdf
Only in /Users/me/Desktop/Papers/Unknown/Glynn: Glynn-A condition for arcs and MDS codes.pdf
Only in /Users/me/Desktop/Papers/Unknown/Glynn: Glynn-TRANSFORMATIONS OF CODES AND GEOMETRY RELATED TO VERONESEANS-1.pdf
Only in /Users/me/Desktop/Papers/Unknown/Glynn: Glynn-TRANSFORMATIONS OF CODES AND GEOMETRY RELATED TO VERONESEANS.pdf
Only in /Users/me/Desktop/Papers/Unknown/Unknown: u7366073110168hk.pdf

comment:17 follow-up: Changed on Nov 3, 2010 at 6:08:04 PM by ye

I still have the problem with CD3.7 (build 7380), although the change log mentions something fixed with sync.

When syncing my mail folder the scanning process is still nearly immediately finished. Only the envelope gets transferred but the messages itself are missing.

comment:18 in reply to: ↑ 17 Changed on Nov 3, 2010 at 7:06:06 PM by zak_burke

Replying to ye:

I still have the problem with CD3.7 (build 7380), although the change log mentions something fixed with sync.

When syncing my mail folder the scanning process is still nearly immediately finished. Only the envelope gets transferred but the messages itself are missing.

Agreed. I saw the changelog and tried build 7380 but still have the same problem: synchronize does not push local changes to a remote server.

comment:19 Changed on Nov 3, 2010 at 8:23:00 PM by ye

P.S. with me it is download not upload.

comment:20 Changed on Nov 4, 2010 at 10:56:19 AM by dkocher

  • Milestone changed from 3.7 to 4.1
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:21 follow-up: Changed on Nov 9, 2010 at 7:35:56 AM by https://www.google.com/accounts/o8/id?id=aitoawl-cuuwtrnavhgl2a8ldwrox-gbwwnoh5o

I have experienced a similar problem and am adding information in case this helps determine the root cause and fix. I was using the current version off the main website or version 3.7. My remote service is Amazon S3. When using Synchronize with "upload", I would get two problems. A compare of large directory (1.6GB) would complete in just a few seconds and it would not upload any newly added files. Drilling down into the directory with an added file(s) and creating a sync on just that directory worked just fine (new file(s) correctly uploaded). This sounds similar to the problem already report. I had a second problem as well. On a completely different folder, each time I asked Cyberduck to sync, it would sync the same 11.MB of files out of the 1GB total size of directory. I did this 4 times and 4 times it uploaded the same files to the remote. It might have something to do with the fact I downloaded these files from the remote to local by accident, and their local timestamp has been updated to the time of download.

Regardless, I reverted to version 3.5.1 and both problems went away.

comment:22 Changed on Nov 24, 2010 at 5:32:19 PM by dkocher

#5361 closed as duplicate.

comment:23 Changed on Nov 29, 2010 at 3:01:50 PM by dkocher

In r7690 make sure to update timestamp of directory after modifying its content.

comment:24 Changed on Nov 29, 2010 at 4:39:02 PM by dkocher

  • Milestone changed from 4.1 to 3.8
  • Resolution set to fixed
  • Status changed from reopened to closed

Please try the latest snapshot build available.

comment:25 follow-up: Changed on Nov 29, 2010 at 5:38:38 PM by ye

I still ( with buit 7825) have the effectthat for my >1GB mail folder the scanning of the folder is imediately finished and nothing happens (sync download).

comment:26 in reply to: ↑ 25 Changed on Nov 30, 2010 at 1:20:42 PM by dkocher

  • Resolution fixed deleted
  • Status changed from closed to reopened

Replying to ye:

I still ( with buit 7825) have the effectthat for my >1GB mail folder the scanning of the folder is imediately finished and nothing happens (sync download).

I think the remaining issue is that directories are not included for the synchronization with the download only option when the local modification date of the folder is newer (but there are possibly still files inside that should be synchronized).

comment:27 Changed on Nov 30, 2010 at 4:40:21 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

In r7850.

comment:28 in reply to: ↑ 21 Changed on Nov 30, 2010 at 4:42:07 PM by dkocher

Replying to https://www.google.com/accounts/o8/id?id=aitoawl-cuuwtrnavhgl2a8ldwrox-gbwwnoh5o:

I have experienced a similar problem and am adding information in case this helps determine the root cause and fix. I was using the current version off the main website or version 3.7. My remote service is Amazon S3. When using Synchronize with "upload", I would get two problems. A compare of large directory (1.6GB) would complete in just a few seconds and it would not upload any newly added files. Drilling down into the directory with an added file(s) and creating a sync on just that directory worked just fine (new file(s) correctly uploaded). This sounds similar to the problem already report. I had a second problem as well. On a completely different folder, each time I asked Cyberduck to sync, it would sync the same 11.MB of files out of the 1GB total size of directory. I did this 4 times and 4 times it uploaded the same files to the remote. It might have something to do with the fact I downloaded these files from the remote to local by accident, and their local timestamp has been updated to the time of download.

Regardless, I reverted to version 3.5.1 and both problems went away.

We now support comparing file checksums for S3, Cloudfiles, Azure and Dropbox protocols making synchronization for these protocols much more robust.

comment:29 Changed on Nov 30, 2010 at 6:30:44 PM by ye

OK. with build 7852 the scan was completed and seemingly all data was transferred.

Some new bug appeared: Although I was logged in I got asked for the password (as reason was said "the access to the keychain is disabled by the preferences". This is true I do not store the passwords in the keychain, but I never did before and I only needed to log in once). Secondly the login window, over the transfer window, immediately appeared again and there was no possibility to make it disappear. The transfer went trough nethertheless.

Also the effect as described in Ticket #4093 is back.

Note: See TracTickets for help on using tickets.
swiss made software