Cyberduck Mountain Duck CLI

#5168 closed defect (duplicate)

Error opening data socket

Reported by: apbainmaine Owned by: apbainmaine
Priority: normal Milestone: 4.4
Component: ftp Version: 3.6.1
Severity: normal Keywords: Error Message 3.61
Cc: Architecture: Intel
Platform: Mac OS X 10.5

Description (last modified by dkocher)

After uploading the recent update, I'm being prompted constantly about certificate issues with my server. After clicking that I do want to continue the upload it cranks for awhile, and then I get the following message:

FTP Error: Upload failed
I won't open a connection to 192.168.1.102 (only to 24.147.240.17)

Being stubborn, I keep clicking Try Again, and eventually it goes, but it's extremely frustrating (particularly when on a deadline).

Change History (17)

comment:1 follow-up: Changed on Sep 9, 2010 at 10:01:12 AM by dkocher

  • Description modified (diff)
  • Resolution set to worksforme
  • Status changed from new to closed

Try to change the FTP connect mode to passive.

comment:2 in reply to: ↑ 1 Changed on Sep 10, 2010 at 9:51:51 PM by quack12

Replying to dkocher:

Try to change the FTP connect mode to passive.

This problem is not closed yet. I and others have the same problem. See ticket #5179.

What is the solution? Hitting try again time and time again is not a solution I intend to use.

Last edited on Sep 16, 2010 at 12:55:05 PM by dkocher (previous) (diff)

comment:3 Changed on Sep 10, 2010 at 10:11:59 PM by dkocher

#5179 closed as duplicate.

comment:4 Changed on Sep 10, 2010 at 10:13:00 PM by dkocher

  • Summary changed from Error message when uploading with v3.61 to Error opening data socket

comment:5 Changed on Sep 11, 2010 at 10:16:04 PM by dkocher

#5167 closed as duplicate.

comment:6 Changed on Sep 11, 2010 at 10:17:54 PM by dkocher

  • Milestone set to 3.6.2

comment:7 Changed on Sep 16, 2010 at 1:14:54 PM by dkocher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Many having issues with this. Have to look into it.

comment:8 Changed on Sep 16, 2010 at 1:15:47 PM by dkocher

See also #5200, #5198, #5179, #5199, #5195, #5139.

Last edited on Sep 16, 2010 at 7:17:25 PM by dkocher (previous) (diff)

comment:9 follow-up: Changed on Sep 16, 2010 at 1:37:40 PM by dkocher

It looks like this issue is caused when changing the connection protocol to FTP-TLS instead of plain FTP.

comment:10 in reply to: ↑ 9 Changed on Sep 16, 2010 at 1:53:04 PM by dkocher

Replying to dkocher:

It looks like this issue is caused when changing the connection protocol to FTP-TLS instead of plain FTP.

Some people are possibly hitting a interoperability issue with ProFTPD documented in #5087. Opening the data socket using passive connect mode (PASV) fails and the fallback to active mode (PORT) fails for most configurations. Hence the error message. Users should switch back to plain FTP connections. Choose FTP (File Transfer Protocol) in the bookmark protocol setting. Most users hit by this compatibility issue have been asked to secure the connection because support for TLS was detected upon negogiating the connection. Refer to switch to secure connection prompt.

Last edited on Sep 24, 2010 at 3:21:43 PM by dkocher (previous) (diff)

comment:11 Changed on Sep 18, 2010 at 2:21:50 PM by dkocher

If the above does not apply, make sure to check you have checked Use Passive FTP Mode (PASV) in the system preferences. Refer to FTP Connect Mode in the wiki.

Last edited on Sep 19, 2010 at 5:23:20 PM by dkocher (previous) (diff)

comment:12 Changed on Sep 19, 2010 at 10:43:39 PM by dkocher

  • Resolution set to duplicate
  • Status changed from reopened to closed

Closing as duplicate for #5087 as the root cause of the issue.

comment:13 Changed on Sep 30, 2010 at 8:11:22 PM by dkocher

As of r7101 the original error is reported and not the error from the fallback mode.

comment:14 Changed on Oct 5, 2010 at 7:14:30 PM by dkocher

#5138 closed as duplicate.

comment:15 Changed on Oct 5, 2010 at 7:14:42 PM by dkocher

#5285 closed as duplicate.

comment:16 Changed on Oct 14, 2010 at 3:04:50 PM by dkocher

#5209 closed as duplicate.

comment:17 Changed on Jul 11, 2013 at 8:26:06 AM by dkocher

  • Milestone changed from 3.7 to 4.4

Duplicate for #5385. Will add proper fallback logic if the server denies PORT command.

Note: See TracTickets for help on using tickets.
swiss made software