Cyberduck Mountain Duck CLI

#5275 closed defect (thirdparty)

Desktop is not refreshed when the file is dropped to Explorer

Reported by: lukas Owned by: dkocher
Priority: normal Milestone: 4.0b8
Component: interface Version: 4.0b2
Severity: normal Keywords: desktop refresh dragndrop
Cc: Architecture: Intel
Platform: Windows 7

Description

When the file is dragged'n'dropped from Cyberduck onto the Desktop needs to be manually refreshed for the files to be visible. This seems to happend on 64bit and 32bit Windows 7. I have noticed this with webdavs connection - sftp seems to work correctly

Change History (8)

comment:1 Changed on Oct 4, 2010 at 4:51:18 PM by dkocher

  • Component changed from core to interface
  • Owner set to dkocher
  • Summary changed from Desktop is not refreshed when the file is dragged'n' dropped Windows 7 to Desktop is not refreshed when the file is dragged'n' dropped to Explorer

comment:2 Changed on Oct 11, 2010 at 1:02:04 PM by yla

Cannot reproduce this behavior on Windows 7 (64bit). I've tried with different protocols.

comment:3 Changed on Oct 13, 2010 at 3:58:08 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

comment:4 Changed on Oct 13, 2010 at 6:39:50 PM by lukas

Hi David, sorry to be a pain but even in release b4 this still happens, This is how i can replicate it: I create webdav (SSL) connection. I drag html file, it corrdctly appears on the desktop. I close Transfers dialog window I drag jsp file onto desktop, it does not appear I drag html file, it does not appear I drag another jsp file same problem I refresh the desktop manually all of the files appear.

Note that the order the files that do appear on the desktop is random, i.e. sometimes its the first file, sometimes its second, etc

comment:5 Changed on Oct 13, 2010 at 6:41:22 PM by lukas

I should of mentioned that i'm using Windows 7 32bit (this also seems to happen on 64 bit Windows 7)

comment:6 Changed on Oct 13, 2010 at 7:51:28 PM by dkocher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:7 Changed on Nov 3, 2010 at 3:51:28 PM by dkocher

  • Summary changed from Desktop is not refreshed when the file is dragged'n' dropped to Explorer to Desktop is not refreshed when the file is dropped to Explorer

comment:8 Changed on Nov 24, 2010 at 8:13:27 AM by yla

  • Resolution set to thirdparty
  • Status changed from reopened to closed

The destination refreshment is out-of Cyberduck's control. This seems to be a common issue on Windows 7:

http://superuser.com/questions/69219/windows-7-desktop-does-not-automatically-refresh http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/09fd46ff-65f1-4fa7-ae2d-9f3b2644fad6

Can you please give those recommendations a try?

Note: See TracTickets for help on using tickets.
swiss made software