Cyberduck Mountain Duck CLI

#5279 closed defect (fixed)

“Server” field is meaningless for S3; should be hidden

Reported by: http://cdn.natesilva.com/ Owned by: dkocher
Priority: normal Milestone: 4.0b3
Component: interface Version: 4.0b2
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Windows 7

Description

Steps to reproduce:

  1. Go to the bookmarks tab.
  2. Click the “+” sign to add a bookmark.
  3. Choose “S3 (Amazon Simple Storage Service)” from the drop-down list.

Results:

One of the fields shown is “Server:” and it is empty, as though the user needs to type something in there.

Notes:

This is confusing as many users won’t know what to enter there. In fact, the field can be left blank. Ideally it should be disabled, removed from the form, or at least pre-filled when the user is setting up an Amazon S3 bookmark.

Attachments (1)

cyberduck-s3-server.png (35.6 KB) - added by http://cdn.natesilva.com/ on Oct 4, 2010 at 5:04:05 PM.
Screen shot

Download all attachments as: .zip

Change History (3)

Changed on Oct 4, 2010 at 5:04:05 PM by http://cdn.natesilva.com/

Screen shot

comment:1 Changed on Oct 4, 2010 at 5:09:09 PM by dkocher

  • Component changed from core to interface
  • Milestone set to 4.0b3
  • Owner set to dkocher

It should be prefilled. We do support editing because of thidparty S3 providers such as Dunkel Cloud Storage.

comment:2 Changed on Oct 6, 2010 at 8:48:20 AM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

In r7230.

Note: See TracTickets for help on using tickets.
swiss made software