Cyberduck Mountain Duck CLI

#5288 closed defect (duplicate)

Edit incompatibilty with Bluefish when creating backup files during save

Reported by: blaquehat Owned by: dkocher
Priority: high Milestone: 4.0b6
Component: core Version: 4.0b3
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Windows 7

Description

If you are editing a file and want to save it. It will not save it back to the FTP site.

Attachments (1)

cyberduck.log (22.7 KB) - added by bushasp on Oct 13, 2010 at 6:09:28 PM.
requested .log file. User and website data removed.

Download all attachments as: .zip

Change History (10)

comment:1 Changed on Oct 6, 2010 at 3:38:06 PM by dkocher

  • Milestone changed from 4.0 to 4.0b4
  • Priority changed from normal to high

comment:2 Changed on Oct 11, 2010 at 7:51:01 AM by yla

Cannot reproduce this issue on Windows 7 and different protocols. Can you please attach the following file after a failed save attempt:

cyberduck.log located in C:\Users\[CurrentUser]\AppData\Roaming\Cyberduck\

comment:3 Changed on Oct 13, 2010 at 4:46:45 PM by bushasp

Comfirming. Log drawer not showing any activity when saving.

System: Windows 7 HP 32bit
Cyberduck: 4.0b4 (7314)
Editor: Bluefish 2.0.0

comment:4 follow-up: Changed on Oct 13, 2010 at 5:12:44 PM by yla

  • Component changed from sftp to interface

Any chance to post the cyberduck.log file after a failed save attempt? The file is located in C:\Users\[CurrentUser]\AppData\Roaming\Cyberduck\

Changed on Oct 13, 2010 at 6:09:28 PM by bushasp

requested .log file. User and website data removed.

comment:5 in reply to: ↑ 4 Changed on Oct 13, 2010 at 6:10:51 PM by bushasp

Replying to yla:

Any chance to post the cyberduck.log file after a failed save attempt? The file is located in C:\Users\[CurrentUser]\AppData\Roaming\Cyberduck\

Sure. I removed URLs and username data form the log, i guess it won't be a problem. It is in the attachments section.

comment:6 Changed on Oct 16, 2010 at 2:51:48 AM by bushasp

Update:

When editing with Notepad the edited file uploaded without a problem. So I tinkered with Bluefish and found that when I turn off the create backup file during file save option (Bluefish 2.0.0, Edit > settings > Files) everything works fine!

The option did not cause trouble on FileZilla 3.3.4.1, only on Cyberduck.

Last edited on Nov 4, 2010 at 9:39:39 AM by dkocher (previous) (diff)

comment:7 Changed on Oct 24, 2010 at 6:48:18 PM by dkocher

  • Summary changed from Editing a file will not save the file back on the FTP site to Edit incompatibilty with Bluefish when creating backup files during save

comment:8 Changed on Oct 24, 2010 at 6:48:33 PM by dkocher

  • Component changed from interface to core

comment:9 Changed on Nov 5, 2010 at 4:07:04 PM by dkocher

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as duplicate of #5376. Generic issue for all editors that save to a different file and then replace the previous.

Note: See TracTickets for help on using tickets.
swiss made software