Cyberduck Mountain Duck CLI

#530 closed defect (worksforme)

incomplete files during SFTP transfer of large directory

Reported by: cwr@… Owned by: dkocher
Priority: normal Milestone:
Component: core Version: 2.5.5
Severity: normal Keywords:
Cc: cwr Architecture:
Platform:

Description

Using Cyberduck (Version 2.5.5 (1971) sorry for not being up-to-date) I transfered two sets of files from a Linux machine to my Mac. Both sets consisted of 900 .tga image files each 2.6MB in size (representing frames of HDTV 720p) for a total transfer of 2.3GB. The transfers were initiated by dragging a folder from the server (in Cyberduck's window) onto my desktop. While later processing these sequences in QuickTime I got errors ("Failed (-8969)") which turned out to be because two of the frame images were incomplete.

I wondered why Cyberduck had given me no error or warning about the incomplete files. I fixed the problem by manually dragging over replacements for the two bad files. These files transfered as expected, so the original data seemed to be fine. I was then able to process my animation data in QT.

But I was REALLY surprised when the second animation sequence had the same problem, and it turns out, on the same two frame numbers! The content of the two video sequences were different, yet frames 384 and 768 of BOTH sequences were only partially transferred by Cyberduck. Note that these frame numbers are related by a factor of 2, suggesting a bug that manifests itself every 384 files, or roughly every gigabyte?

Here is a view of one of the two folders, sorted by file size, showing the two incompete files at the top:

http://www.red3d.com/cwr/temp/Cyberduck/TwoBadFiles.jpg

Change History (6)

comment:1 Changed on Jul 1, 2006 at 2:54:44 PM by dkocher

There really should be an error message in the transfer window in Cyberduck as the icons of the files have not been updated and Cyberduck therfore considered these incomplete. Can you reproduce this issue; there should be a alert icon on the right you can click to see the error message(s) in v 2.5.5

comment:2 Changed on Jul 5, 2006 at 9:56:09 PM by anonymous

There were three alert icons. One in the Transfers log item (clicking there didn't seem to do anything) and one in each of two separate panels above saying:

I/O Error: Timeout waiting for server message (frame0384.tga) I/O Error: Timeout waiting for server message (frame0768.tga)

As before these files were 1.4MB and 1.5MB. Note that since my initial report I have updated to Cyberduck 2.6 and the symptom seems identical. semi formal dressses

Last edited on Jan 30, 2011 at 8:47:09 PM by releonor (previous) (diff)

comment:3 Changed on May 18, 2007 at 8:34:01 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

comment:4 Changed on May 20, 2009 at 6:59:07 PM by cwr

  • Cc cwr added

Looking at the descriptions, it seems likely that these two tickets describe the same bug:

Ticket #530 (closed defect: worksforme) "incomplete files during SFTP transfer of large directory" opened: Jun 30, 2006 closed: May 18, 2007

Ticket #1235 (closed defect: fixed) "Transfers larger than 231 (2147483648) bytes fail" opened: Aug 30, 2007 closed: May 5, 2008

If the bug still existed in August 2007, why was the first ticket been closed in May 2007 with "works for me"?

comment:5 Changed on Nov 3, 2011 at 10:17:01 AM by karabi

I am also getting "Timeout waiting for server message " currently running version 2.5 should I update??

be yourself quotes

comment:6 Changed on Nov 3, 2011 at 1:36:35 PM by cwr

Karabi, I'm hardly the “early adopter” type, but since the current version is 4.1.3, yes upgrading from 2.5 is probably a good idea!

Note: See TracTickets for help on using tickets.
swiss made software