Cyberduck Mountain Duck CLI

#5301 closed defect (fixed)

System.Argument Exeption

Reported by: jcnaquin Owned by: dkocher
Priority: normal Milestone: 4.0b4
Component: googledrive Version: 4.0b3
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Windows 7

Description (last modified by dkocher)

When trying to view permissions on file located in Google docs. Endless loop. Had to kill task to terminate.

Attachments (1)

Untitled.jpg (183.1 KB) - added by jcnaquin on Oct 9, 2010 at 1:32:01 AM.

Download all attachments as: .zip

Change History (6)

Changed on Oct 9, 2010 at 1:32:01 AM by jcnaquin

comment:1 Changed on Oct 9, 2010 at 8:00:58 AM by dkocher

  • Description modified (diff)
  • Milestone set to 4.0b4

comment:2 Changed on Oct 9, 2010 at 8:05:49 AM by dkocher

Possibly related stacktrace.

Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: java.lang.NullPointerException: Internal Reason must not be null.
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.util.common.base.Preconditions.checkNotNull(Preconditions.java:204)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.util.ErrorElement.setInternalReason(ErrorElement.java:170)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.util.ServiceExceptionInitializer$InternalReasonHandler.processEndElement(ServiceExceptionInitializer.java:237)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.util.XmlParser.endElement(XmlParser.java:996)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at org.xml.sax.helpers.ParserAdapter.endElement(ParserAdapter.java:626)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endElement(AbstractSAXParser.java:593)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanEndElement(XMLDocumentFragmentScannerImpl.java:1782)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2938)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:648)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:140)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:511)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:808)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:119)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at org.xml.sax.helpers.ParserAdapter.parse(ParserAdapter.java:405)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.util.XmlParser.parse(XmlParser.java:677)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.util.XmlParser.parse(XmlParser.java:568)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.util.ServiceExceptionInitializer.parse(ServiceExceptionInitializer.java:134)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.util.ServiceExceptionInitializer.parse(ServiceExceptionInitializer.java:119)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.util.ServiceException.<init>(ServiceException.java:117)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.util.ResourceNotFoundException.<init>(ResourceNotFoundException.java:48)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.client.http.HttpGDataRequest.handleErrorResponse(HttpGDataRequest.java:555)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.client.http.GoogleGDataRequest.handleErrorResponse(GoogleGDataRequest.java:563)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.client.http.HttpGDataRequest.checkResponse(HttpGDataRequest.java:536)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.client.http.HttpGDataRequest.execute(HttpGDataRequest.java:515)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.client.http.GoogleGDataRequest.execute(GoogleGDataRequest.java:535)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.client.Service.getFeed(Service.java:1073)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.client.Service.getFeed(Service.java:936)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.client.GoogleService.getFeed(GoogleService.java:631)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.google.gdata.client.Service.getFeed(Service.java:955)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at ch.cyberduck.core.gdocs.GDPath.readAcl(GDPath.java:283)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at ch.cyberduck.ui.action.ReadAclWorker.run(ReadAclWorker.java:46)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at ch.cyberduck.ui.action.ReadAclWorker.run(ReadAclWorker.java:33)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at ch.cyberduck.ui.cocoa.threading.WorkerBackgroundAction.run(WorkerBackgroundAction.java:43)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at ch.cyberduck.ui.AbstractController$1.run(AbstractController.java:73)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at java.lang.Thread.run(Thread.java:637)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 2010-10-09 10:03:29,582 [pool-1-thread-2] ERROR ch.cyberduck.ui.cocoa.ProxyController - Excpetion running task on main thread:null
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: java.lang.NullPointerException
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at java.util.ArrayList.addAll(ArrayList.java:472)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at ch.cyberduck.ui.cocoa.InfoController.setAcl(InfoController.java:492)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at ch.cyberduck.ui.cocoa.InfoController.access$3100(InfoController.java:56)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at ch.cyberduck.ui.cocoa.InfoController$18.cleanup(InfoController.java:1927)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at ch.cyberduck.ui.cocoa.InfoController$18.cleanup(InfoController.java:1924)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at ch.cyberduck.ui.cocoa.threading.WorkerBackgroundAction.cleanup(WorkerBackgroundAction.java:51)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at ch.cyberduck.ui.AbstractController$1$1.run(AbstractController.java:85)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at org.rococoa.internal.MainThreadUtils$3.callback(MainThreadUtils.java:86)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at sun.reflect.GeneratedMethodAccessor33.invoke(Unknown Source)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at java.lang.reflect.Method.invoke(Method.java:597)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.sun.jna.CallbackReference$DefaultCallbackProxy.invokeCallback(CallbackReference.java:384)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.sun.jna.CallbackReference$DefaultCallbackProxy.callback(CallbackReference.java:414)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.sun.jna.Function.invokeVoid(Native Method)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.sun.jna.Function.invoke(Function.java:328)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.sun.jna.Function.invoke(Function.java:276)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at org.rococoa.internal.MsgSendHandler.invoke(MsgSendHandler.java:111)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at com.sun.jna.Library$Handler.invoke(Library.java:214)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at $Proxy0.syntheticSendMessage(Unknown Source)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at org.rococoa.Foundation.send(Foundation.java:200)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at org.rococoa.Foundation.send(Foundation.java:187)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at org.rococoa.internal.ObjCObjectInvocationHandler.sendOnThisOrMainThread(ObjCObjectInvocationHandler.java:254)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at org.rococoa.internal.ObjCObjectInvocationHandler.invokeCocoa(ObjCObjectInvocationHandler.java:222)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at org.rococoa.internal.ObjCObjectInvocationHandler.intercept(ObjCObjectInvocationHandler.java:185)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at ch.cyberduck.ui.cocoa.application.NSApplication$$ByRococoa.run(<generated>)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:108)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at java.lang.reflect.Method.invoke(Method.java:597)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at apple.launcher.LaunchRunner.run(LaunchRunner.java:115)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:50)
Oct  9 10:03:29 kochi [0x0-0x458057c].ch.sudo.cyberduck[36378]: 	at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)

comment:3 Changed on Oct 10, 2010 at 5:55:50 PM by dkocher

I can replicate this here with a file that is not displayed on the Google Docs website, but returned when listing the files using the API that we make use of. Trying to reference the file fails with a Not Found error reported by the server that gives an additional error because of a bug in the Google provided client library.

Can you confirm that the file cheatsheet-en.pdf can't actually be found in your Docs account?

comment:4 Changed on Oct 10, 2010 at 7:25:28 PM by jcnaquin

I can confirm that the file does in fact exist and can be found in my docs. Located here: https://docs.google.com/leaf?id=1F1f-CVkWbNdBZGY8AGwh_hnfTvYCTJ5z8Gabrhr156nxvlX9ETI5aA5X5i-U&sort=name&layout=list&num=50

I did notice that Cyberduck lists all folders, and lists all items in the folders as well. In other words, it lists them twice, once in folder structure and once as a separate item. I can download cheatsheet-en.pdf through either listing via Cyberduck.

comment:5 Changed on Oct 11, 2010 at 3:03:30 PM by yla

  • Resolution set to fixed
  • Status changed from new to closed

In r7279. Thanks for reporting this issue.

Note: See TracTickets for help on using tickets.
swiss made software