Cyberduck Mountain Duck CLI

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5351 closed defect (fixed)

Immediate crash after application launch

Reported by: rfwilmut Owned by: Roger Wilmut
Priority: high Milestone: 3.7.1
Component: core Version: 3.7
Severity: blocker Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description

Downloaded latest Cyberduck: also later used update facility in previous version. Consistently crashed on opening; I deleted the .plist file but no difference. 24 inch 2008 iMac running 10.6.4. Crash report attached.

Attachments (1)

cyberduck crash.txt.zip (13.9 KB) - added by rfwilmut 8 years ago.
Crash report

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by rfwilmut

Crash report

comment:1 Changed 8 years ago by dkocher

Previous releases can be found at http://cyberduck.ch/changelog/. I only have a wild guess that it might be related to the new bookmark importing feature for third party applications. Can you set the following hidden configuration option by opening a Terminal.app and pasting

defaults write ch.sudo.cyberduck bookmark.import.com.panic.Transmit true

Does that make any difference?

comment:2 Changed 8 years ago by dkocher

  • Priority changed from normal to high
  • Summary changed from Latest Cyberduck will not run to Immediate crash after application launch

comment:3 Changed 8 years ago by dkocher

#5352 closed as duplicate.

comment:4 Changed 8 years ago by dkocher

The issue is now clearly linked to #3073.

2010-10-20 17:37:40.340 Cyberduck[20095:a07] *** -[NSKeyedUnarchiver decodeObjectForKey:]: cannot decode object of class (DotMacFavorite)

Seems to be an issue with some favorites for iDisk that are encoded differently from the rest.

comment:5 Changed 8 years ago by dkocher

The workaround is to remove the file ~/Library/Preferences/com.panic.Transmit.plist or to disable Transmit bookmarks import with

defaults write ch.sudo.cyberduck bookmark.import.com.panic.Transmit true

to mark the bookmarks as already imported.

comment:6 Changed 8 years ago by dkocher

  • Milestone set to 3.7.1
  • Resolution set to fixed
  • Status changed from new to closed

In r7372.

comment:7 Changed 8 years ago by dkocher

A snapshot build is available with the fix included.

comment:8 Changed 8 years ago by dkocher

In r7380 using exception handler to catch other unknown errors with the archive.

Note: See TracTickets for help on using tickets.
swiss made software