Cyberduck Mountain Duck CLI

#5370 closed defect (worksforme)

Cyberduck erases temp file while editing

Reported by: jdallen88 Owned by:
Priority: normal Milestone:
Component: core Version: 3.7
Severity: normal Keywords: saving, overwrite, trash, temp, temporary
Cc: Architecture:
Platform: Mac OS X 10.6

Description (last modified by dkocher)

I just upgraded to version 3.7 (7380) and I typically use Cyberduck by logging into my FTP, opening a file to edit, and then saving to upload it. Usually I'll keep the file open and save/upload several times.

However after the upgrade I noticed when I tried saving a second time I would get an error from my editor Could not overwrite file [location/filename] because it has been removed Or Could not be saved because it is in the trash depending on the editor. I'm fairly certain this involves Cyberduck and not the editor because my text editors haven't been updated.

Perhaps it's not a bug though and simply a new feature that has to be changed? Any suggestions would be much appreciated, thank you.

Change History (3)

comment:1 Changed on Oct 25, 2010 at 3:29:22 PM by dkocher

I cannot replicate this issue. What editor are you using?

comment:2 Changed on Oct 29, 2010 at 4:19:33 PM by jdallen88

I've tried it in Smultron and TextEdit and the both have the same problem so I don't think it has anything to do with the editor. In Cyberduck I right-click on the file I want to edit, select Edit With, choose my editor make changes and press command S to save. This works for the first change and it reflects correctly when I view my files online. When I make the second change though it says it could not overwrite the file. I tried saving it as a file in my documents folder but the same error comes up saying it has been removed. However when I look in Finder I can find it.

comment:3 Changed on Nov 19, 2010 at 1:08:09 PM by dkocher

  • Description modified (diff)
  • Resolution set to worksforme
  • Status changed from new to closed

Still cannot reproduce this.

Note: See TracTickets for help on using tickets.