Cyberduck Mountain Duck CLI

#5394 closed defect (fixed)

CloudFiles Not Uploading Since Beta 3

Reported by: jetsinboxes Owned by: Matt Costello
Priority: highest Milestone: 4.0b6
Component: cloudfiles Version: 3.7
Severity: critical Keywords: CloudFiles, Upload, Failed
Cc: spambucket@… Architecture: Intel
Platform: Windows 7

Description

I have been unable to successfully upload anything from my local machine to Rackspace Cloud Files. I do not receive any error other then the upload indicator saying Transfer incomplete. Can you look closer into why this may have stopped working since Beta 3? Thanks

Matt Costello Rackspace Cloud

Change History (15)

comment:1 Changed on Nov 2, 2010 at 8:39:58 AM by dkocher

I don't have any issues here meaning I cannot replicate it. Can you post the transcript from the log. (Right-click in the Transfer window toolbar, choose Log opening the log window before starting the transfer.)

comment:2 follow-up: Changed on Nov 2, 2010 at 7:27:33 PM by jetsinboxes

Here is the log from when I tried to upload a filed call 311.zip and it is 7 megs.

GET /v1.0 HTTP/1.1
x-auth-user: 
x-auth-key: 
User-Agent: Cyberduck/4.0b5 (7454) (Windows 7/6.1) (amd64)
Host: auth.api.rackspacecloud.com

HTTP/1.1 204 No Content
HTTP/1.1 204 No Content
Date: Tue, 02 Nov 2010 19:10:21 GMT
Server: Apache/2.2.3 (Mosso Engineering)
X-Storage-Url: https://storage101.dfw1.clouddrive.com/v1/MossoCloudFS_0688d3e1-a132-44e9-b435-a6e1c8e83bab
X-Storage-Token: 94dfc852-6aa3-4584-b383-02d0b5fb503a
X-CDN-Management-Url: https://cdn1.clouddrive.com/v1/MossoCloudFS_0688d3e1-a132-44e9-b435-a6e1c8e83bab
X-Auth-Token: 94dfc852-6aa3-4584-b383-02d0b5fb503a
X-Server-Management-Url: https://servers.api.rackspacecloud.com/v1.0/502395
Content-Length: 0
Connection: close
Content-Type: application/octet-stream

GET /v1/MossoCloudFS_0688d3e1-a132-44e9-b435-a6e1c8e83bab/freshinstallfiles?format=xml&path= HTTP/1.1
X-Auth-Token: 94dfc852-6aa3-4584-b383-02d0b5fb503a
User-Agent: Cyberduck/4.0b5 (7454) (Windows 7/6.1) (amd64)
Host: storage101.dfw1.clouddrive.com

HTTP/1.1 200 OK
HTTP/1.1 200 OK
X-Container-Object-Count: 0
X-Container-Bytes-Used: 0
Content-Length: 87
Content-Type: application/xml; charset=utf8
Date: Tue, 02 Nov 2010 19:10:21 GMT

Here is the log from when I tried to upload a filed call SecurityFAQ.docx and it is 16 Kilobytes.

GET /v1.0 HTTP/1.1
x-auth-user: 
x-auth-key: 
User-Agent: Cyberduck/4.0b5 (7454) (Windows 7/6.1) (amd64)
Host: auth.api.rackspacecloud.com

HTTP/1.1 204 No Content
HTTP/1.1 204 No Content
Date: Tue, 02 Nov 2010 19:18:10 GMT
Server: Apache/2.2.3 (Mosso Engineering)
X-Storage-Url: https://storage101.dfw1.clouddrive.com/v1/MossoCloudFS_0688d3e1-a132-44e9-b435-a6e1c8e83bab
X-Storage-Token: 94dfc852-6aa3-4584-b383-02d0b5fb503a
X-CDN-Management-Url: https://cdn1.clouddrive.com/v1/MossoCloudFS_0688d3e1-a132-44e9-b435-a6e1c8e83bab
X-Auth-Token: 94dfc852-6aa3-4584-b383-02d0b5fb503a
X-Server-Management-Url: https://servers.api.rackspacecloud.com/v1.0/502395
Content-Length: 0
Connection: close
Content-Type: application/octet-stream

GET /v1/MossoCloudFS_0688d3e1-a132-44e9-b435-a6e1c8e83bab/isos?format=xml&path= HTTP/1.1
X-Auth-Token: 94dfc852-6aa3-4584-b383-02d0b5fb503a
User-Agent: Cyberduck/4.0b5 (7454) (Windows 7/6.1) (amd64)
Host: storage101.dfw1.clouddrive.com

HTTP/1.1 200 OK
HTTP/1.1 200 OK
X-Container-Object-Count: 17
X-Container-Bytes-Used: 3274958791
Content-Length: 4217
Content-Type: application/xml; charset=utf8
Date: Tue, 02 Nov 2010 19:18:10 GMT

Please let me know if you need me to provide anything else.

Matt Costello Rackspace Cloud

Last edited on Nov 2, 2010 at 9:22:11 PM by dkocher (previous) (diff)

comment:3 Changed on Nov 2, 2010 at 9:25:51 PM by dkocher

That should be followed by a PUT which is missing. Can you attach cyberduck.log in AppData/Roaming/Cyberduck of your home directory.

comment:4 Changed on Nov 2, 2010 at 10:28:22 PM by jetsinboxes

I tried to attach my cyberduck.log file however your site has a 256k upload limit and my log is 562k. Please download the log file via my CloudFiles CDN URL: http://c0028336.cdn1.cloudfiles.rackspacecloud.com/cyberduck.log

Let me know if I can provide anything else.

Matt Costello Rackspace Cloud

comment:5 in reply to: ↑ 2 Changed on Nov 3, 2010 at 12:25:28 PM by dkocher

Replying to jetsinboxes:

Here is the log from when I tried to upload a filed call 311.zip and it is 7 megs.

GET /v1.0 HTTP/1.1
x-auth-user: 
x-auth-key: 
User-Agent: Cyberduck/4.0b5 (7454) (Windows 7/6.1) (amd64)
Host: auth.api.rackspacecloud.com

Your user and secret key is not set. Was there no login prompt? Check your username in the bookmark setting.

comment:6 Changed on Nov 3, 2010 at 10:12:49 PM by jetsinboxes

dkocher,

I apologize for not warning you of this in advance but for security reasons I purposely took out all remnants of x-auth-user: and x-auth-key: Since this is a publicly viewable ticketing system I did not want to give out my credentials. I am sure you can understand where I am coming from on this. I am happy to provide any additional resources to assist in troubleshooting this.

Matt Costello Rackspace Cloud

comment:7 Changed on Nov 3, 2010 at 10:26:38 PM by yla

Do you have any chance to try to reproduce this on the Mac version of Cyberduck?

comment:8 Changed on Nov 4, 2010 at 1:42:00 AM by jetsinboxes

Yla,

I was able to successfully upload a 1.4 gigabyte file to my CloudFiles account using CyberDuck on MAC.

Matt Costello Rackspace Cloud

comment:9 Changed on Nov 4, 2010 at 2:00:13 AM by jetsinboxes

Yla,

BTW that was using version 3.7 for mac.

Matt Costello Rackspace Cloud

comment:10 Changed on Nov 4, 2010 at 9:28:35 AM by dkocher

Can you upload to servers that are not using the CloudFiles protocol? Should find out if this is a general issue with uploads for you or specific to CloudFiles.

comment:11 Changed on Nov 10, 2010 at 12:41:44 AM by jetsinboxes

Yes I can upload to other servers just not to Cloud Files. The interesting thing is that I installed this on a machine that has never had CyberDuck installed and it worked fine without issue. Although the three machines that have had CyberDuck since B1 are all unable to upload to CloudFiles. Perhaps these installations have become corrupt? In addtion I have tried uninstalling Cyberduck from all three machines, rebooting, and then reinstalling with no success. I tried uploading from B1 which did not work, and then I let the software update to B5 and it still did not upload to CloudFiles. All three of these machines all run Windows 7 and all connect to CloudFiles and can see the data in the containers. I just cannot upload or download content. Any other things you guys would like me to try out?

Matt Costello Rackspace Cloud

comment:12 Changed on Nov 10, 2010 at 1:30:39 AM by jetsinboxes

dkocher,

I failed to mention that when I did the clean install it was on Windows XP using the XP mode of Windows 7. So I can successfully install any version cyberduck and upload successfully to CloudFiles using Windows XP but not from any Windows 7 enabled machine. I've also had several other Rackers install CyberDuck on various Windows 7 machines and none can upload successfully to CloudFiles they can only see their data and containers within their Cloud Files accounts. We've also just installed this on a clean Windows XP box and we were able to successfully upload to Cloud Files. This is new information that I just found out myself. I apologize for not providing this in the earlier post. I hope this helps!!

Matt Costello Rackspace Cloud

comment:13 Changed on Nov 11, 2010 at 4:15:35 AM by jetsinboxes

I just wanted to update you that I am no longer experiencing this on any Windows 7, and XP as of the latest b6. Do you have a location where you post the latest build in exe instead of updating from b1 to newest when installing on clean virtual boxes during my testing? I have an MSDN license so I'd like to test this in all versions and a latest build exe could ease testing. Thanks for all of the hard work!

Matt Costello Rackspace Cloud

comment:14 Changed on Nov 11, 2010 at 6:24:20 AM by yla

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for your update. That's good to know but as far as I can remember I did not change anything in this area. I have to go through the last commits. Feel free to reopen the ticket whenever you should encounter this issue again. You will get a direct link in separate mail.

comment:15 Changed on Nov 11, 2010 at 9:36:54 AM by dkocher

  • Milestone changed from 4.0 to 4.0b6
Note: See TracTickets for help on using tickets.
swiss made software