Cyberduck Mountain Duck CLI

#5396 closed defect (fixed)

SFTP errors not being reported

Reported by: https://www.google.com/accounts/o8/id?id=aitoawng0mubul6w1lwi-_asmp86l3vkj-uzo3y Owned by: dkocher
Priority: highest Milestone: 4.0b8
Component: sftp Version: 4.0b5
Severity: blocker Keywords:
Cc: Architecture: Intel
Platform: Windows 7

Description

I know you have chosen not to display the log for SFTP, but you have asked me to beta test this product and I consider the log to be a critical part of the system, not a nice to have. How can you troubleshoot bugs without adequate reporting and logging? I would not consider using this software when it shows a folder as being empty where it has actually got 1300 files in it, and no indication that there was a problem or error.

At the very least, put up a warning that you could not read the folder contents.

Attachments (1)

cyberduck.log (66.3 KB) - added by https://www.google.com/accounts/o8/id?id=aitoawng0mubul6w1lwi-_asmp86l3vkj-uzo3y on Nov 3, 2010 at 5:32:54 PM.
Log of failed directory access

Download all attachments as: .zip

Change History (18)

comment:1 Changed on Nov 2, 2010 at 3:24:23 PM by dkocher

The folder if not accessible should have a one-way icon drawn over the folder icon. Missing SFTP logging is in #2944.

comment:2 follow-ups: Changed on Nov 2, 2010 at 4:32:38 PM by https://www.google.com/accounts/o8/id?id=aitoawng0mubul6w1lwi-_asmp86l3vkj-uzo3y

The folder looks and behaves exactly like an empty folder - except that it should have 1300 files in it. Other (smaller) folders in the same location work correctly, but this one does not. It has a + sign at the side, I click this and it changes to -, click again and it goes back to + - everything works perfectly except there should be 1300 files listed.

The issue here is not why the files are not showing (that's a separate ticket), but why it does not say there's a problem.

I have seen 2944 - that is why I raised a DEFECT report as I consider this is a blocking defect - I will not consider using software which does not report problems.

Also, I do not see how we can identify why it is not showing those files without seeing the log or at least an error report - that is why I have given this a higher priority than the other ticket.

Regards

John

comment:3 in reply to: ↑ 2 Changed on Nov 3, 2010 at 1:50:33 PM by dkocher

Replying to https://www.google.com/accounts/o8/id?id=aitoawng0mubul6w1lwi-_asmp86l3vkj-uzo3y:

It has a + sign at the side, I click this and it changes to -, click again and it goes back to + - everything works perfectly except there should be 1300 files listed.

That indicates the folder is missing read attributes. Check using File → Info → Permissions.

comment:4 in reply to: ↑ 2 Changed on Nov 3, 2010 at 2:12:00 PM by dkocher

Replying to https://www.google.com/accounts/o8/id?id=aitoawng0mubul6w1lwi-_asmp86l3vkj-uzo3y:

I have seen 2944 - that is why I raised a DEFECT report as I consider this is a blocking defect - I will not consider using software which does not report problems.

Problems accessing directories is not reported with an error message but indicated with the overlay icon on the folder instead.

  • source:/trunk/img/dropfolderbadge.png Drop folder with no read right
  • source:/trunk/img/privatefolderbadge.png No executable bit set or read attempt failed
  • source:/trunk/img/readonlyfolderbadge.png No write permission.
Last edited on Nov 3, 2010 at 2:12:59 PM by dkocher (previous) (diff)

comment:5 Changed on Nov 3, 2010 at 2:15:06 PM by dkocher

See also #5395.

comment:6 Changed on Nov 3, 2010 at 4:17:42 PM by https://www.google.com/accounts/o8/id?id=aitoawng0mubul6w1lwi-_asmp86l3vkj-uzo3y

File Info shows permissions 766 - full read/write permissions. The calculate size button shows the size as 0 Bytes.

There are no overlay icons on this folder.

Other SFTP clients running on this PC with the same credentials can see 1300 + files in this folder. Cyberduck can see files in other folders on the same server, but this one shows as empty.

There is a fair chance the problem here is that the remote server is returning invalid information, but we will never know until we can see a meaningful error message or status log.

comment:7 Changed on Nov 3, 2010 at 4:21:31 PM by dkocher

Can you post the debug cyberduck.log file that is included in these beta builds in AppData/Cyberduck of your home folder.

Changed on Nov 3, 2010 at 5:32:54 PM by https://www.google.com/accounts/o8/id?id=aitoawng0mubul6w1lwi-_asmp86l3vkj-uzo3y

Log of failed directory access

comment:8 Changed on Nov 3, 2010 at 5:36:13 PM by https://www.google.com/accounts/o8/id?id=aitoawng0mubul6w1lwi-_asmp86l3vkj-uzo3y

The full log was rather large so this is a new file - just shows startup, viewing one folder which works, viewing failing folder, then doing file info on failing folder.

John

comment:9 Changed on Nov 4, 2010 at 1:34:05 PM by dkocher

The culprit is

2010-11-03 17:26:21,668 [pool-1-thread-2] WARN  ch.cyberduck.core.sftp.SFTPPath - Listing directory failed:Illegal sftp packet len: 71587

This looks like a duplicate of either #5308 or #3395.

comment:10 follow-up: Changed on Nov 4, 2010 at 2:11:17 PM by https://www.google.com/accounts/o8/id?id=aitoawng0mubul6w1lwi-_asmp86l3vkj-uzo3y

That may well be the answer to #5395 (which is indeed a duplicate of #5308, except on Windows instead of Mac), but this ticket is about why the software does not correctly report the issue. The folder is shown as empty, not faulty. If there is an error in the data being returned from the server, you should say there is an error and say what it is, not incorrectly show the folder as empty.

As far as I am concerned, the inability to report an error is far more serious than the failure to handle it - which is why this ticket was flagged as higher priority than #5395. Once we get the client telling us what it thinks the error is, we can ask the server supplier to fix it. As Cyberduck is the only client which thinks this is an error, we cannot use another client to generate the report so the server supplier just ignores our requests.

Regards

John

Last edited on Nov 4, 2010 at 2:45:04 PM by dkocher (previous) (diff)

comment:11 in reply to: ↑ 10 Changed on Nov 4, 2010 at 2:53:05 PM by dkocher

Replying to https://www.google.com/accounts/o8/id?id=aitoawng0mubul6w1lwi-_asmp86l3vkj-uzo3y:

That may well be the answer to #5395 (which is indeed a duplicate of #5308, except on Windows instead of Mac), but this ticket is about why the software does not correctly report the issue. The folder is shown as empty, not faulty. If there is an error in the data being returned from the server, you should say there is an error and say what it is, not incorrectly show the folder as empty.

As I mentioned above, you *should* get the private badge on the folder after reading the directory fails. That does not seem to be the case which is a bug.

As far as I am concerned, the inability to report an error is far more serious than the failure to handle it - which is why this ticket was flagged as higher priority than #5395. Once we get the client telling us what it thinks the error is, we can ask the server supplier to fix it. As Cyberduck is the only client which thinks this is an error, we cannot use another client to generate the report so the server supplier just ignores our requests.

Direct them to #5308 including your cyberduck.log which has the SFTP packets sent and received.

Regards

John

comment:12 Changed on Dec 1, 2010 at 4:14:00 PM by yla

  • Resolution set to fixed
  • Status changed from new to closed

In r7887.

comment:13 Changed on Dec 1, 2010 at 4:14:20 PM by yla

  • Milestone set to 4.0b8

comment:14 follow-up: Changed on Dec 8, 2010 at 11:07:25 PM by https://www.google.com/accounts/o8/id?id=aitoawng0mubul6w1lwi-_asmp86l3vkj-uzo3y

This is marginaly better - if you have sharp eyes, you might notice a little symbol on the folder - but your icons are so small to start with, it's hard to see. You also do not say anywhere obvious what the icon means, so I still click on it to see what happens - and it still says there are no files in the folder.

THIS IS CRAP!

Cyberduck looks like a really useful product for us as we move towards S3, but if it cannot handle errors with any sort of common sense approach, it's useless. If I recomended this to my clients I would be spending half my life explaining to them that there really are files in this folder - and if I said you can see them using almost any other ftp client, they're going to ask me why I recommend this one.

Stop being arrogant and saying 'its not our fault', and try fixing it - nobody else seems to have a problem with that approach.

Regards John

comment:15 in reply to: ↑ 14 Changed on Dec 9, 2010 at 10:03:18 AM by dkocher

Replying to https://www.google.com/accounts/o8/id?id=aitoawng0mubul6w1lwi-_asmp86l3vkj-uzo3y:

This is marginaly better - if you have sharp eyes, you might notice a little symbol on the folder - but your icons are so small to start with, it's hard to see. You also do not say anywhere obvious what the icon means, so I still click on it to see what happens - and it still says there are no files in the folder.

There is always room for improvement. In that particular case we'll see to make these overlay icons more crisp.

THIS IS CRAP!

Cyberduck looks like a really useful product for us as we move towards S3, but if it cannot handle errors with any sort of common sense approach, it's useless. If I recomended this to my clients I would be spending half my life explaining to them that there really are files in this folder - and if I said you can see them using almost any other ftp client, they're going to ask me why I recommend this one.

Before writing a rant here it might be a better idea to fix the original issue which is described in #5308. You will not have this issue with S3 as its an entirely different protocol over HTTP.

Stop being arrogant and saying 'its not our fault', and try fixing it - nobody else seems to have a problem with that approach.

My stand is still that it might be a better idea to fix the root cause and not implement a workaround. Time is limited, therefore I first fix my own bugs and not implementing workarounds for thirdparty issues that might have other side effects and break the protocol specification.

Regards John

comment:16 Changed on Dec 9, 2010 at 11:35:04 AM by https://www.google.com/accounts/o8/id?id=aitoawng0mubul6w1lwi-_asmp86l3vkj-uzo3y

OK, so the server manufacturer is as arrogant as you, and say their server works with every other client and they cannot be expected to support every rag-tag start-up that comes along. Unfortunately the server is not ours, it belongs to one of our clients who also say that it works with every other client they have tried. This is a mainstream server manufacturer, used in some of the worlds biggest companies - it's not in beta, they are not asking for comment on a new system, they are selling a mature product with a large user base. If you want to penetrate that user base, you will need to provide a client which works with their server.

BUT

Whatever causes the problem, the fact that I can click on the folder and be told it is empty is wrong. Just change it so it says 'there was an error loading this folder' - and preferably give some sort of explanation or error code. Saying it is empty is telling lies.

Even disable click on a folder with an error icon, pop up a error message, anything except saying it is empty.

You ask me to beta test this software, and when I report a problem you tell me there's nothing wrong. I am not currently using Cyberduck, not because of this problem but because you refuse to admit it exists - how many more bugs are there in it which you do not admit to? I certainly cannot recomend it to my colleagues or clients as it would undermine my credibility. In a very crowded Windows marketplace, you need to provide a service which people can recommend with confidence. At present you cannot compete with the likes of cuteFTP (which is made by the same people as make the server, so it definitely does not have this problem).

comment:17 Changed on Dec 11, 2010 at 4:51:53 PM by dkocher

Added reference to this issue in the wiki documentation.

Note: See TracTickets for help on using tickets.
swiss made software