Cyberduck Mountain Duck CLI

#5403 closed defect (fixed)

SFTP and trailing slash in Web URL

Reported by: hcabbos Owned by: dkocher
Priority: high Milestone: 3.8
Component: sftp Version: 4.0b5
Severity: normal Keywords:
Cc: Architecture: PPC
Platform: Mac OS X 10.5

Description

This incident is for SFTP. I don't know if FTP is behaving the same way.

Cyberduck is forcing the trailing slash for the *Web URL*. If I remove it and close the prefs window and then return, the slash is put back. This screws up the Web URL as it enters 2 forward slashes right after the .com when using the copy url feature.

For instance, I get: http://mydomain.com//myfolder

And note that my *Server Path* is correct. I've tried it with or without an end slash, for Server Path (not Web Path) and the problem persists.

Cyberduck shouldn't be demanding the end slash for Web URL. Please fix this :(

Change History (7)

comment:1 Changed on Nov 9, 2010 at 5:54:15 PM by dkocher

Can you replicate the issue in the latest snapshot build available from the software update?

comment:2 Changed on Nov 10, 2010 at 5:58:32 AM by hcabbos

Yes, the problem is stil present with the latest snapshot.

comment:3 Changed on Nov 15, 2010 at 11:30:28 AM by dkocher

Testcase in r7587.

comment:4 Changed on Nov 15, 2010 at 4:11:39 PM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

Fix in r7588.

comment:5 Changed on Nov 15, 2010 at 6:32:19 PM by hcabbos

I wouldn't know how to get r7588 to test it. As of 7572, it was still broken.

comment:6 Changed on Nov 16, 2010 at 7:50:39 PM by dkocher

Please switch to the latest snapshot build for testing.

comment:7 Changed on Nov 24, 2010 at 8:32:21 PM by hcabbos

Just downloaded Version 4.0b7 (7761). This issue has been fixed. Thank you!

Note: See TracTickets for help on using tickets.
swiss made software