Cyberduck Mountain Duck CLI

#548 closed defect (worksforme)

IO Error: read timed out on Upload

Reported by: shannon@… Owned by: cyberduck
Priority: high Milestone:
Component: ftp Version: 2.4.6
Severity: major Keywords:
Cc: Architecture:
Platform: Mac OS X 10.6

Description

When trying to upload files to a server I get the error "IO Error: Read Timed Out" or "IO Error: Operation Timed Out". The file name I tried to upload will show up in the directory, but will display "0 kb". I CAN download files from the server though. This problem is only occurring for two of the four domains I maintain - all hosted by the same company.

When I called the tech support at our web host, they discovered that the two domains that I CAN upload to are older "discreet platform" servers. The two domains that I CAN"T upload to are the newer "cluster platform" servers.

Do you have any insight on why I am unable to upload files, but can still connect and download files from a site hosted on a cluster server?

Also, I have tried using two other FTP programs to upload and they all react the same as Cyberduck does...

Please help if you have any suggestions!

Thanks.

Shannon-

Change History (7)

comment:1 Changed on Jul 15, 2006 at 11:52:23 AM by dlspaude@…

I also get the same problem (Mac OS X 10.4.7 (and 10.4.6), dial-up modem connection, Cyberduck 2.6 (2315)). If I use the command line ftp executable it works just fine. The file size I was using was 85 KB and Cyberduck would only upload 53 KB of the file before it failed. I suspect it is a dial-up modem connection (slow connection compared to broadband) issue where Cyberduck is seeing a stall for an extended periond of time. FTP shows a -stalled- message, but it must wait long enough before aborting the upload.

Any ideas?

comment:2 Changed on Jul 15, 2006 at 8:02:48 PM by anonymous

We solved our problem by updating our router's firmware. It was a Linksys router and the latest firmware update solved all of our issues with uploading files to a web server.

comment:3 Changed on Aug 15, 2006 at 1:14:54 PM by anonymous

I also solved the problem by updating to the latest Linksys firmware. The files are fully uploaded now, but I still get I/O errors.

comment:4 Changed on Dec 21, 2006 at 10:37:16 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

comment:6 follow-up: Changed on Apr 19, 2010 at 1:19:25 AM by zeussama@…

My problem is a bit different. I can login to FTP and browse the files, but unable to download or upload files. However, I use other FPT app, In this case Forklift, guest what it's WORKS just fine.

I thought it was firewall, but looks like it's Cyberduck faulty.

Cyberduck 3.4.2

Here's the error transcript: 200 Zzz... TYPE I 200 TYPE is now 8-bit binary PORT 192,168,0,100,202,52 200 PORT command successful RETR robots.txt 425 Could not open data connection to port 11673: Connection timed out

The port number always changing.

comment:7 in reply to: ↑ 6 Changed on Apr 20, 2010 at 4:02:12 PM by dkocher

  • Platform set to Mac OS X 10.6

Replying to zeussama@…:

Choose Passive (PASV) for the Connect Mode in the bookmark setting.

Note: See TracTickets for help on using tickets.
swiss made software