Cyberduck Mountain Duck CLI

#5481 closed defect (duplicate)

FTP problems with chmod GUI window on connections to pureftpd server

Reported by: https://www.google.com/accounts/o8/id?id=aitoawmvdelpssenl8kvueq2zkgru7zsm5q1ls4 Owned by:
Priority: normal Milestone: 3.8
Component: ftp Version: 3.7
Severity: normal Keywords: chmod ftp
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description

When I try to change permissions to a file the gui window does not work properly.

Let's say one of the checkboxes -example group write- is unchecked and I want to check it. As soon as a check, it goes very fast to checked and unchecked again. It changes its state as I click but inmediatly is reverted to previous state. That makes me think the changes had not been applied. If I close the file information window and I open it again, it continues showing old permissions. Only when I logout and login again I can see the correct new permission I have applied.

It is really anoying. If I change more than one permission at a time, I think only the last one I click changes its value. And I'm always seeing old permissions so it is very difficult to know which permissions I'm really setting.

I'm not sure if I'm able to explain it properly. It's really very strange behaviour.

The server I'm connecting to is a http://www.pureftpd.org/ server.

Problem appears with FTP and FTPS connections to that server. It is not happening on SFTP connections to that server.

Cyberduck FTP and FTPS chmod gui window (information window) on connections to other servers works fine, so I suppose it is something that appears on that specific server, pure-ftpd.

The server has no problem to chmod files with FTP. I have tested the connection from a terminal and all works fine.

The only problem is that strange behaviour on the gui cyberduck interface to change permissions when connected to pure-ftpd server.

Change History (1)

comment:1 Changed on Nov 29, 2010 at 9:17:25 PM by dkocher

  • Component changed from core to ftp
  • Milestone set to 3.8
  • Resolution set to duplicate
  • Status changed from new to closed

I suppose that is a duplicate of #5378. Please try the latest beta build available.

Note: See TracTickets for help on using tickets.