Cyberduck Mountain Duck CLI

#5503 closed defect (fixed)

Wrong filesize for upload displayed

Reported by: davidmaurer Owned by: dkocher
Priority: normal Milestone: 3.8.1
Component: core Version: 3.8
Severity: normal Keywords: Upload problems
Cc: Architecture: PPC
Platform: Mac OS X 10.5

Description

When uploading files to ftp server via cyberduck, after update to 3.8, it shows filesize always with 4,0 (or 4,1) GB. But I was uploading a 48,0 MB file. I tested various files with different sizes. It shows always a filesize of 4,0 GB. Upload doesnt progress after the actual filesize is reached (e.g. 48,0 MB), and will not be completed. No file does appear on my FTP Server.

Attachments (1)

Bild 11.png (25.8 KB) - added by davidmaurer on Dec 4, 2010 at 9:53:22 AM.

Download all attachments as: .zip

Change History (13)

Changed on Dec 4, 2010 at 9:53:22 AM by davidmaurer

comment:1 Changed on Dec 4, 2010 at 5:44:08 PM by tijn1978

I have exactly the same issue when uploading files in Version 3.8 (7920)

comment:2 Changed on Dec 4, 2010 at 6:12:14 PM by dkocher

  • Milestone set to 4.0
  • Owner set to dkocher
  • Status changed from new to assigned

Bug must have been introduced in r7696.

comment:3 Changed on Dec 5, 2010 at 4:08:07 AM by lrkirsch

After updating to version 3.8, I also experienced the filesize problem when uploading to my Amazon S3 bucket. (I never tried FTP.) So I went back to 3.7, and all is well again. I'm still using OS 10.5.8 if that might matter.

comment:4 Changed on Dec 5, 2010 at 7:08:32 AM by depourtales

Same issue on 10.5.8 and v3.8 using FTPS transfers. Anyway, all the transfers finish and the files are correctly saved on the target FTPS folder. Uploads are marked as finished

comment:5 Changed on Dec 5, 2010 at 12:06:57 PM by dkocher

  • Platform set to Mac OS X 10.5

comment:6 Changed on Dec 5, 2010 at 3:54:48 PM by dkocher

  • Architecture set to PPC

The root cause of the issue is tracked in Rococoa Issue #3.

comment:7 Changed on Dec 5, 2010 at 3:55:15 PM by dkocher

Can you confirm you are running this on a PowerPC (PPC) Mac?

comment:8 Changed on Dec 5, 2010 at 4:02:41 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r7929.

comment:9 Changed on Dec 5, 2010 at 4:21:32 PM by dkocher

Please try the latest snapshot build available.

comment:10 Changed on Dec 5, 2010 at 10:52:41 PM by davidmaurer

last snapshot build (7929) did fix it! thank you very much. Bye the way: Forgot to set "architecture" correctly: It is Intel based MacBook Pro.

comment:11 Changed on Dec 6, 2010 at 5:01:47 PM by dkocher

  • Milestone changed from 4.0 to 3.8.1

comment:12 Changed on Dec 6, 2010 at 5:14:15 PM by dkocher

  • Summary changed from wrong filesize while upload displayed in 3.8 to Wrong filesize for upload displayed
Note: See TracTickets for help on using tickets.
swiss made software