Cyberduck Mountain Duck CLI

#5552 closed defect (fixed)

Can't open new browser window or Quit

Reported by: https://www.google.com/accounts/o8/id?id=aitoawnwmtjgchda9vhhftgwqml7a-qdoge0cf4 Owned by:
Priority: highest Milestone: 4.0
Component: core Version: 4.0b8
Severity: normal Keywords:
Cc: Architecture:
Platform: Mac OS X 10.6

Description

Updated to version 4.0b8 (8021) and now I can't open a new browser window or quit the program (force quit works, though). I've tried trashing prefs, restarting, and repairing disk permissions. Please help.

Snippet of the log below:

12/13/10 12:16:00 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at ch.cyberduck.ui.cocoa.MainController.newDocument(MainController.java:1133)
12/13/10 12:16:00 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at ch.cyberduck.ui.cocoa.MainController.newBrowserMenuClicked(MainController.java:434)
12/13/10 12:16:00 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
12/13/10 12:16:00 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
12/13/10 12:16:00 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
12/13/10 12:16:00 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at java.lang.reflect.Method.invoke(Method.java:597)
12/13/10 12:16:00 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at org.rococoa.internal.OCInvocationCallbacks.callMethod(OCInvocationCallbacks.java:155)
12/13/10 12:16:00 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		... 27 more
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]	2010-12-13 12:17:38,867 [main] ERROR org.rococoa.callback - Exception calling method for selector newBrowserMenuClicked:
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]	java.lang.reflect.InvocationTargetException
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at java.lang.reflect.Method.invoke(Method.java:597)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at org.rococoa.internal.OCInvocationCallbacks.callMethod(OCInvocationCallbacks.java:155)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at org.rococoa.internal.OCInvocationCallbacks.access$200(OCInvocationCallbacks.java:52)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at org.rococoa.internal.OCInvocationCallbacks$2.callback(OCInvocationCallbacks.java:82)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at sun.reflect.GeneratedMethodAccessor11.invoke(Unknown Source)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at java.lang.reflect.Method.invoke(Method.java:597)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at com.sun.jna.CallbackReference$DefaultCallbackProxy.invokeCallback(CallbackReference.java:384)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at com.sun.jna.CallbackReference$DefaultCallbackProxy.callback(CallbackReference.java:414)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at com.sun.jna.Function.invokeVoid(Native Method)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at com.sun.jna.Function.invoke(Function.java:328)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at com.sun.jna.Function.invoke(Function.java:276)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at org.rococoa.internal.MsgSendHandler.invoke(MsgSendHandler.java:111)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at com.sun.jna.Library$Handler.invoke(Library.java:214)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at $Proxy0.syntheticSendMessage(Unknown Source)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at org.rococoa.Foundation.send(Foundation.java:200)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at org.rococoa.Foundation.send(Foundation.java:187)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at org.rococoa.internal.ObjCObjectInvocationHandler.sendOnThisOrMainThread(ObjCObjectInvocationHandler.java:254)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at org.rococoa.internal.ObjCObjectInvocationHandler.invokeCocoa(ObjCObjectInvocationHandler.java:222)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at org.rococoa.internal.ObjCObjectInvocationHandler.intercept(ObjCObjectInvocationHandler.java:185)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at ch.cyberduck.ui.cocoa.application.NSApplication$$ByRococoa.run(<generated>)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:108)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at java.lang.reflect.Method.invoke(Method.java:597)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at apple.launcher.LaunchRunner.run(LaunchRunner.java:115)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:50)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]	Caused by: java.lang.IllegalArgumentException: Parameter 'directory' is not a directory
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at org.apache.commons.io.FileUtils.listFiles(FileUtils.java:293)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at ch.cyberduck.core.aquaticprime.LicenseFactory.find(LicenseFactory.java:86)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at ch.cyberduck.ui.cocoa.BrowserController.awakeFromNib(BrowserController.java:132)
12/13/10 12:17:38 PM	[0x0-0xa30a3].ch.sudo.cyberduck[885]		at ch.cyberduck.ui.cocoa.BundleController.loadBundle(BundleController.java:64)

Change History (1)

comment:1 Changed on Dec 13, 2010 at 5:34:25 PM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

In r8072.

Note: See TracTickets for help on using tickets.
swiss made software