Cyberduck Mountain Duck CLI

#5618 closed defect (fixed)

Timeout on 501 response

Reported by: casdex@… Owned by: dkocher
Priority: normal Milestone: 4.1
Component: webdav Version: 3.8.1
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description (last modified by dkocher)

It appears as if cyberduck simply times out when it receives a 501 response code to a webdav propfind request. This is most commonly seen when re-launching cyberduck that had previously been connected to a webdav server where it appears cyberduck attempts to open a connection using the previously supplied username but no password. The result is a two minute wait before a prompt for a new username/password is displayed.

Attachments (1)

cyberduck (2.5 KB) - added by casdex@… on Jan 5, 2011 at 7:19:50 PM.
wireshark capture of the described behavior.

Download all attachments as: .zip

Change History (9)

Changed on Jan 5, 2011 at 7:19:50 PM by casdex@…

wireshark capture of the described behavior.

comment:1 Changed on Jan 5, 2011 at 9:35:46 PM by dkocher

  • Description modified (diff)
  • Summary changed from Timeout on 401 response? to Timeout on 501 response

I can replicate this by attempting to connect to the host.

comment:2 Changed on Jan 5, 2011 at 10:17:19 PM by dkocher

The issue is that the XML parser used is trying to resolve the DTD of the system id http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd in the document returned.

We must configure the feature http://apache.org/xml/features/nonvalidating/load-external-dtd to false.

comment:3 Changed on Jan 5, 2011 at 10:29:15 PM by dkocher

You can workaround the issue by not returning a HTML response for authentication failures.

comment:4 Changed on Jan 5, 2011 at 10:34:23 PM by dkocher

  • Milestone set to 4.0
  • Status changed from new to assigned

comment:5 Changed on Jan 25, 2011 at 9:15:43 PM by dkocher

We are working together with the developer of Sardine to replace our current WebDAV implementation.

comment:6 Changed on Jan 25, 2011 at 9:16:01 PM by dkocher

  • Milestone changed from 4.0 to 4.1

comment:7 Changed on May 20, 2011 at 12:13:49 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r8689.

comment:8 Changed on Jun 28, 2011 at 8:25:03 AM by dkocher

New fix applied in Sardine and integrated in r8849.

Note: See TracTickets for help on using tickets.
swiss made software