Cyberduck Mountain Duck CLI

Opened 8 years ago

Closed 7 years ago

#5653 closed defect (fixed)

Proxy connection fails

Reported by: Bburton333 Owned by: dkocher
Priority: normal Milestone: 4.0b9
Component: cloudfiles Version: 4.0b8
Severity: blocker Keywords:
Cc: Architecture:
Platform: Windows 7

Description

Steps to reproduce: From a Bookmark with username and api key configured, right-click and click the Connect to server option. Or, from the Open Connection icon, click and select Rackspace Cloud Files, enter Username and API Access Key.

Results: Almost nothing--there is a green dot on the right side of the bookmark but the Disconnect and Upload buttons remain greyed out. Nothing is displayed in the Log Drawer to indicate a connection was attempted.

Have tried the equivalent in the latest OS X release with success.

Attachments (2)

cyberduck.log (43.1 KB) - added by Bburton333 7 years ago.
Cyberduck_Cloudfiles_bookmark.png (25.7 KB) - added by Bburton333 7 years ago.
Screen shot of Cloud Files Bookmark

Download all attachments as: .zip

Change History (10)

comment:1 Changed 8 years ago by dkocher

Can you please send me by email or attach the content of cyberduck.log See Logging information on Windows.

Changed 7 years ago by Bburton333

comment:2 Changed 7 years ago by dkocher

Thanks for the log.

2011-01-03 13:50:44,977 [pool-1-thread-3] ERROR ch.cyberduck.ui.AbstractController - Excpetion running background task:Scheme 'http' not registered.

For unknown reasons it is trying to use HTTP whereas only HTTPS (with SSL encryption) is configured and allowed to authenticate.

comment:3 Changed 7 years ago by dkocher

  • Milestone set to 4.0b9

comment:4 Changed 7 years ago by dkocher

Can you post a screenshot of your bookmark configuration.

Changed 7 years ago by Bburton333

Screen shot of Cloud Files Bookmark

comment:5 Changed 7 years ago by Bburton333

This issue can be reproduced whether a bookmark or Open Connection is used. In either case, the connection information shows port 443 and the URL starting with https://... See attached screen shot. The cyberduck.log also shows the same error in either case.

comment:6 Changed 7 years ago by dkocher

Second thought on this. Looks like there is a bug when you have a HTTPS proxy configured in your network settings.

comment:7 Changed 7 years ago by dkocher

  • Summary changed from Can't connect with Rackspace Cloud Files to Proxy connection fails

comment:8 Changed 7 years ago by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

In r8235.

Note: See TracTickets for help on using tickets.
swiss made software