Cyberduck Mountain Duck CLI

#5697 closed enhancement (fixed)

Option to skip existing files on folder download

Reported by: Ahmad48124 Owned by: dkocher
Priority: normal Milestone: 4.0
Component: interface Version: 4.0b9
Severity: normal Keywords: folder download mirror dav skip
Cc: Architecture: Intel
Platform: Windows 7

Description

When downloading a folder through WebDAV containing some files that already exist locally, options are given to resume, overwrite, rename, or rename existing. It would be extremely useful if an option to "skip" existing files could be added to the dropdown (fig.2) so that any files in the network folder that don't exist in the local folder would be downloaded, but files that exist locally with the same name would be skipped.

(Basically an option to update a local mirror of a network folder without having to individually uncheck all of the files that already exist locally or overwrite/rename them).

Thanks

Attachments (1)

CD_folder_example_1.jpg (134.6 KB) - added by Ahmad48124 on Feb 10, 2011 at 11:25:28 AM.
Image of folder download dialog

Download all attachments as: .zip

Change History (6)

Changed on Feb 10, 2011 at 11:25:28 AM by Ahmad48124

Image of folder download dialog

comment:1 follow-up: Changed on Feb 10, 2011 at 2:15:29 PM by dkocher

You can achieve this by unchecking the folder (in this case EXAM 3) which will result in all its content to be skipped as well.

comment:2 Changed on Feb 10, 2011 at 3:35:29 PM by Ahmad48124

Last edited on Feb 10, 2011 at 3:37:10 PM by Ahmad48124 (previous) (diff)

comment:3 in reply to: ↑ 1 Changed on Feb 10, 2011 at 3:37:46 PM by Ahmad48124

Replying to dkocher:

You can achieve this by unchecking the folder (in this case EXAM 3) which will result in all its content to be skipped as well.

You are correct in saying that it will skip all of the folder's contents. The problem is that if some of the files in the server folder are present in the local folder, it is not possible to select the folder for download and have it skip any filenames that exist and download only the files that are NOT present in the local folder (but ARE present in the server folder). Currently the only options for this behavior are:

  1. Download each file that is not present locally individually to the target directory (time consuming).

OR

  1. Individually uncheck each file that has the same name as a local file, but leave the parent folder checked (in this case leave EXAM 3 checked, but uncheck each of the individual files inside the EXAM 3 folder in the download dialog; also time consuming).

Better example:

Let's say we have a network folder that looks like this:

/dav/FOLDER1
FILE1.TXT
FILE2.TXT
FILE3.TXT

and a local folder that looks like this:

/local/FOLDER1
FILE1.TXT
FILE2.TXT

Now say we choose to download /dav/FOLDER1 to /local/.

In this case the download prompt will come up saying that FILE1.TXT and FILE2.TXT both exist already, and asks what action to take. Unchecking FOLDER1 aborts the download (it will say complete, but report that zero bytes were downloaded successfully).

The proposed "skip" option would simply ignore both FILE1.TXT and FILE2.TXT (preserving the local copy), and only download FILE3.txt to /local/FOLDER1.


Sorry if my original ticket wasn't clear. This function is extremely useful when new files are added to the server daily and need to be copied to the local mirror without overwriting any changes to existing files since they were downloaded or ending up with several renamed copies of the same file.

It's the same concept as merging two local folders on a Windows machine. Windows gives the option of renaming, overwriting, or skipping files, so I'd love to see this functionality in CyberDuck as well :)

Thanks again

comment:4 Changed on Feb 12, 2011 at 8:11:56 PM by dkocher

  • Milestone changed from 4.0b10 to 4.0
  • Status changed from new to assigned

The skip option was removed in r5623. We may want to revert that because of the explanation above.

comment:5 Changed on Feb 28, 2011 at 1:32:48 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

Duplicate for #1159. Regression fixed in r8411.

Note: See TracTickets for help on using tickets.