Cyberduck Mountain Duck CLI

#5713 closed defect (fixed)

Transfer do not complete for larger files (1GB)

Reported by: lee.norman@… Owned by: dkocher
Priority: normal Milestone: 4.0.2
Component: ftp-tls Version: 4.0.2
Severity: normal Keywords: incomplete transfer
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description (last modified by dkocher)

Hi -

I commonly transfer 1GB+ files from my FTP server to my home computer using cyberduck. Recently I have changed to TLS and it seems that most of the transfer stopped (without error on the transfer window) and i cannot even resumed it. The transfer usually stopped at ~700ishh MB mark for the file.

What's even stranger is that if I transfer the file again (not using resume)... it will start again and goes to completion.

For smaller 300-400MB files, they are OK. I am at a lost as to what supporting logs to give you. I would love some guidance on what additional information you need.

This has been causing alot of issues since I don't know the file is not completed ... and I have deleted the original on the server. This have lead to a few lost files. Looking forward to your investigation of the problem.

Attachments (5)

SFT failed transfer.jpg (217.5 KB) - added by lee.norman@… on Feb 20, 2011 at 10:45:30 AM.
Showing the file size and transfer window mismatch after SFTP indicated transfer to be finished
cyberduck ticket.rtf (31.4 KB) - added by lee.norman@… on Feb 23, 2011 at 1:33:20 PM.
transfer draw log
cyberduck options.tiff (77.3 KB) - added by lee.norman@… on Feb 23, 2011 at 1:57:05 PM.
connection option setting in preferences.
illegalPortCmd.txt (42.3 KB) - added by lee.norman@… on Mar 19, 2011 at 11:30:19 PM.
transcript from log draw that are port of the illegal port command.
illegal port.txt (6.0 KB) - added by lee.norman@… on Mar 27, 2011 at 2:32:19 PM.
transcript from log draw that are port of the illegal port command. after upgrade to 4.0.2

Download all attachments as: .zip

Change History (34)

Changed on Feb 20, 2011 at 10:45:30 AM by lee.norman@…

Showing the file size and transfer window mismatch after SFTP indicated transfer to be finished

comment:1 Changed on Feb 20, 2011 at 10:49:17 AM by lee.norman@…

1/ I have added a screen shot of the file size on the server, the file transfer window indicate the file have completed and the actual size on disk.

2/The FTP server is running ProFTPD 1.3.3a Server

Please tell me what additional information that you need.

comment:2 Changed on Feb 20, 2011 at 11:26:55 AM by dkocher

  • Summary changed from SFTP file transfer do not complete for larger files (1GB) and still show as green on transfer window to Transfer do not complete for larger files (1GB)

comment:3 Changed on Feb 20, 2011 at 3:24:59 PM by dkocher

  • Keywords SFTP removed

Things to try:

  • Update to the latest ProFTPd release. Currently 1.3.3d.
  • Update to the latest snapshot build of Cyberduck which has a new FTP implementation.
  • Post the transcript from the log drawer of the Transfers window.

comment:4 Changed on Feb 22, 2011 at 6:48:45 AM by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed

Please reopen if still an issue after following the steps above.

comment:5 Changed on Feb 22, 2011 at 7:27:25 AM by lee.norman@…

I will update with the log drawer in the next day or so. There are no large files to transfer for the last day or so.

comment:6 Changed on Feb 23, 2011 at 1:28:33 PM by lee.norman@…

  • Resolution thirdparty deleted
  • Status changed from closed to reopened

comment:7 Changed on Feb 23, 2011 at 1:32:46 PM by lee.norman@…

I have uploaded the transcript from the log drawer. These are the sections of the log where most of the files transferred is failed in the described way... actually, might be all of them.

The exception is the transfer of *Kuroshitsuji* which is a restart which the original transfer prematurely terminated.

another point of note is that all of these transfer pretty much start at the same time.

I have also attached the screen shot of my preference setting. network error retry is set to 9 times

Thanks.

Last edited on Feb 23, 2011 at 2:05:13 PM by lee.norman@… (previous) (diff)

Changed on Feb 23, 2011 at 1:33:20 PM by lee.norman@…

transfer draw log

Changed on Feb 23, 2011 at 1:57:05 PM by lee.norman@…

connection option setting in preferences.

comment:8 Changed on Feb 27, 2011 at 10:03:41 PM by lee.norman@…

Hi - I also notice that this problem occurs more often when I have 8-9 files transferring concurrently. If I do 1 or 2 at a time, it happens much less often. Don't know if this helps.

comment:9 Changed on Mar 4, 2011 at 10:09:21 PM by lee.norman@…

hi - any thoughts on this problem? it is still consistently happening please see if I can provide more information. thanks.

comment:10 follow-up: Changed on Mar 13, 2011 at 3:19:15 PM by dkocher

Can you find any related output in the system.log (/Applications/Utilities/Console.app)? Also, please update to the latest 4.0 release available.

comment:11 Changed on Mar 15, 2011 at 9:00:07 PM by dkocher

  • Description modified (diff)
  • Milestone set to 4.0.2
  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:12 Changed on Mar 15, 2011 at 9:14:54 PM by lee.norman@…

I have been using 4.0.1 still with the same problem but less frequent, I will try with 4.0.2, but where can I download it? thanks.

Last edited on Mar 15, 2011 at 9:15:46 PM by lee.norman@… (previous) (diff)

comment:13 Changed on Mar 15, 2011 at 9:16:16 PM by lee.norman@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:14 in reply to: ↑ 10 ; follow-up: Changed on Mar 16, 2011 at 12:41:33 PM by lee.norman@…

Replying to dkocher:

Can you find any related output in the system.log (/Applications/Utilities/Console.app)? Also, please update to the latest 4.0 release available.

some error in the system.log. I have clear the log file last night with weekly cron. only have today's log. This is on v4.0.1

Error 1 : `There are numerous errors like this one

Mar 16 22:39:15 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 2011-03-16 22:39:15,658 [background-92] ERROR ch.cyberduck.ui.cocoa.model.FinderLocal - No such file:/Volumes/usbshare1/seedbox/fileABC 2011.03.06/fileABC 2011.03.06.wmv

Error 2: Only one instance in the last 24 hrs.

Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 2011-03-16 22:24:07,129 [main] ERROR org.rococoa.callback - Exception calling method for selector clearButtonClicked:
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: java.lang.reflect.InvocationTargetException
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at java.lang.reflect.Method.invoke(Method.java:597)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.internal.OCInvocationCallbacks.callMethod(OCInvocationCallbacks.java:155)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.internal.OCInvocationCallbacks.access$200(OCInvocationCallbacks.java:52)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.internal.OCInvocationCallbacks$2.callback(OCInvocationCallbacks.java:82)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at sun.reflect.GeneratedMethodAccessor14.invoke(Unknown Source)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at java.lang.reflect.Method.invoke(Method.java:597)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at com.sun.jna.CallbackReference$DefaultCallbackProxy.invokeCallback(CallbackReference.java:384)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at com.sun.jna.CallbackReference$DefaultCallbackProxy.callback(CallbackReference.java:414)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at com.sun.jna.Function.invokeVoid(Native Method)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at com.sun.jna.Function.invoke(Function.java:328)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at com.sun.jna.Function.invoke(Function.java:276)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.internal.MsgSendHandler.invoke(MsgSendHandler.java:111)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at com.sun.jna.Library$Handler.invoke(Library.java:214)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at $Proxy0.syntheticSendMessage(Unknown Source)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.Foundation.send(Foundation.java:200)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.Foundation.send(Foundation.java:187)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.internal.ObjCObjectInvocationHandler.sendOnThisOrMainThread(ObjCObjectInvocationHandler.java:254)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.internal.ObjCObjectInvocationHandler.invokeCocoa(ObjCObjectInvocationHandler.java:222)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.internal.ObjCObjectInvocationHandler.intercept(ObjCObjectInvocationHandler.java:185)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at ch.cyberduck.ui.cocoa.application.NSApplication$$ByRococoa.run(<generated>)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:119)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at java.lang.reflect.Method.invoke(Method.java:597)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at apple.launcher.LaunchRunner.run(LaunchRunner.java:116)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:51)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: Caused by: java.util.ConcurrentModificationException
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at java.util.AbstractList$Itr.checkForComodification(AbstractList.java:372)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at java.util.AbstractList$Itr.next(AbstractList.java:343)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at ch.cyberduck.ui.cocoa.TransferController.clearButtonClicked(TransferController.java:1031)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	... 32 more
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: JNA: Callback org.rococoa.internal.OCInvocationCallbacks$2@14323d5 threw the following exception:
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: org.rococoa.RococoaException: Exception calling method for selector clearButtonClicked:
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.internal.OCInvocationCallbacks.callMethod(OCInvocationCallbacks.java:159)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.internal.OCInvocationCallbacks.access$200(OCInvocationCallbacks.java:52)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.internal.OCInvocationCallbacks$2.callback(OCInvocationCallbacks.java:82)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at sun.reflect.GeneratedMethodAccessor14.invoke(Unknown Source)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at java.lang.reflect.Method.invoke(Method.java:597)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at com.sun.jna.CallbackReference$DefaultCallbackProxy.invokeCallback(CallbackReference.java:384)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at com.sun.jna.CallbackReference$DefaultCallbackProxy.callback(CallbackReference.java:414)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at com.sun.jna.Function.invokeVoid(Native Method)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at com.sun.jna.Function.invoke(Function.java:328)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at com.sun.jna.Function.invoke(Function.java:276)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.internal.MsgSendHandler.invoke(MsgSendHandler.java:111)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at com.sun.jna.Library$Handler.invoke(Library.java:214)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at $Proxy0.syntheticSendMessage(Unknown Source)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.Foundation.send(Foundation.java:200)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.Foundation.send(Foundation.java:187)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.internal.ObjCObjectInvocationHandler.sendOnThisOrMainThread(ObjCObjectInvocationHandler.java:254)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.internal.ObjCObjectInvocationHandler.invokeCocoa(ObjCObjectInvocationHandler.java:222)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.internal.ObjCObjectInvocationHandler.intercept(ObjCObjectInvocationHandler.java:185)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at ch.cyberduck.ui.cocoa.application.NSApplication$$ByRococoa.run(<generated>)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:119)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at java.lang.reflect.Method.invoke(Method.java:597)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at apple.launcher.LaunchRunner.run(LaunchRunner.java:116)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:51)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: Caused by: java.util.ConcurrentModificationException
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at java.util.AbstractList$Itr.checkForComodification(AbstractList.java:372)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at java.util.AbstractList$Itr.next(AbstractList.java:343)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at ch.cyberduck.ui.cocoa.TransferController.clearButtonClicked(TransferController.java:1031)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at java.lang.reflect.Method.invoke(Method.java:597)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	at org.rococoa.internal.OCInvocationCallbacks.callMethod(OCInvocationCallbacks.java:155)
Mar 16 22:24:07 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 	... 27 more
Last edited on Mar 16, 2011 at 12:42:55 PM by lee.norman@… (previous) (diff)

comment:15 in reply to: ↑ 14 ; follow-up: Changed on Mar 17, 2011 at 11:09:51 AM by dkocher

Replying to lee.norman@…:

Error 1 : `There are numerous errors like this one

Mar 16 22:39:15 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 2011-03-16 22:39:15,658 [background-92] ERROR ch.cyberduck.ui.cocoa.model.FinderLocal - No such file:/Volumes/usbshare1/seedbox/fileABC 2011.03.06/fileABC 2011.03.06.wmv

Have you removed this USB volume while a transfer was in progress?

comment:16 in reply to: ↑ 15 Changed on Mar 17, 2011 at 11:25:34 AM by lee.norman@…

no I have not. The transfer occurs in the middle of the night and all devices are up for the duration. Thanks for keep trying.

Replying to dkocher:

Replying to lee.norman@…:

Error 1 : `There are numerous errors like this one

Mar 16 22:39:15 normans-macbook-pro-15 [0x0-0x23023].ch.sudo.cyberduck[287]: 2011-03-16 22:39:15,658 [background-92] ERROR ch.cyberduck.ui.cocoa.model.FinderLocal - No such file:/Volumes/usbshare1/seedbox/fileABC 2011.03.06/fileABC 2011.03.06.wmv

Have you removed this USB volume while a transfer was in progress?

comment:17 Changed on Mar 19, 2011 at 7:35:19 PM by dkocher

  • Milestone 4.0.2 deleted

comment:18 follow-up: Changed on Mar 19, 2011 at 7:36:03 PM by dkocher

Try download to another harddisk and replicate the issue.

comment:19 Changed on Mar 19, 2011 at 11:29:29 PM by lee.norman@…

I have also notice this morning that there are quite a few illegal port command dialogue box pop-ed up and I hit retry. But the transfer did not resume after. I have attached the related transcript from log draw last night. illegalPortCmd.txt for your review. Thanks.

Changed on Mar 19, 2011 at 11:30:19 PM by lee.norman@…

transcript from log draw that are port of the illegal port command.

comment:20 in reply to: ↑ 18 ; follow-up: Changed on Mar 19, 2011 at 11:31:02 PM by lee.norman@…

Replying to dkocher:

Try download to another harddisk and replicate the issue.

OK. Will do this over the next 24 hrs and report back.

comment:21 in reply to: ↑ 20 Changed on Mar 20, 2011 at 10:27:31 PM by lee.norman@…

Replying to lee.norman@…:

Replying to dkocher:

Try download to another harddisk and replicate the issue.

OK. Will do this over the next 24 hrs and report back.

I have tried download to another drive (boot drive) this time and the transfer still not complete and I got illegal port command error as well. Thanks.

comment:22 Changed on Mar 22, 2011 at 9:13:18 PM by dkocher

  • Milestone set to 4.0.2
  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in r8589.

comment:23 follow-ups: Changed on Mar 27, 2011 at 2:31:29 PM by lee.norman@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

after upgrading to 4.0.2, when I want to start another download, I got illegal port command... same thing if i tried to resume a previous download. I cannot even start a transfer any more. bummer. I will try a few more things and report back.

uploaded the log draw in "illegal port.txt" for your reference

hope you see something.

Changed on Mar 27, 2011 at 2:32:19 PM by lee.norman@…

transcript from log draw that are port of the illegal port command. after upgrade to 4.0.2

comment:24 in reply to: ↑ 23 Changed on Mar 28, 2011 at 1:50:06 PM by lee.norman@…

Replying to lee.norman@…:

after upgrading to 4.0.2, when I want to start another download, I got illegal port command... same thing if i tried to resume a previous download. I cannot even start a transfer any more. bummer. I will try a few more things and report back.

uploaded the log draw in "illegal port.txt" for your reference

hope you see something.

This sort of looking like a separate problem. Open another docket. Cannot confirm if the problem of this ticket is fixed since I cannot even make a transfer happen. Keep this ticket open please. Thanks.

comment:25 in reply to: ↑ 23 Changed on Mar 29, 2011 at 6:15:34 AM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

Replying to lee.norman@…:

after upgrading to 4.0.2, when I want to start another download, I got illegal port command... same thing if i tried to resume a previous download. I cannot even start a transfer any more. bummer. I will try a few more things and report back.

uploaded the log draw in "illegal port.txt" for your reference

hope you see something.

Switch to passive (PASV) connect mode.

comment:26 follow-up: Changed on Apr 2, 2011 at 11:54:53 PM by lee.norman@…

  • Milestone 4.0.2 deleted
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 3.8.1 to 4.0.2

after setting to PASV connect mode and using 4.0.2, transferring of files still stop prematurely when using SFTP transfer. Reopen the ticket. Thank for having a look again.

comment:27 follow-up: Changed on Apr 12, 2011 at 11:21:23 AM by Wstsandmore

I made a very interesting observation, which could help you programmers probably a lot :

After uploading a file the Cyberduck File Browser (at least in Macinsosh ) does reload. First I thought that this is a convenient feature to show the user the updated state, but I now realized that Cyberduck also seems to depend on the new recalculated filesize, because if I upload a large file into a subfolder where a reload of the filemanager does not show the new filesize, and then move the entire folder straight away to another location (as I often do with large files in order to prevent people from downloading partially uploaded stuff ), the filesize in that moved folder keeps being zero, because it was never updated by Cyberduck to be larger now.

This also creates really strange problems when uploading multiple folders including large files: The first uploaded files are not registered as uploaded because a refresh of the filebrowser and therewith filecalculation was not made, so if the connection is reset once daily by the ISP, Cyberduck reloads the multiple task, but does not see the files already uploaded and starts them again from the beginning. The only way to prevent this is to open the folder of the file currently uploaded so that it refreshes on completion. But this only works on single folder uploads, because multiple tasks only refresh at the very end.

comment:28 in reply to: ↑ 27 Changed on Jul 4, 2011 at 9:18:17 AM by dkocher

Replying to Wstsandmore:

I made a very interesting observation, which could help you programmers probably a lot :

After uploading a file the Cyberduck File Browser (at least in Macinsosh ) does reload. First I thought that this is a convenient feature to show the user the updated state, but I now realized that Cyberduck also seems to depend on the new recalculated filesize, because if I upload a large file into a subfolder where a reload of the filemanager does not show the new filesize, and then move the entire folder straight away to another location (as I often do with large files in order to prevent people from downloading partially uploaded stuff ), the filesize in that moved folder keeps being zero, because it was never updated by Cyberduck to be larger now.

This also creates really strange problems when uploading multiple folders including large files: The first uploaded files are not registered as uploaded because a refresh of the filebrowser and therewith filecalculation was not made, so if the connection is reset once daily by the ISP, Cyberduck reloads the multiple task, but does not see the files already uploaded and starts them again from the beginning. The only way to prevent this is to open the folder of the file currently uploaded so that it refreshes on completion. But this only works on single folder uploads, because multiple tasks only refresh at the very end.

I do not understand the issue. The refresh in the browser window is just to show uploaded files.

comment:29 in reply to: ↑ 26 Changed on Jul 4, 2011 at 9:22:42 AM by dkocher

  • Milestone set to 4.0.2
  • Resolution set to fixed
  • Status changed from reopened to closed

Replying to lee.norman@…:

after setting to PASV connect mode and using 4.0.2, transferring of files still stop prematurely when using SFTP transfer. Reopen the ticket. Thank for having a look again.

I cannot replicate any more issues. Post the transcript with the problem to a new ticket reporting against 4.1.

Note: See TracTickets for help on using tickets.
swiss made software