Cyberduck Mountain Duck CLI

#5721 closed defect (duplicate)

Cannot save bookmark edits

Reported by: Randy Hanson Owned by:
Priority: normal Milestone: 4.0
Component: core Version: 3.8.1
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by Randy Hanson)

Edit a bookmark, change something like URL, and there's no save button. Command-W or clicking the red dot simple CANCELS the edit.

<edit> mac version, 7954 on 10.6.6.

Change History (8)

comment:1 Changed on Feb 23, 2011 at 6:11:14 PM by Randy Hanson

  • Description modified (diff)

comment:2 Changed on Feb 23, 2011 at 6:49:02 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot replicate such an issue. Changes are saved upon edit.

comment:3 Changed on Feb 23, 2011 at 7:00:56 PM by Randy Hanson

Try editing a bookmark, change the web URL field to anything. Close it. Then edit again and change it to:"http://summitsips.com" without the quotes. Exit. Check it again, and it truncated the last "m" of the ".com". It's crazy. This is the URL to the site I am opening, but I cannot get it to save the URL properly until I delete and recreate the bookmark from scratch. I guess it's inconsistent.

Same thing happens with another site, it's truncating the trailing m in .com in that field. I guess I could try to record a video of this if you cannot reproduce it.

comment:4 Changed on Feb 23, 2011 at 7:03:35 PM by Randy Hanson

Ok, if I set that field of my bookmark to "http://amazon.com" it saves it fine. But if I try to set it CORRECTLY to the URL of the site I am accessing, it truncates the "m". Driving me nuts.

comment:5 Changed on Feb 23, 2011 at 7:04:15 PM by Randy Hanson

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:6 Changed on Feb 23, 2011 at 7:08:51 PM by Randy Hanson

Tried a few more things. For instance, if I add a space after .com in the Web URL field, it saves it, only with the space at the end. If I go back and edit the space out again, close, it does not make the change. Editing it again reveals the space is still there. I am not touching any other fields, jus this one, but once it's broken, I cannot get it back to what it is supposed to be at all, and I have to start with a new bookmark. This obviously affects things like OPEN URL when I right-click a file in the FTP browser--the URL is wrong because there's a space, or a missing "m" in .com from this field.

comment:7 Changed on Feb 23, 2011 at 7:35:09 PM by Randy Hanson

Ok, final comment. I figured out that if I DON'T enter http: into the web URL field, I can get it to save the proper domain name there. I also did a test where I added a trailing "m" to the server field. I can then add the "m" in the web URL field and it saves it, then go back and remove the m from the end of the server. Messy, but I can fix the web URL by doing these goofy steps. There must be some comparison/rewrite going on with that field with respect to whats in the server field, yes? that's when it truncates? Maybe trying to remove a trailing "/" in some cases? Anyway, it was pretty frustrating. Still a bug, IMHO, but I'm no programmer.

comment:8 Changed on Feb 23, 2011 at 9:59:03 PM by dkocher

  • Milestone set to 4.0
  • Resolution set to duplicate
  • Status changed from reopened to closed

Thanks for your additional comments. It looks like a duplicate for #5550 then. Update to the latest snapshot build and reopen if you still have issues.

Note: See TracTickets for help on using tickets.