Cyberduck Mountain Duck CLI

Opened 8 years ago

Closed 8 years ago

#5758 closed defect (fixed)

S3 Versioning: Wrong version of files downloaded when parent folder is downloaded

Reported by: Ben Clayton Owned by: dkocher
Priority: normal Milestone: 4.0.2
Component: s3 Version: 4.0
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description

Steps to reproduce:

  • Create an S3 bucket, and enable 'Bucket Versioning' in the S3 tab in preferences
  • Create a folder in the bucket, e.g. 'foo'
  • Place a text file containing some content into the folder, e.g. 'test.txt'
  • Overwrite said text file with an empty file of the same name. e.g. the 'latest' version of test.txt should now be empty.
  • In Cyberduck, drag the 'foo' folder from S3 to the desktop.
  • Examine the downloaded text.txt file. It will be the non-empty version.

It appears that Cyberduck does not download the latest version of files in versioned buckets when a folder is copied. Same behaviour when the right-click 'Download To' option is used

If you drag the text.txt file itself to the desktop, then it *does* download the correct version.

Change History (4)

comment:1 Changed 8 years ago by dkocher

  • Status changed from new to assigned

I currently get arbitrary results here and I don't think it is related to downloading a folder or a single file. When selecting the default (latest) file for download we always use the default GET with no version information whatsoever which should always return the latest version as with non versioned buckets. Have to investigate with AWS.

I can replicate the issue as described in the ticket.

Last edited 8 years ago by dkocher (previous) (diff)

comment:2 Changed 8 years ago by dkocher

The issue is that when download a folder all of its content including all versions are downloaded eventually overriding the locally where you will have an arbitrary version depending on what version was downloaded latest.

comment:3 Changed 8 years ago by dkocher

  • Milestone changed from 4.1 to 4.0.2

comment:4 Changed 8 years ago by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r8523.

Note: See TracTickets for help on using tickets.
swiss made software