Cyberduck Mountain Duck CLI

Opened 7 years ago

Closed 7 years ago

#5902 closed defect (fixed)

SFTP gives no error if no SSH shell access closes connection

Reported by: lkmorlan Owned by: dkocher
Priority: normal Milestone: 4.2
Component: sftp Version: 4.0.2
Severity: normal Keywords:
Cc: Architecture:
Platform: Mac OS X 10.6

Description

When I tried to connect to a SFTP server, the connection started to open and then immediately closed, as if my connection attempt simply vanished. If the log tray is open, a cryptic SSH_FXP_INIT is all that appears.

The cause is that my account has no shell access. I could tell that by trying to SSH to the server from Terminal: I would connect, get a message stating that I have no access, and the connection would close.

Most users would not know how to try connecting in Terminal and could not debug this problem. It would be very helpful if Cyberduck would display an error message and the text returned by the server if a connection closes right after it opens.

Change History (1)

comment:1 Changed 7 years ago by dkocher

  • Milestone set to 4.1.4
  • Resolution set to fixed
  • Status changed from new to closed

In r9274.

Note: See TracTickets for help on using tickets.
swiss made software