Cyberduck Mountain Duck CLI

#6046 closed defect (fixed)

Interrupted SFTP upload leaves file with 000 permissions, making it unresumable

Reported by: William+G Owned by: dkocher
Priority: normal Milestone: 4.1
Component: sftp Version: 4.0.2
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

I'm uploading a directory using SFTP when the connection is suddenly closed. Logging in to the server I see a partially uploaded file with permission 000. Resuming the upload fails for this particular file with a permission denied error (probably because Cyberduck is trying to append to a read-only file).

Steps to reproduce:

  1. Open a terminal to the upload destination
  2. Upload a file
  3. While uploading do a ls -l, it should display permission 000 for the file currently being uploaded.
  4. Pull the Ethernet cable. After a while it displays "Upload failed. Socket closed."
  5. Plug the Ethernet cable back in.
  6. Try to resume the upload. It will fail.

Client version: Cyberduck 4.0.2 (8601) on Windows Server version: Debian 6.0, ssh package version 1:5.5p1-6

Change History (3)

comment:1 Changed on Jul 4, 2011 at 9:10:59 PM by dkocher

Have you checked Preferences → Transfers → Permissions → Uploads → Change Permissions?

comment:2 Changed on Jul 4, 2011 at 9:12:38 PM by dkocher

I can replicate the issue.

comment:3 Changed on Jul 5, 2011 at 12:57:03 PM by dkocher

  • Milestone set to 4.1
  • Resolution set to fixed
  • Status changed from new to closed

In r8886.

Note: See TracTickets for help on using tickets.
swiss made software