Cyberduck Mountain Duck CLI

#6093 closed defect (thirdparty)

Edit in Subethaedit fails

Reported by: Nebagakid Owned by: dkocher
Priority: high Milestone: 4.1.2
Component: core Version: 4.1
Severity: major Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.7

Description

Double clicking a file causes Cyberduck to hang while it opens in SubEthaEdit and "Computes MD5 Hash." Similarly, on save, Cyberduck hangs and the save is not uploaded as it was in Snow Leopard.

Change History (11)

comment:1 Changed on Jul 21, 2011 at 8:21:31 AM by dkocher

  • Milestone set to 4.1.1
  • Owner set to dkocher
  • Status changed from new to assigned

Upon save we get handleModifiedFileEvent: Got ODB editor event for unknown file..

comment:2 Changed on Jul 21, 2011 at 8:21:37 AM by dkocher

See also #4117.

comment:3 Changed on Jul 21, 2011 at 8:21:48 AM by dkocher

  • Summary changed from Click to Edit hangs in Lion to Edit in Subethaedit fails

comment:4 Changed on Jul 21, 2011 at 8:22:32 AM by dkocher

Subethaedit writes a suspicious SubEthaEdit[57852]: -[PlainTextDocument setDisplayName:] oh look, super supports us!.

comment:5 Changed on Jul 21, 2011 at 12:12:35 PM by dkocher

As a workaround you can disable the ODB editor support and instead work with the file notifications editor support now available. Use

defaults write ch.sudo.cyberduck editor.odb.enable false

in Terminal.app and restart Cyberduck.

comment:6 Changed on Jul 21, 2011 at 1:32:22 PM by dkocher

Looks like a regression in 10.7 that doesn't properly resolve symbolic links in filenames using stringByResolvingSymlinksInPath.

Last edited on Jul 21, 2011 at 1:37:58 PM by dkocher (previous) (diff)

comment:7 Changed on Jul 21, 2011 at 1:39:50 PM by dkocher

The status returned from the ODB event from Subethaedit is 1712 which is not expected.

comment:8 Changed on Jul 21, 2011 at 2:20:09 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from assigned to closed

Logging failed edit attempt in r8927.

comment:9 Changed on Aug 28, 2011 at 1:17:29 PM by dkocher

  • Milestone 4.1.1 deleted

comment:10 Changed on Aug 28, 2011 at 1:17:41 PM by dkocher

#6178 closed as duplicate.

comment:11 Changed on Aug 31, 2011 at 8:03:59 AM by dkocher

  • Milestone set to 4.1.2

Workaround in r8998.

Note: See TracTickets for help on using tickets.
swiss made software