Cyberduck Mountain Duck CLI

#6106 closed defect (fixed)

Runtime crash

Reported by: Gjtorikian Owned by:
Priority: highest Milestone: 4.1.1
Component: appstore Version: 4.1
Severity: major Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.7

Description

Heya--

I was rocking the downloaded version of Cyberduck 4.0. Feeling the extreme guilt of using the software for years and never donating, I finally buckled down, went to my couch, found some change, and purchased the Cyberduck 4.1 version in the App Store. I was/am running Lion. I did not uninstall the previous 4.0 version.

Now, I get a crash whenever I try to launch Cyberduck. Thinking that the two versions conflicted, I saved my bookmarks and uninstalled Cyberduck. Then, I redownloaded it from the App Store. With no luck.

I am attaching the error log to this ticket. I am marking it as priority highest because clearly, the 4.0 app was working in Lion. So it's either a 4.1 issue, or an issue with the binary in the App Store.

Attachments (2)

lion_crash.txt (47.7 KB) - added by Gjtorikian on Jul 22, 2011 at 8:06:44 PM.
App crash log
Cyberduck.rtf (2.8 KB) - added by Lbcfleming on Jul 23, 2011 at 11:32:28 PM.
From system.log

Download all attachments as: .zip

Change History (11)

Changed on Jul 22, 2011 at 8:06:44 PM by Gjtorikian

App crash log

comment:1 Changed on Jul 22, 2011 at 10:06:39 PM by dkocher

  • Component changed from core to appstore
  • Milestone set to 4.1.1
  • Severity changed from normal to major
  • Summary changed from Cyberduck not working on Lion, after App Store purchase to Runtime crash

Changed on Jul 23, 2011 at 11:32:28 PM by Lbcfleming

From system.log

comment:2 Changed on Jul 23, 2011 at 11:33:25 PM by Lbcfleming

I have the same problem. The donation-ware version (4.1) still works; the app-store doesn't.

comment:3 Changed on Jul 26, 2011 at 9:25:23 AM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

Downgrade in r8954.

comment:4 Changed on Jul 26, 2011 at 9:26:16 AM by dkocher

From the attachment.

24/07/11 10:20:58.900 AM [0x0-0x259259].ch.sudo.cyberduck: Exception in thread "main" 
24/07/11 10:20:58.901 AM [0x0-0x259259].ch.sudo.cyberduck: java.lang.ExceptionInInitializerError
24/07/11 10:20:58.901 AM [0x0-0x259259].ch.sudo.cyberduck: 	at ch.cyberduck.ui.cocoa.UserDefaultsPreferences.setDefaults(UserDefaultsPreferences.java:161)
24/07/11 10:20:58.901 AM [0x0-0x259259].ch.sudo.cyberduck: 	at ch.cyberduck.core.Preferences.instance(Preferences.java:66)
24/07/11 10:20:58.901 AM [0x0-0x259259].ch.sudo.cyberduck: 	at ch.cyberduck.core.sparkle.Updater.getFeed(Updater.java:47)
24/07/11 10:20:58.901 AM [0x0-0x259259].ch.sudo.cyberduck: 	at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:69)
24/07/11 10:20:58.902 AM [0x0-0x259259].ch.sudo.cyberduck: Caused by: java.lang.NullPointerException
24/07/11 10:20:58.902 AM [0x0-0x259259].ch.sudo.cyberduck: 	at sun.net.www.ParseUtil.encodePath(ParseUtil.java:105)
24/07/11 10:20:58.902 AM [0x0-0x259259].ch.sudo.cyberduck: 	at sun.misc.URLClassPath$JarLoader.checkResource(URLClassPath.java:738)
24/07/11 10:20:58.902 AM [0x0-0x259259].ch.sudo.cyberduck: 	at sun.misc.URLClassPath$JarLoader.getResource(URLClassPath.java:823)
24/07/11 10:20:58.902 AM [0x0-0x259259].ch.sudo.cyberduck: 	at sun.misc.URLClassPath.getResource(URLClassPath.java:195)
24/07/11 10:20:58.902 AM [0x0-0x259259].ch.sudo.cyberduck: 	at java.net.URLClassLoader$1.run(URLClassLoader.java:358)
24/07/11 10:20:58.902 AM [0x0-0x259259].ch.sudo.cyberduck: 	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
24/07/11 10:20:58.902 AM [0x0-0x259259].ch.sudo.cyberduck: 	at java.security.AccessController.doPrivileged(Native Method)
24/07/11 10:20:58.902 AM [0x0-0x259259].ch.sudo.cyberduck: 	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
24/07/11 10:20:58.902 AM [0x0-0x259259].ch.sudo.cyberduck: 	at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
24/07/11 10:20:58.902 AM [0x0-0x259259].ch.sudo.cyberduck: 	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
24/07/11 10:20:58.902 AM [0x0-0x259259].ch.sudo.cyberduck: 	at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
24/07/11 10:20:58.902 AM [0x0-0x259259].ch.sudo.cyberduck: 	at ch.cyberduck.ui.cocoa.foundation.FoundationKitFunctionsLibrary.<clinit>(FoundationKitFunctionsLibrary.java:35)
24/07/11 10:20:58.902 AM [0x0-0x259259].ch.sudo.cyberduck: 	... 4 more
24/07/11 10:20:58.910 AM com.apple.launchd.peruser.501: ([0x0-0x259259].ch.sudo.cyberduck[1239]) Exited with code: 255

comment:5 Changed on Jul 30, 2011 at 6:04:19 PM by dkocher

  • Milestone changed from 4.1.1 to 4.1.2
  • Resolution fixed deleted
  • Status changed from closed to reopened

We will want to upgrade to 1.7.0.21.0-b17.

comment:6 Changed on Aug 8, 2011 at 10:22:38 AM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

In r8973.

comment:7 Changed on Aug 26, 2011 at 3:30:10 PM by dkocher

  • Milestone changed from 4.1.2 to 4.1.1

comment:8 Changed on Aug 26, 2011 at 6:43:06 PM by dkocher

#6138 closed as duplicate.

comment:9 Changed on Aug 31, 2011 at 10:07:32 PM by Gjtorikian

Is r8973 pushed to the Apple App Store? I don't think it has.

Note: See TracTickets for help on using tickets.
swiss made software