Cyberduck Mountain Duck CLI

#6108 closed defect (fixed)

Read timeout error message after upload is complete

Reported by: iPeter79 Owned by: dkocher
Priority: normal Milestone: 4.4
Component: core Version: 4.1
Severity: normal Keywords: upload transfer big files
Cc: Architecture: PPC
Platform: Mac OS X 10.5

Description

The FTP-Upload fails If i upload files which are bigger than approximately 28 MBs. This is also with older cyberduck versions. After the upload cyberduck opens a dialog that says that the transfer and reconnection is failed. When i abort this message-box the file is most completely on the server (the same size).

Protocoll: FTP only (with not secure), Language: German, Code: ISO-8859-1 (standard), No Proxys

Attachments (4)

Cyberduck-Logfile.rtf (4.4 KB) - added by iPeter79 on Jul 26, 2011 at 9:15:29 AM.
Logfile
Cyberduck-Upload-Fehlermeldung.png (109.6 KB) - added by iPeter79 on Jul 26, 2011 at 9:16:07 AM.
Fehlermeldung
Cyberduck-Logfile 2.rtf (4.5 KB) - added by iPeter79 on Jul 27, 2011 at 9:03:05 AM.
Logfile 2
Cyberduck-Screenshot 2.png (152.8 KB) - added by iPeter79 on Jul 27, 2011 at 9:03:33 AM.
Screenshot 2

Download all attachments as: .zip

Change History (21)

comment:1 Changed on Jul 26, 2011 at 8:28:04 AM by dkocher

What is the exact error message and the content in the transcript in the log drawer (⌘-L)?

Changed on Jul 26, 2011 at 9:15:29 AM by iPeter79

Logfile

Changed on Jul 26, 2011 at 9:16:07 AM by iPeter79

Fehlermeldung

comment:2 Changed on Jul 26, 2011 at 9:18:51 AM by iPeter79

Here is the logfile and a screenshot (in the attachment).

comment:3 Changed on Jul 26, 2011 at 9:54:36 AM by dkocher

Could you also post the transcript from the log drawer of the Transfers window. Possibly modifying permissions and/or timestamps after the upload is complete fails. Try to uncheck Transfers → Berechtigungen → Uploads → Berechtigungen ändern and Transfers → Zeitstempel → Uploads →Änderungsdatum beibehalten in Preferences.

Changed on Jul 27, 2011 at 9:03:05 AM by iPeter79

Logfile 2

Changed on Jul 27, 2011 at 9:03:33 AM by iPeter79

Screenshot 2

comment:4 Changed on Jul 27, 2011 at 9:25:48 AM by iPeter79

Here is the transscript (under the log is more text from me):

---

220 Welcome to Vogel-Druck FTP service.
USER memo
331 Please specify the password.
PASS ********
230 Login successful.
NOOP
200 NOOP ok.
SYST
215 UNIX Type: L8
STAT /home/memo/Transfer
213-Status follows:
drwx------   10 ftp      ftp            10 Feb 25 00:18 .
drwx------    5 ftp      ftp             5 Aug 10  2009 ..
drwx------    4 ftp      ftp             4 Nov 27  2009 memo_intern
drwx------    3 ftp      ftp             3 Apr 02  2009 von_Bernhard
drwx------    6 ftp      ftp             6 Oct 29  2009 von_Richard
drwx------    2 ftp      ftp             2 Aug 25  2008 von_Senfft
drwx------    6 ftp      ftp             6 Feb 05  2009 von_Steffen
drwx------   23 ftp      ftp            23 Mar 04 16:46 von_Vogel
drwx------    8 ftp      ftp             8 Sep 29  2010 von_Woelfel
drwx------    7 ftp      ftp             7 May 18  2010 von_memo
213 End of status
NOOP
200 NOOP ok.
STAT /home/memo/Transfer/von_Woelfel
213-Status follows:
drwx------    8 ftp      ftp             8 Sep 29  2010 .
drwx------   10 ftp      ftp            10 Feb 25 00:18 ..
drwx------    3 ftp      ftp             3 Jul 26 13:02 an_Richard
drwx------    2 ftp      ftp             2 Oct 01  2009 an_Steffen
drwx------    5 ftp      ftp             7 Jul 20 14:40 an_Vogel
drwx------   12 ftp      ftp            16 Jul 26 10:58 an_Woelfel
drwx------    2 ftp      ftp             2 Feb 02 12:31 an_alle_mac_user
drwx------    7 ftp      ftp             7 Jul 20 14:20 an_memo
213 End of status
NOOP
200 NOOP ok.
STAT /home/memo/Transfer/von_Woelfel/an_Woelfel
213-Status follows:
drwx------   12 ftp      ftp            16 Jul 26 10:58 .
drwx------    8 ftp      ftp             8 Sep 29  2010 ..
drwx------    4 ftp      ftp             4 Jan 02  2008 Andre
-rw-------    1 ftp      ftp        245760 Apr 14 15:28 Biblio_Notizen.indl
drwx------    2 ftp      ftp             2 Jan 04  2010 Georgia
drwx------    4 ftp      ftp             4 Jan 02  2008 Liane
-rw-------    1 ftp      ftp      24580096 Mar 27 23:24 MM1_Anschreiben_rueck_05.indd
-rw-------    1 ftp      ftp      24576000 Mar 28 11:42 MM1_Anschreiben_rueck_06.indd
drwx------    2 ftp      ftp             2 Sep 01  2009 Peter
drwx------    4 ftp      ftp             4 Feb 18 19:16 Sabrina
-rw-------    1 ftp      ftp       5468718 May 05 13:22 SoftkatGenerator_2009.zip
drwx------    4 ftp      ftp             4 Oct 16  2007 Steffi
drwx------    2 ftp      ftp             2 Jul 26 11:19 Test
drwx------    2 ftp      ftp            20 Mar 03 14:42 Vorlagen_Musterseiten
drwx------    2 ftp      ftp             2 Feb 17 18:41 conny
drwx------    2 ftp      ftp             5 Apr 14 15:04 memo-Bibliotheken_neu_2011-04
213 End of status
NOOP
200 NOOP ok.
STAT /home/memo/Transfer/von_Woelfel/an_Woelfel/Test
213-Status follows:
drwx------    2 ftp      ftp             2 Jul 26 11:19 .
drwx------   12 ftp      ftp            16 Jul 26 10:58 ..
213 End of status
CWD /home/memo/Transfer/von_Woelfel/an_Woelfel/Test
250 Directory successfully changed.
TYPE A
200 Switching to ASCII mode.
FEAT
211-Features:
 AUTH SSL
 AUTH TLS
 EPRT
 EPSV
 MDTM
 PASV
 PBSZ
 PROT
 REST STREAM
 SIZE
 TVFS
211 End
PASV
227 Entering Passive Mode (212,185,175,132,222,99)
LIST -a
150 Here comes the directory listing.
drwx------    2 ftp      ftp             2 Jul 26 11:19 .
drwx------   12 ftp      ftp            16 Jul 26 10:58 ..
226 Directory send OK.
NOOP
200 NOOP ok.
STAT /home/memo/Transfer/von_Woelfel/an_Woelfel/Test
213-Status follows:
drwx------    2 ftp      ftp             3 Jul 26 13:47 .
drwx------   12 ftp      ftp            16 Jul 26 10:58 ..
-rw-------    1 ftp      ftp      26468352 Jul 26 13:56 GMA3_moebel_04.indd
213 End of status
NOOP
220 Welcome to Vogel-Druck FTP service.
USER memo
331 Please specify the password.
PASS ********
230 Login successful.
STAT /home/memo/Transfer/von_Woelfel/an_Woelfel/Test
213-Status follows:
drwx------    2 ftp      ftp             3 Jul 26 13:47 .
drwx------   12 ftp      ftp            16 Jul 26 10:58 ..
-rw-------    1 ftp      ftp      26468352 Jul 26 13:56 GMA3_moebel_04.indd
213 End of status

---

I have also upload the logfile as attachment. Here is the screenshot with the bug-message too ("I/O Fehler: Upload fehlgeschlagen – Read timed out."). I modified the permissions and the timestamps. But with no affection (the same problem). With a older Version of Cyberduck (under 4.0) this problem was only with files over a certain size. Now the problem is with every files too. Since Version 4 Cyberduck can not open the preferenched ftp-server at the start. only the memory state open on the start-up.

Can i write further in german on this site please? But my english is not so good and you are live in switzerland.

Last edited on Jul 27, 2011 at 9:45:27 AM by dkocher (previous) (diff)

comment:5 Changed on Jul 27, 2011 at 9:46:34 AM by dkocher

Kommentare in Deutsch sind auch möglich, ja.

comment:6 Changed on Jul 27, 2011 at 9:49:59 AM by dkocher

Ich sollte noch das Log haben vom Log Drawer des Transfer Fensters.

comment:7 Changed on Jul 27, 2011 at 9:50:29 AM by dkocher

  • Summary changed from FTP-Upload from big files fails to Read timeout after upload is complete

comment:8 Changed on Jul 27, 2011 at 10:28:50 AM by iPeter79

Entschuldigung, ich habe gar nicht gewusst dass das Transfer-Fenster auch einen Log-Bereich hat. Hier ist also die das richtige Protokoll vom Transfer:

220 Welcome to Vogel-Druck FTP service.
USER memo
331 Please specify the password.
PASS ********
230 Login successful.
NOOP
200 NOOP ok.
SYST
215 UNIX Type: L8
STAT /home/memo/Transfer/von_Woelfel/an_Woelfel/Test
213-Status follows:
drwx------    2 ftp      ftp             2 Jul 26 14:18 .
drwx------   12 ftp      ftp            16 Jul 26 10:58 ..
213 End of status
CWD /home/memo/Transfer/von_Woelfel/an_Woelfel/Test
250 Directory successfully changed.
TYPE A
200 Switching to ASCII mode.
FEAT
211-Features:
 AUTH SSL
 AUTH TLS
 EPRT
 EPSV
 MDTM
 PASV
 PBSZ
 PROT
 REST STREAM
 SIZE
 TVFS
211 End
PASV
227 Entering Passive Mode (212,185,175,132,216,128)
LIST -a
150 Here comes the directory listing.
drwx------    2 ftp      ftp             2 Jul 26 14:18 .
drwx------   12 ftp      ftp            16 Jul 26 10:58 ..
226 Directory send OK.
TYPE I
200 Switching to Binary mode.
PASV
227 Entering Passive Mode (212,185,175,132,209,190)
STOR /home/memo/Transfer/von_Woelfel/an_Woelfel/Test/PM3_Jan_2_04.indd
150 Ok to send data.
NOOP
220 Welcome to Vogel-Druck FTP service.
USER memo
331 Please specify the password.
PASS ********
230 Login successful.
SITE CHMOD 644 /home/memo/Transfer/von_Woelfel/an_Woelfel/Test/PM3_Jan_2_04.indd
500 Unknown SITE command.
QUIT
221 Goodbye.

Wie schon gesagt erscheint nach einer bestimmten Zeit oder per Aktualisierung des Verzeichnisses die Datei komplett, obwohl die Fehlermeldung angezeigt wird. Was mir auch aufgefallen ist, ist das Cyberduck gelegentlich ziemlich langsam bei der Verbindung und Aktualisierung reagiert. Manchmal geht es ganz schnell. Ich schätze dass es am Server liegen muss (spezielle Einstellungen). Ein anderer Client (Interarchy) zeigte auch dieses Problem, obwohl es mit diesem im Gegensatz zu Cyberduck Zuhause ging. Vielleicht sollte ich mal auf Aktiven-Mode umschalten und evtl. etwas in der Proxy-Einstellung umstellen?

comment:9 Changed on Jul 28, 2011 at 12:38:29 PM by iPeter79

Inzwischen habe ich auch den aktiven und passiven FTP-Modus probiert (System/Programm). Dies hat aber auch nichts genutzt. Zuhause (das Problem besteht hauptsächlich im Büro) hat es übrigens mit Cyberduck und einen anderen FTP-Programm (Interachy) funktioniert (was im Büro auch zu Problemen führte). Jetzt hatte ich mal die kompletten Einstellungen von Cyberduck gelöscht (Plist-Datei und Application-Support-Ordner), die gespeicherten Lesezeichen (Server) wieder importiert und meine vorherigen Einstellungen neu eingetragen. Daraufhin hat die Übertragung ohne Fehlermeldung funktioniert. Wobei ich noch kontrollieren muss, ob die Fehlermeldung nur unterdrückt worden ist (die Unterdrückung hat nämlich seit der 4er-Version auch nicht mehr funktioniert). Angenehmer Nebeneffekt ist auch, dass man bei SFTP jetzt auch ein Programm wählen kann (ging vorher nicht), da alles ausgegraut war. Ob diese Verbindungsart allerdings jetzt auch korrekt funktioniert, muss ich noch nachprüfen (es kamen immer Zertifikat-Fehlermeldungen beim Login).

comment:10 Changed on Aug 22, 2011 at 4:56:32 PM by dkocher

The server is closing the control connection while the transfer is in progress. When reopening the connection succeeds there should be no error message, though.

comment:11 Changed on Dec 21, 2011 at 10:36:36 PM by dkocher

  • Milestone set to 4.3

#6445 closed as duplicate.

comment:12 Changed on Jan 21, 2012 at 7:51:18 PM by dkocher

#6488 closed as duplicate.

comment:13 Changed on Nov 26, 2012 at 6:42:43 PM by dkocher

  • Component changed from ftp to core

comment:14 Changed on Nov 27, 2012 at 1:07:08 PM by dkocher

  • Status changed from new to assigned

comment:15 Changed on Nov 27, 2012 at 4:08:21 PM by dkocher

  • Summary changed from Read timeout after upload is complete to Read timeout error message after upload is complete

comment:16 Changed on Jun 26, 2013 at 4:30:12 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r11411.

comment:17 Changed on Jun 26, 2013 at 4:47:47 PM by dkocher

  • Milestone changed from 4.4 to 4.3.2
Note: See TracTickets for help on using tickets.
swiss made software