Cyberduck Mountain Duck CLI

#6123 closed defect (thirdparty)

Interoperability with FireUploader

Reported by: Andrew0204 Owned by: dkocher
Priority: normal Milestone:
Component: cloudfiles Version: 4.1
Severity: normal Keywords: Folders
Cc: Architecture: Intel
Platform: Windows 7

Description

When I make new folders within a Cloudfiles container using Cyberduck, the folders it creates are reported by the Rackspace CloudFiles Manager as being of type application/directory. I have been using FireUploader for Firefox for a long time now and have created many folders within containers for my websites and these folders are reported by the Rackspace Cloudfiles Manager as type application/folder. The problem is that all my existing folders within containers that I have created with FireUploader can't be viewed or opened in Cyberduck - it doesn't recognize them as folders. In fact, the Cyberduck info box reports the folders as Kind:Unknown.

And, the reverse causes a problem too. If I create a folder within a CDN container using Cyberduck, the file type application/directory, is not recognized by FireUploader and can't be opened.

Would it be possible to provide CloudFiles options in Cyberduck so that the file type can be set to either application/folder or application directory when creating or viewing folders within containers?

At the moment this problem is preventing me from using Cyberduck, which is disappointing because I find it easier to use than FireUploader.

Attachments (1)

screenshot.jpg (123.5 KB) - added by Andrew0204 on Aug 1, 2011 at 1:07:13 PM.

Download all attachments as: .zip

Change History (4)

Changed on Aug 1, 2011 at 1:07:13 PM by Andrew0204

comment:1 Changed on Aug 1, 2011 at 9:30:08 PM by dkocher

  • Severity changed from major to normal
  • Summary changed from Folders created with Cyberduck incompatible with other Cloudfiles file managers to Interoperability with FireUploader

We follow the recommendations of the Rackspace developer documentation about setting a proper MIME type for directory placeholders. Others should do the same.

comment:2 Changed on Aug 1, 2011 at 11:53:46 PM by Andrew0204

Ok, thanks anyway.

comment:3 Changed on Sep 6, 2011 at 6:20:34 AM by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
swiss made software