Cyberduck Mountain Duck CLI

#6147 closed defect (worksforme)

Empty child directories not created on upload

Reported by: Motherboard Owned by: dkocher
Priority: normal Milestone: 4.1.2
Component: sftp Version: 4.1
Severity: normal Keywords:
Cc: Architecture:
Platform: Mac OS X 10.7

Description

Bear with me on this one as I explain the sequence of steps that generate the error.

  1. I have a folder called Example on my desktop that contains other child folders, and these child folders are empty.
  1. I drop & drag the Example folder to my private SFTP site with no issue.
  1. I delete the Example folder on the SFTP site using Cyberduck during the same session.
  1. I re-upload the Example folder on my desktop to the SFTP site. However, only the parent directory (Example) is created on the server. The child directories are absent. If the child folders in Example contain files, then the following error is reported for each file:

No such file (SSH_FX_NO_SUCH_FILE: A reference was made to a file which does not exist.).

This error makes sense since the child folders are missing on the SFTP server.

  1. If I close Cyberduck, reopen it and then reconnect to the SFTP server, I can transfer Example to the SFTP server and the child directories are created correctly on the SFTP server. However, if I repeat steps 3 and 4, the same error occurs consistently.

I tested the same version of Cyberduck running on Mac OS X 10.6.8 (Snow Leopard) and it worked fine, so this seems to be a Lion issue.

NOTE: In Step 1, if the Example folder contains files only (e.g., jpegs), then the error does not occur. The error seems related to multi-level folder hierarchies.

Thank you for your time.

Change History (3)

comment:1 Changed on Aug 9, 2011 at 8:29:00 PM by dkocher

  • Milestone set to 4.1.2

Thanks for the detailed bug report. Sounds strange enough. Will have to try to replicate.

comment:2 Changed on Aug 9, 2011 at 8:29:33 PM by dkocher

  • Summary changed from Lion SFTP to Empty child directories not created on upload

comment:3 Changed on Aug 28, 2011 at 6:32:33 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I could replicate the issue once but now whatever I try the upload always succeeds.

Note: See TracTickets for help on using tickets.
swiss made software