Cyberduck Mountain Duck CLI

#6181 closed defect (fixed)

Empty Content-Type violating RFC2616

Reported by: Tingjun Li Owned by: dkocher
Priority: normal Milestone: 4.1.3
Component: s3 Version: 4.1
Severity: normal Keywords: Content-Type, RFC2616
Cc: Architecture: Intel
Platform: Windows 7

Description

Hello,

I'm using Cyberduck/4.1 (8911) to create a S3/HTTP(Amazon Simple Storage Service) connection, it send request with an empty Content-Type which is violating RFC2616. Please have a look at this issue, thanks. (Wireshark cap file attached.)

Attachments (1)

Cyberduck_login_amazon_s3.pcap (6.7 KB) - added by Tingjun Li on Aug 30, 2011 at 2:41:59 AM.
Cyberduck_login_amazon_s3.pcap

Download all attachments as: .zip

Change History (10)

Changed on Aug 30, 2011 at 2:41:59 AM by Tingjun Li

Cyberduck_login_amazon_s3.pcap

comment:1 follow-up: Changed on Aug 30, 2011 at 9:05:43 AM by dkocher

Is this giving a blocking issue? Just to know what priority to assign.

comment:2 in reply to: ↑ 1 Changed on Aug 31, 2011 at 7:08:37 AM by Tingjun Li

Replying to dkocher:

Is this giving a blocking issue? Just to know what priority to assign.

It's OK with connecting S3 but failed with connecting some other S3-compatible services (has not been public currently)

comment:3 Changed on Aug 31, 2011 at 7:33:57 AM by dkocher

Can you just attach the transcript from the log drawer (⌘-L) of the Transfers and Browser windows.

comment:4 Changed on Aug 31, 2011 at 7:34:16 AM by dkocher

  • Milestone set to 4.2
  • Status changed from new to assigned

comment:5 Changed on Aug 31, 2011 at 3:16:48 PM by dkocher

  • Milestone changed from 4.2 to 4.1.3

comment:6 Changed on Aug 31, 2011 at 3:17:35 PM by dkocher

GET / HTTP/1.1
Date: Wed, 31 Aug 2011 15:16:17 GMT
Content-Type: 
Authorization: AWS XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX=
Host: s3.amazonaws.com:443
Connection: Keep-Alive
User-Agent: Cyberduck/4.1.2 (Mac OS X/10.6.8) (i386)

comment:7 Changed on Aug 31, 2011 at 3:27:34 PM by dkocher

The issue is reported against Jets3t in issue 109.

comment:8 Changed on Sep 1, 2011 at 8:57:04 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

Updated library with patch included in r9000.

comment:9 Changed on Sep 2, 2011 at 7:19:01 AM by Tingjun Li

Good job! Thanks! :-)

Note: See TracTickets for help on using tickets.
swiss made software