Cyberduck Mountain Duck CLI

#6188 closed defect (fixed)

Repeated hangs after subdirectory has over 4760 files

Reported by: Jklein992 Owned by:
Priority: normal Milestone: 4.1.3
Component: core Version: 4.1
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description (last modified by dkocher)

The application (4.1.2) has started to hang when one sub directory on logged-in server exceeded 4760 files. The problem appears faster (within a few minutes) if the large directory is viewed, but eventually (within 5 minutes) it hangs in any directory on the server. It is also difficult to add any more files to this large directory. After all files are sent the applications hangs while "Listing directory xxxx". see the log drawer below.

TYPE I
200 Switching to Binary mode.
PORT 192,168,1,51,201,179
200 PORT command successful. Consider using PASV.
STOR /var/www/graphics/chip/1970chevcanada_19.jpg
150 Ok to send data.
226 File receive OK.
QUIT
221 Goodbye.

Change History (3)

comment:1 Changed on Sep 4, 2011 at 10:46:36 AM by dkocher

  • Description modified (diff)

comment:2 Changed on Sep 4, 2011 at 10:47:22 AM by dkocher

Could this be a duplicate of #6183 instead? Do you have the option Transfers → Remove when transfer completes in Preferences enabled?

comment:3 Changed on Sep 4, 2011 at 11:11:35 AM by dkocher

  • Milestone set to 4.1.3
  • Resolution set to fixed
  • Status changed from new to closed

In r9001.

Note: See TracTickets for help on using tickets.
swiss made software