Cyberduck Mountain Duck CLI

Opened 7 years ago

Closed 5 years ago

#6208 closed enhancement (fixed)

Multipart uploads not resumable

Reported by: Aolchik Owned by: dkocher
Priority: normal Milestone: 4.4
Component: s3 Version: 4.1
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.7

Description

I'm trying to upload a large file to S3 (1GB). The upload fails and resume is never enabled. I have always to restart the upload. The result is that I cannot upload the file.

Change History (16)

comment:1 Changed 7 years ago by dkocher

  • Summary changed from Resume is not enabled when uploading large files do S3 to Multipart uploads not resumable
  • Type changed from defect to enhancement

comment:2 Changed 7 years ago by dkocher

Currently when an upload to S3 fails we abort the multipart upload deleting all parts already transferred.

comment:3 Changed 7 years ago by dkocher

What is the error message you get when the transfer is interrupted?

comment:4 follow-up: Changed 6 years ago by jtcawrse

I still have this problem. Do I have a setting that is incorrect? How can I enable this feature?

comment:5 in reply to: ↑ 4 Changed 6 years ago by dkocher

Replying to jtcawrse:

I still have this problem. Do I have a setting that is incorrect? How can I enable this feature?

Resumable multipart uploads are not currently enabled. We have to do more tests before we enable this feature. What is the error message you get for the interrupted transfers?

comment:6 follow-up: Changed 6 years ago by jtcawrse

Usually it is a broken pipe or some other network disconnect. My internet connection is not very stable.

comment:7 in reply to: ↑ 6 Changed 6 years ago by dkocher

Replying to jtcawrse:

Usually it is a broken pipe or some other network disconnect. My internet connection is not very stable.

We are tracking the same issue in #6391.

comment:8 Changed 6 years ago by jtcawrse

Failure again. 4.5G upload. Build 4.2

This upload is essential to my work. Any help or advice appreciated.

Server: AmazonS3
PUT /061370%2Fpowerropeshddec11.mp4?uploadId=ScB3BtIHaRYxFnCz_lO_hGxApn6nx_XDr7OgjICj0d4kp6RP4z0USG520pHurG7iK5aQk7cETnh_2UerzWiKeA--&partNumber=20 HTTP/1.1
Date: Sat, 03 Dec 2011 07:38:16 GMT
Content-Type: application/octet-stream
Authorization: AWS=
Content-Length: 5242880
Host: mexifitdl.s3.amazonaws.com:443
Connection: Keep-Alive
User-Agent: Cyberduck/4.2 (Mac OS X/10.7.2) (i386)
Expect: 100-continue

Last edited 6 years ago by dkocher (previous) (diff)

comment:9 Changed 6 years ago by jtcawrse

tried again with build 4.2.1

x-amz-request-id: 7CEC650EC535DFC3
Date: Sat, 03 Dec 2011 15:12:50 GMT
Server: AmazonS3
PUT /061370%2Fpowerropeshddec11.mp4?uploadId=EzZy_0nYejCsUUYXrrjg3L3JbbjBiH84xzgLkK_EXXY.iRCktrV_q4BegYUaqkT4DKho5PMDWEBtG8X_9mXrFQ--&partNumber=8 HTTP/1.1
Date: Sat, 03 Dec 2011 15:12:39 GMT
Content-Type: application/octet-stream
Authorization: AWS c=
Content-Length: 5242880
Host: mexifitdl.s3.amazonaws.com:443
Connection: Keep-Alive
User-Agent: Cyberduck/4.2.1 (Mac OS X/10.7.2) (i386)
Expect: 100-continue

Last edited 6 years ago by dkocher (previous) (diff)

comment:10 Changed 5 years ago by ekan

This is still happening in Version 4.2.1 (9350).

comment:11 Changed 5 years ago by kevin39

Same problem is, my file is 7.17go... Broken pipe (4.3.1).

Date: Sat, 04 May 2013 14:56:41 GMT
Server: AmazonS3
PUT /iPhoto_2006-2012.tar?uploadId=6GJ859iFc8yPuMYSaCMONAnRbV6sXCqt2bhx0kwz5zfSUq2kIPtzWJkmF0MeHCx.dThPSIqcD.KK2qHGkVKbxQ--&partNumber=10 HTTP/1.1
Date: Sat, 04 May 2013 14:56:38 GMT
Content-Type: application/octet-stream
Authorization: (hidden)
Content-Length: 5242880
Host: mes-backups.s3.amazonaws.com:80
Connection: Keep-Alive
User-Agent: Cyberduck/4.3.1 (Mac OS X/10.8.3) (i386)
Expect: 100-continue

Last edited 5 years ago by kevin39 (previous) (diff)

comment:12 Changed 5 years ago by kevin39

Due to cyberduck's bugs with multi-part upload (see my comment above), I uploaded my big file using s3tools (s3tools.org) from command line and it worked without any problem. My conclusion is Cyberduck seems to have some problem to upload multi-part files.

Last edited 5 years ago by kevin39 (previous) (diff)

comment:13 Changed 5 years ago by dkocher

  • Milestone set to 4.4

comment:14 Changed 5 years ago by dkocher

#7273 closed as duplicate.

comment:15 Changed 5 years ago by dkocher

  • Milestone changed from 4.5 to 4.4
  • Status changed from new to assigned

comment:16 Changed 5 years ago by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r12447.

Note: See TracTickets for help on using tickets.
swiss made software