Cyberduck Mountain Duck CLI

#6247 closed defect (duplicate)

Cyberduck Installation on Mac running Snow Leopard 10.6.8

Reported by: KPV Owned by: Ken
Priority: high Milestone: 4.1.3
Component: core Version: 4.1
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description

David, I would first like to commend you on your efforts to make this software. Great job! I was using it a bit on my Macbook Pro running Snow Leopard 10.6.8 and I recently had to reinstall the operating system due to a problem. I have installed all of the other applications to get myself up and running and the last on the list is Cyberduck. I have downloaded it several times from your site and each time I try to install it, it fails. I double click on the download icon and receive a message asking whether I want to install the software that was downloaded from the internet. I click yes and nothing happens. I had it running prior to the Mac OS problem and all of the other software is reloaded and running, so this must have something to do with Cyberduck specifically. Can you shed some light on this? Any thoughts or suggestions? Any help would be greatly appreciated. Best regards, Ken

Change History (12)

comment:1 Changed on Sep 21, 2011 at 6:23:27 AM by dkocher

Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

comment:2 follow-up: Changed on Sep 21, 2011 at 6:35:10 AM by KPV

Yes. I created a .log file to send to you. Incidentally, it didn't work on my Mac Pro either. Where should I send the .log file? Regards, Ken

comment:3 Changed on Sep 21, 2011 at 6:36:42 AM by KPV

9/20/11 6:14:17 PM	[0x0-0x35035].ch.sudo.cyberduck[273]	[LaunchRunner Error] ch.cyberduck.ui.cocoa.MainApplication.main(String[]) threw an exception:
9/20/11 6:14:17 PM	[0x0-0x35035].ch.sudo.cyberduck[273]	java.lang.UnsatisfiedLinkError: jnidispatch (/com/sun/jna/darwin/libjnidispatch.jnilib) not found in resource path
9/20/11 6:14:17 PM	[0x0-0x35035].ch.sudo.cyberduck[273]	        at com.sun.jna.Native.loadNativeLibraryFromJar(Native.java:722)
9/20/11 6:14:17 PM	[0x0-0x35035].ch.sudo.cyberduck[273]	        at com.sun.jna.Native.loadNativeLibrary(Native.java:699)
9/20/11 6:14:17 PM	[0x0-0x35035].ch.sudo.cyberduck[273]	        at com.sun.jna.Native.<clinit>(Native.java:114)
9/20/11 6:14:17 PM	[0x0-0x35035].ch.sudo.cyberduck[273]	        at org.rococoa.Foundation.<clinit>(Foundation.java:73)
9/20/11 6:14:17 PM	[0x0-0x35035].ch.sudo.cyberduck[273]	        at org.rococoa.Rococoa.createClass(Rococoa.java:49)
9/20/11 6:14:17 PM	[0x0-0x35035].ch.sudo.cyberduck[273]	        at org.rococoa.cocoa.foundation.NSObject.<clinit>(NSObject.java:28)
9/20/11 6:14:17 PM	[0x0-0x35035].ch.sudo.cyberduck[273]	        at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:49)
9/20/11 6:14:17 PM	[0x0-0x35035].ch.sudo.cyberduck[273]	        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
9/20/11 6:14:17 PM	[0x0-0x35035].ch.sudo.cyberduck[273]	        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
9/20/11 6:14:17 PM	[0x0-0x35035].ch.sudo.cyberduck[273]	        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
9/20/11 6:14:17 PM	[0x0-0x35035].ch.sudo.cyberduck[273]	        at java.lang.reflect.Method.invoke(Method.java:597)
9/20/11 6:14:17 PM	[0x0-0x35035].ch.sudo.cyberduck[273]	        at apple.launcher.LaunchRunner.run(LaunchRunner.java:115)
9/20/11 6:14:17 PM	[0x0-0x35035].ch.sudo.cyberduck[273]	        at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:50)
9/20/11 6:14:17 PM	[0x0-0x35035].ch.sudo.cyberduck[273]	        at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)
9/20/11 6:29:24 PM	[0x0-0x41041].ch.sudo.cyberduck[316]	[LaunchRunner Error] ch.cyberduck.ui.cocoa.MainApplication.main(String[]) threw an exception:
9/20/11 6:29:24 PM	[0x0-0x41041].ch.sudo.cyberduck[316]	java.lang.UnsatisfiedLinkError: jnidispatch (/com/sun/jna/darwin/libjnidispatch.jnilib) not found in resource path
9/20/11 6:29:24 PM	[0x0-0x41041].ch.sudo.cyberduck[316]	        at com.sun.jna.Native.loadNativeLibraryFromJar(Native.java:722)
9/20/11 6:29:24 PM	[0x0-0x41041].ch.sudo.cyberduck[316]	        at com.sun.jna.Native.loadNativeLibrary(Native.java:699)
9/20/11 6:29:24 PM	[0x0-0x41041].ch.sudo.cyberduck[316]	        at com.sun.jna.Native.<clinit>(Native.java:114)
9/20/11 6:29:24 PM	[0x0-0x41041].ch.sudo.cyberduck[316]	        at org.rococoa.Foundation.<clinit>(Foundation.java:73)
9/20/11 6:29:24 PM	[0x0-0x41041].ch.sudo.cyberduck[316]	        at org.rococoa.Rococoa.createClass(Rococoa.java:49)
9/20/11 6:29:24 PM	[0x0-0x41041].ch.sudo.cyberduck[316]	        at org.rococoa.cocoa.foundation.NSObject.<clinit>(NSObject.java:28)
9/20/11 6:29:24 PM	[0x0-0x41041].ch.sudo.cyberduck[316]	        at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:49)
9/20/11 6:29:24 PM	[0x0-0x41041].ch.sudo.cyberduck[316]	        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
9/20/11 6:29:24 PM	[0x0-0x41041].ch.sudo.cyberduck[316]	        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
9/20/11 6:29:24 PM	[0x0-0x41041].ch.sudo.cyberduck[316]	        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
9/20/11 6:29:24 PM	[0x0-0x41041].ch.sudo.cyberduck[316]	        at java.lang.reflect.Method.invoke(Method.java:597)
9/20/11 6:29:24 PM	[0x0-0x41041].ch.sudo.cyberduck[316]	        at apple.launcher.LaunchRunner.run(LaunchRunner.java:115)
9/20/11 6:29:24 PM	[0x0-0x41041].ch.sudo.cyberduck[316]	        at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:50)
9/20/11 6:29:24 PM	[0x0-0x41041].ch.sudo.cyberduck[316]	        at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)
9/20/11 6:30:28 PM	com.apple.launchd.peruser.501[92]	([0x0-0x3a03a].com.apple.Terminal[292]) Exited: Killed

Last edited on Sep 21, 2011 at 7:04:30 AM by dkocher (previous) (diff)

comment:4 in reply to: ↑ 2 Changed on Sep 21, 2011 at 6:37:03 AM by dkocher

Replying to KPV:

Yes. I created a .log file to send to you. Incidentally, it didn't work on my Mac Pro either. Where should I send the .log file? Regards, Ken

Attach it here or send it to feedback@….

comment:5 Changed on Sep 21, 2011 at 7:09:41 AM by dkocher

This is a duplicate of #6242. Can you update to the latest snapshot build which does possibly not solve the issue but will give better error reporting on the cause of the issue. Please again post the system.log output.

comment:6 Changed on Sep 21, 2011 at 7:10:02 AM by dkocher

  • Milestone set to 4.1.3
  • Resolution set to duplicate
  • Status changed from new to closed

comment:7 Changed on Sep 21, 2011 at 7:30:24 AM by KPV

David, I downloaded Cyberduck-9025.tar.qz I am not a programmer. I double clicked it and it says "Unable to unarchive "Cyberduck-9025.tar" into "Downloads"" What should I do with this file?

comment:8 Changed on Sep 21, 2011 at 7:49:21 AM by KPV

OK, I installed Stuffit Expander and unzipped the 9025.tar file.

I then tried installing Cyberduck.

This is the console output....

9/21/11 3:44:26 AM	[0x0-0x7e07e].com.stuffit.StuffIt-Destinations[656]	Wed Sep 21 03:44:26 Kenneth-Volpes-MacBook-Pro.local StuffIt Destinations[656] <Info>: Starting 'Expand an archive' with 'file://localhost/Users/Administrator/Desktop/Cyberduck-9025.tar'
9/21/11 3:44:28 AM	[0x0-0x7e07e].com.stuffit.StuffIt-Destinations[656]	Wed Sep 21 03:44:28 Kenneth-Volpes-MacBook-Pro.local StuffIt Destinations[656] <Info>: 'Expand an archive' results: file://localhost/Users/Administrator/Desktop/Cyberduck.app/
9/21/11 3:44:36 AM	[0x0-0x88088].ch.sudo.cyberduck[695]	[LaunchRunner Error] ch.cyberduck.ui.cocoa.MainApplication.main(String[]) threw an exception:
9/21/11 3:44:36 AM	[0x0-0x88088].ch.sudo.cyberduck[695]	java.lang.UnsatisfiedLinkError: jnidispatch (/com/sun/jna/darwin/libjnidispatch.jnilib) not found in resource path
9/21/11 3:44:36 AM	[0x0-0x88088].ch.sudo.cyberduck[695]	        at com.sun.jna.Native.loadNativeLibraryFromJar(Native.java:699)
9/21/11 3:44:36 AM	[0x0-0x88088].ch.sudo.cyberduck[695]	        at com.sun.jna.Native.loadNativeLibrary(Native.java:675)
9/21/11 3:44:36 AM	[0x0-0x88088].ch.sudo.cyberduck[695]	        at com.sun.jna.Native.<clinit>(Native.java:118)
9/21/11 3:44:36 AM	[0x0-0x88088].ch.sudo.cyberduck[695]	        at org.rococoa.Foundation.<clinit>(Foundation.java:73)
9/21/11 3:44:36 AM	[0x0-0x88088].ch.sudo.cyberduck[695]	        at org.rococoa.Rococoa.createClass(Rococoa.java:49)
9/21/11 3:44:36 AM	[0x0-0x88088].ch.sudo.cyberduck[695]	        at org.rococoa.cocoa.foundation.NSObject.<clinit>(NSObject.java:28)
9/21/11 3:44:36 AM	[0x0-0x88088].ch.sudo.cyberduck[695]	        at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:49)
9/21/11 3:44:36 AM	[0x0-0x88088].ch.sudo.cyberduck[695]	        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
9/21/11 3:44:36 AM	[0x0-0x88088].ch.sudo.cyberduck[695]	        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
9/21/11 3:44:36 AM	[0x0-0x88088].ch.sudo.cyberduck[695]	        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
9/21/11 3:44:36 AM	[0x0-0x88088].ch.sudo.cyberduck[695]	        at java.lang.reflect.Method.invoke(Method.java:597)
9/21/11 3:44:36 AM	[0x0-0x88088].ch.sudo.cyberduck[695]	        at apple.launcher.LaunchRunner.run(LaunchRunner.java:115)
9/21/11 3:44:36 AM	[0x0-0x88088].ch.sudo.cyberduck[695]	        at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:50)
9/21/11 3:44:36 AM	[0x0-0x88088].ch.sudo.cyberduck[695]	        at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)
9/21/11 3:44:50 AM	[0x0-0x8a08a].ch.sudo.cyberduck[699]	[LaunchRunner Error] ch.cyberduck.ui.cocoa.MainApplication.main(String[]) threw an exception:
9/21/11 3:44:50 AM	[0x0-0x8a08a].ch.sudo.cyberduck[699]	java.lang.UnsatisfiedLinkError: jnidispatch (/com/sun/jna/darwin/libjnidispatch.jnilib) not found in resource path
9/21/11 3:44:50 AM	[0x0-0x8a08a].ch.sudo.cyberduck[699]	        at com.sun.jna.Native.loadNativeLibraryFromJar(Native.java:699)
9/21/11 3:44:50 AM	[0x0-0x8a08a].ch.sudo.cyberduck[699]	        at com.sun.jna.Native.loadNativeLibrary(Native.java:675)
9/21/11 3:44:50 AM	[0x0-0x8a08a].ch.sudo.cyberduck[699]	        at com.sun.jna.Native.<clinit>(Native.java:118)
9/21/11 3:44:50 AM	[0x0-0x8a08a].ch.sudo.cyberduck[699]	        at org.rococoa.Foundation.<clinit>(Foundation.java:73)
9/21/11 3:44:50 AM	[0x0-0x8a08a].ch.sudo.cyberduck[699]	        at org.rococoa.Rococoa.createClass(Rococoa.java:49)
9/21/11 3:44:50 AM	[0x0-0x8a08a].ch.sudo.cyberduck[699]	        at org.rococoa.cocoa.foundation.NSObject.<clinit>(NSObject.java:28)
9/21/11 3:44:50 AM	[0x0-0x8a08a].ch.sudo.cyberduck[699]	        at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:49)
9/21/11 3:44:50 AM	[0x0-0x8a08a].ch.sudo.cyberduck[699]	        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
9/21/11 3:44:50 AM	[0x0-0x8a08a].ch.sudo.cyberduck[699]	        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
9/21/11 3:44:50 AM	[0x0-0x8a08a].ch.sudo.cyberduck[699]	        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
9/21/11 3:44:50 AM	[0x0-0x8a08a].ch.sudo.cyberduck[699]	        at java.lang.reflect.Method.invoke(Method.java:597)
9/21/11 3:44:50 AM	[0x0-0x8a08a].ch.sudo.cyberduck[699]	        at apple.launcher.LaunchRunner.run(LaunchRunner.java:115)
9/21/11 3:44:50 AM	[0x0-0x8a08a].ch.sudo.cyberduck[699]	        at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:50)
9/21/11 3:44:50 AM	[0x0-0x8a08a].ch.sudo.cyberduck[699]	        at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)

Last edited on Sep 21, 2011 at 8:13:27 AM by dkocher (previous) (diff)

comment:9 follow-up: Changed on Sep 21, 2011 at 9:28:43 AM by dkocher

I forgot a bit in the previous build. Can you please run build r9026. Sorry for the tedious task.

comment:10 in reply to: ↑ 9 Changed on Sep 21, 2011 at 12:00:57 PM by dkocher

Replying to dkocher:

I forgot a bit in the previous build. Can you please run build r9026. Sorry for the tedious task.

No more necessary. Got a stacktrace in #6242.

comment:11 follow-up: Changed on Sep 21, 2011 at 1:41:07 PM by KPV

David, Do you have a working download? Please advise. Thanks, Ken

comment:12 in reply to: ↑ 11 Changed on Sep 21, 2011 at 2:13:20 PM by dkocher

Replying to KPV:

David, Do you have a working download? Please advise. Thanks, Ken

The cause of the issue has not been identified yet and no resolution is available.

Note: See TracTickets for help on using tickets.
swiss made software