Cyberduck Mountain Duck CLI

#6248 closed defect (wontfix)

Unsupported Content-Coding: unknown

Reported by: pmathot Owned by: dkocher
Priority: high Milestone: 4.1.3
Component: webdav Version: 4.1
Severity: critical Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description (last modified by dkocher)

Hello,

I'm facing a critical issue, this is preventing me from working properly.

When trying to open or download a file from a webDAV server I'm receiving the following error:

HTTP Error: Download failed

Unsupported Content-Coding: unknown.

This is what I have in the console:

CONNECT oracle.com@stbeehive.oracle.com:443 HTTP/1.1
Host: oracle.com@stbeehive.oracle.com
Proxy-Connection: Keep-Alive
User-Agent: Cyberduck/4.1 (Mac OS X/10.6.8) (i386)
HTTP/1.0 200 Connection established
GET /content/dav/st/OCNCC%20Support%20Belgium/Public%20Documents/KM_migration_status.xlsx HTTP/1.1
Host: oracle.com@stbeehive.oracle.com
Connection: Keep-Alive
User-Agent: Cyberduck/4.1 (Mac OS X/10.6.8) (i386)
Cookie: ORA_OCSBHVE_DAV_DUMMY_TOKEN=valueofdumyabc; ORA_OCSBHVE_DAV_SESSION_TOKEN=-1110879843; ora_ocsbhv_dav_dbupdate_time=1316610732429
Cookie2: $Version=1
Authorization: Basic cGhpbGlwcGUubWF0aG90QG9yYWNsZS5jb206R29sZC1jb2FzdG5lcmFuZzE=
HTTP/1.1 200 OK
Date: Wed, 21 Sep 2011 13:15:23 GMT
Server: Oracle-Application-Server-10g
Content-Length: 18210
Set-Cookie: ORA_OCSBHVE_DAV_SESSION_TOKEN=-1110879843; Expires=Thu, 22-Sep-2011 05:15:23 GMT; Path=/content/dav
Set-Cookie: ora_ocsbhv_dav_dbupdate_time=1316610732429; Expires=Thu, 22-Sep-2011 05:15:23 GMT; Path=/content/dav
Surrogate-Control: no-store
Cache-Control: private, max-age=1
Last-Modified: Thu, 09 Dec 2010 15:26:04 GMT
Content-Encoding: unknown
Content-Language: en_US
Keep-Alive: timeout=15, max=100
Connection: Keep-Alive
Content-Type: application/vnd.openxmlformats-officedocument.spreadsheetml.sheet; charset=WINDOWS-1252

And this is what I have from the syslog:

 [0x0-0x10a10a].ch.sudo.cyberduck[5584]: 2011-09-21 15:19:18,741 [main] ERROR ch.cyberduck.ui.cocoa.model.FinderLocal - File attribute changed failed:/var/folders/zA/zAKi73dxGHOMO05GG3eIsE+++TM/-Tmp-/7c0ac870-813b-4deb-af9d-63ee68756acf/content/dav/st/OCNCC Support Belgium/Public Documents/KM_migration_status.xlsx

It used to work perfectly in version 4.0.2

Change History (12)

comment:1 Changed on Sep 21, 2011 at 1:53:18 PM by dkocher

  • Description modified (diff)
  • Summary changed from encountering "HTTP Error: Download failed Unsupported Content-Coding: unknown." when trying to open or download a file using webDAV protocol to Unsupported Content-Coding: unknown

comment:2 Changed on Sep 21, 2011 at 2:10:37 PM by dkocher

The issue is that the server is responding with an invalid Content-Encoding token. Valid values are (by The Internet Assigned Numbers Authority (IANA)):

  • gzip An encoding format produced by the file compression program "gzip" (GNU zip) as described in RFC 1952 [25]. This format is a Lempel-Ziv coding (LZ77) with a 32 bit CRC.
  • compress The encoding format produced by the common UNIX file compression program "compress". This format is an adaptive Lempel-Ziv-Welch coding (LZW).
  • deflate The "zlib" format defined in RFC 1950 [31] in combination with the "deflate" compression mechanism described in RFC 1951 [29].
  • identity The default (identity) encoding; the use of no transformation whatsoever. This content-coding is used only in the Accept- Encoding header, and SHOULD NOT be used in the Content-Encoding header.

comment:3 Changed on Sep 21, 2011 at 2:11:18 PM by dkocher

As a workaround you can enter in a Terminal.app window

defaults write ch.sudo.cyberduck http.compression.enable false

comment:4 Changed on Sep 21, 2011 at 2:11:46 PM by dkocher

  • Milestone set to 4.1.3
  • Resolution set to wontfix
  • Status changed from new to closed

Closing this because the server violates the HTTP specification.

comment:5 Changed on Sep 21, 2011 at 2:28:24 PM by pmathot

Thanks for the workaround ;)

comment:6 Changed on Sep 21, 2011 at 10:00:09 PM by 5280mike

I get this same error on Cyberduck 4.1.3 for Windows and Mac.

This workaround works fine on Mac:

defaults write ch.sudo.cyberduck http.compression.enable false

Can you please post how to perform the equivalent workaround on Windows 7?

Thanks, Mike

Last edited on May 30, 2014 at 7:27:37 AM by dkocher (previous) (diff)

comment:7 Changed on Sep 22, 2011 at 7:40:12 AM by pmathot

I believe you have to write this parameter in the windows configuration file

http.compression.enable false I'll have a check and try to tell you what to do ;)

comment:8 Changed on Sep 22, 2011 at 8:20:42 AM by pmathot

adding the following line in the user.config should do it :

                        <setting name="http.compression.enable" value="false" />

after these lines:

<?xml version="1.0" encoding="utf-8"?>
<configuration>
    <userSettings>
        <Ch.Cyberduck.Properties.Settings>
            <setting name="UpgradeSettings" serializeAs="String">
                <value>False</value>
            </setting>
            <setting name="CdSettings" serializeAs="Xml">
                <value>
                    <settings>
                        <setting name="ui.loginform.windowstate" value="PGludD4wPC9pbnQ+" />
                        <setting name="bookmark.import.org.mozdev.fireftp" value="true" />

the file is in C:\Documents and Settings\USER\Application Data\Cyberduck\Cyberduck.exe_Url_ourpw1i1uihyyu2cpvi02kp52zaghxpg\<version>

I tried and it is working

Last edited on Sep 22, 2011 at 8:22:43 AM by pmathot (previous) (diff)

comment:9 Changed on Sep 22, 2011 at 7:10:19 PM by 5280mike

The user.config entry works. Thanks!

comment:10 Changed on May 30, 2014 at 7:27:56 AM by dkocher

#6608 closed as duplicate.

comment:11 Changed on May 30, 2014 at 7:28:09 AM by dkocher

#6939 closed as duplicate.

comment:12 Changed on May 30, 2014 at 8:39:06 AM by dkocher

#7979 closed as duplicate.

Note: See TracTickets for help on using tickets.
swiss made software