Cyberduck Mountain Duck CLI

#6311 closed defect (thirdparty)

BadImageFormatException loading System.Runtime.Remoting

Reported by: YLAGARDE27 Owned by:
Priority: high Milestone:
Component: core Version: 4.1.3
Severity: normal Keywords:
Cc: Architecture:
Platform: Windows 7

Description

Hi, I have a mac and used your product for years! But I unfortunately also have to work on a pc laptop that run windows 7! Ive tried to install cyberduck two times, first I tried 2 weeks ago with version 4.0.3 and now the new version 4.1.3! Installation goes well but when i open it, it crash without doing anything... Any help please cause I really love cyberduck and I would like to use it on my pc too!!

Change History (7)

comment:1 Changed on Oct 17, 2011 at 4:54:56 AM by dkocher

Please post the cyberduck.log located in AppData.

comment:2 Changed on Oct 17, 2011 at 12:27:38 PM by YLAGARDE27

I found the Cyberduck.log file but their is nothing in it! But there is 11 files in the CrashReporter folders! Here is the last one!!! Thanks!

I cant add the document as it says that its a SPAM...

Last edited on Oct 17, 2011 at 12:30:08 PM by YLAGARDE27 (previous) (diff)

comment:3 Changed on Oct 17, 2011 at 2:29:13 PM by dkocher

Please send the crash report to feedback@cyberduck.ch.

comment:4 Changed on Oct 18, 2011 at 12:34:45 PM by dkocher

  • Platform set to Windows 7
  • Summary changed from Crash on startup to BadImageFormatException loading System.Runtime.Remoting

comment:5 Changed on Oct 18, 2011 at 12:35:00 PM by dkocher

-----------------------------
[General Info]

Application: Cyberduck
Version:     4.1.3 (9045)
Region:      French (Canada)
Machine:     YANICK_PORTABLE
User:        Yanick
Date: 2011-10-17
Time: 00:08

User Explanation:

Yanick said ""
-----------------------------

[Exception Info 1]

Top-level Exception
Type:        System.BadImageFormatException
Message:     Could not load file or assembly 'System.Runtime.Remoting, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The module was expected to contain an assembly manifest.
Source:      Microsoft.VisualBasic
Stack Trace: at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(String[] commandLine)
   at Ch.Cyberduck.Ui.Controller.MainController.Run(ICollection commandLineArgs)
   at Ch.Cyberduck.Ui.Controller.MainController.Run()
   at Ch.Cyberduck.Ui.Controller.MainController.Main()

-----------------------------

[Assembly Info]

mscorlib, Version=4.0.0.0
core, Version=4.1.3.9045
System, Version=4.0.0.0
System.Xml, Version=4.0.0.0
Microsoft.VisualBasic, Version=10.0.0.0
System.Windows.Forms, Version=4.0.0.0
StructureMap, Version=2.6.1.0
ObjectListView, Version=2.5.0.37781
IKVM.OpenJDK.Core, Version=0.46.0.1
System.Design, Version=4.0.0.0
System.Drawing, Version=4.0.0.0
Interop.Bonjour, Version=1.0.0.0
AutomaticUpdater, Version=2.6.14.0
Growl.Connector, Version=2.0.0.0
System.Core, Version=4.0.0.0
ExceptionReporter.WinForms, Version=2.1.1.0
mscorlib, Version=2.0.0.0
System.Windows.Forms, Version=2.0.0.0
System.Security, Version=4.0.0.0
IKVM.OpenJDK.Text, Version=0.46.0.1
Growl.CoreLibrary, Version=2.0.0.0
System.Drawing, Version=2.0.0.0
CustomOpenFileFolderDialog, Version=0.0.0.0
ActiveButtons, Version=1.0.0.1
Windows7.DesktopIntegration, Version=1.0.0.0

-----------------------------

[Config Settings]

<?xml version="1.0"?>
<configuration>
  <configSections>
    <sectionGroup name="userSettings" type="System.Configuration.UserSettingsGroup, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
      <section name="Ch.Cyberduck.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" allowExeDefinition="MachineToLocalUser" requirePermission="false" />
    </sectionGroup>
  </configSections>
</configuration>
-----------------------------

[System Info]

Operating System
-Microsoft Windows 7 Édition Familiale Premium
--CodeSet = 1252
--CSDVersion = Service Pack 1
--CurrentTimeZone = -240
--FreePhysicalMemory = 2107892
--OSArchitecture = 64 bits
--OSLanguage = 1036
--ServicePackMajorVersion = 1
--ServicePackMinorVersion = 0
--Version = 6.1.7601

Machine
-YANICK_PORTABLE
--Manufacturer = Hewlett-Packard
--Model = HP Pavilion dv6 Notebook PC
--TotalPhysicalMemory = 4285394944
--UserName = Yanick_Portable\Yanick

-----------------------------


comment:6 Changed on Oct 20, 2011 at 12:46:13 AM by YLAGARDE27

Is there any fix?

comment:7 Changed on Oct 20, 2011 at 5:02:56 AM by yla

  • Resolution set to thirdparty
  • Status changed from new to closed

You most probably have a corrupt .NET Framework installation (System.Runtime.Remoting is not a Cyberduck component). Try to repair the Microsoft .NET Framework 4 Client Profile (Control Panel -> Uninstall Software -> choose the .NET Framework -> right click -> Uninstall/Change -> Choose Repair. If that does not help try to uninstall/reinstall the .NET Framework.

Note: See TracTickets for help on using tickets.