Cyberduck Mountain Duck CLI

#6312 closed defect (duplicate)

Crash on startup with UnsatisfiedLinkError exception

Reported by: mick Owned by:
Priority: normal Milestone:
Component: core Version: 4.1.3
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.5

Description

ch.cyberduck.ui.cocoa.MainApplication.main(String[]) threw an exception:
java.lang.UnsatisfiedLinkError: no jnidispatch in java.library.path
  at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1753)
  at java.lang.Runtime.loadLibrary0(Runtime.java:822)

I'm not sure what broke in this situation. This copy of Cyberduck has worked for me over the past few weeks, but now it crashes on startup. I guess I'll try rebooting and restalling Cyberduck or something...

Change History (5)

comment:1 Changed on Oct 17, 2011 at 5:45:37 PM by mick

Tried rebooting & reinstalling with no change. I checked my last reboot time (using "last") and I hadn't rebooted between today and well before installing Cyberduck 4.1.3. Maybe the jnidispach library moved?

comment:2 Changed on Oct 18, 2011 at 12:38:25 PM by dkocher

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate for issue #6242.

comment:3 follow-up: Changed on Oct 18, 2011 at 10:23:00 PM by http://mick129.wordpress.com/

Hurray for a fix in the nightly builds

comment:4 in reply to: ↑ 3 Changed on Oct 19, 2011 at 1:05:46 PM by dkocher

Replying to http://mick129.wordpress.com/:

Hurray for a fix in the nightly builds

Between 4.1.3 and the latest snapshot build there was no change that would fix this therefore I am amazed you found the latest snapshot build works. Anything else that has changed in your setup?

comment:5 Changed on Jan 29, 2012 at 5:57:39 PM by dkocher

See also #6242.

Note: See TracTickets for help on using tickets.
swiss made software