Cyberduck Mountain Duck CLI

#6327 closed defect (worksforme)

Long load time ... 3+ minutes first open

Reported by: hbaumann Owned by:
Priority: normal Milestone: 4.2
Component: core Version: 4.1.3
Severity: major Keywords: speed, load time,
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description

Cyberduck seems to be taking longer and longer to open for me. It's now at 3+ minutes the first time. Subsequent opens without restarting the machine are faster but that first time is absurd. I do not remember this being so slow until recently and I'm trying to figure out why and resolve it.

I've tried reinstalling the app (cleared out all old associated files and then added it back.) I've tried using an older version of CyberDuck. (4.1.3 and went back to 4.1.2 after talk to other people running CyberDuck.) I tried installing the most current version of Java. I've tried repairing permissions.

Most of the things that run in the background like Growl, Evernote, and Dropbox I've had for a long time.

Looking for other suggestions or even incompatibilities to troubleshoot this. 3+ minutes for a program to start is insane at this day in age.

Attachments (1)

Screen shot 2011-10-27 at 6.10.30 PM.png (34.5 KB) - added by hbaumann on Oct 27, 2011 at 10:11:53 PM.
System profile overview

Download all attachments as: .zip

Change History (20)

comment:1 Changed on Oct 27, 2011 at 10:12:33 AM by dkocher

Can you find any related output in the system.log (/Applications/Utilities/Console.app)? Definitely not the usual startup time.

comment:2 Changed on Oct 27, 2011 at 3:51:19 PM by hbaumann

All that happens during that open period are Growl helper errors. I'm going to try turning off growl notifications in CyberDuck (I'm assuming I can) and see if it starts up faster next restart.

Since those are the only errors while starting CyberDuck I've them below in case it helps resolve some underlying problem. I did scan back through the logs a bit and it doesn't look like I'm getting Growl errors at any other time.

I'll let you know next restart if turning off growl resolves the lengthy startup.

Hilary Baumann | http://www.fascinationdesign.com | 859-492-1654


10/27/11 11:32:28 AM	[0x0-0x12012].com.Growl.GrowlHelperApp[198]	Thu Oct 27 11:32:28 hilary-baumanns-computer.local GrowlHelperApp[198] <Error>: kCGErrorIllegalArgument: CGSSetWindowTransformAtPlacement: Singular matrix [inf nan nan inf]
10/27/11 11:32:28 AM	[0x0-0x12012].com.Growl.GrowlHelperApp[198]	Thu Oct 27 11:32:28 hilary-baumanns-computer.local GrowlHelperApp[198] <Error>: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.
10/27/11 11:32:28 AM	[0x0-0x12012].com.Growl.GrowlHelperApp[198]	Thu Oct 27 11:32:28 hilary-baumanns-computer.local GrowlHelperApp[198] <Error>: kCGErrorIllegalArgument: CGSSetWindowTransformAtPlacement: Singular matrix [inf nan nan inf]
10/27/11 11:32:28 AM	[0x0-0x12012].com.Growl.GrowlHelperApp[198]	Thu Oct 27 11:32:28 hilary-baumanns-computer.local GrowlHelperApp[198] <Error>: kCGErrorIllegalArgument: CGSSetWindowTransformAtPlacement: Singular matrix [inf nan nan inf]
10/27/11 11:32:28 AM	[0x0-0x12012].com.Growl.GrowlHelperApp[198]	Thu Oct 27 11:32:28 hilary-baumanns-computer.local GrowlHelperApp[198] <Error>: kCGErrorIllegalArgument: CGSSetWindowTransformAtPlacement: Singular matrix [inf nan nan inf]
10/27/11 11:32:28 AM	[0x0-0x12012].com.Growl.GrowlHelperApp[198]	Thu Oct 27 11:32:28 hilary-baumanns-computer.local GrowlHelperApp[198] <Error>: kCGErrorIllegalArgument: CGSSetWindowTransformAtPlacement: Singular matrix [inf nan nan inf]
10/27/11 11:32:28 AM	[0x0-0x12012].com.Growl.GrowlHelperApp[198]	Thu Oct 27 11:32:28 hilary-baumanns-computer.local GrowlHelperApp[198] <Error>: kCGErrorIllegalArgument: CGSSetWindowTransformAtPlacement: Singular matrix [inf nan nan inf]
10/27/11 11:32:28 AM	[0x0-0x12012].com.Growl.GrowlHelperApp[198]	Thu Oct 27 11:32:28 hilary-baumanns-computer.local GrowlHelperApp[198] <Error>: kCGErrorIllegalArgument: CGSSetWindowTransformAtPlacement: Singular matrix [inf nan nan inf]
10/27/11 11:32:32 AM	[0x0-0x12012].com.Growl.GrowlHelperApp[198]	Thu Oct 27 11:32:32 hilary-baumanns-computer.local GrowlHelperApp[198] <Error>: kCGErrorIllegalArgument: CGSSetWindowTransformAtPlacement: Singular matrix [inf nan nan inf]
10/27/11 11:32:32 AM	[0x0-0x12012].com.Growl.GrowlHelperApp[198]	Thu Oct 27 11:32:32 hilary-baumanns-computer.local GrowlHelperApp[198] <Error>: kCGErrorIllegalArgument: CGSSetWindowTransformAtPlacement: Singular matrix [inf nan nan inf]
10/27/11 11:32:32 AM	[0x0-0x12012].com.Growl.GrowlHelperApp[198]	Thu Oct 27 11:32:32 hilary-baumanns-computer.local GrowlHelperApp[198] <Error>: kCGErrorIllegalArgument: CGSSetWindowTransformAtPlacement: Singular matrix [inf nan nan inf]
10/27/11 11:32:32 AM	[0x0-0x12012].com.Growl.GrowlHelperApp[198]	Thu Oct 27 11:32:32 hilary-baumanns-computer.local GrowlHelperApp[198] <Error>: kCGErrorIllegalArgument: CGSSetWindowTransformAtPlacement: Singular matrix [inf nan nan inf]
10/27/11 11:32:32 AM	[0x0-0x12012].com.Growl.GrowlHelperApp[198]	Thu Oct 27 11:32:32 hilary-baumanns-computer.local GrowlHelperApp[198] <Error>: kCGErrorIllegalArgument: CGSSetWindowTransformAtPlacement: Singular matrix [inf nan nan inf]
10/27/11 11:32:32 AM	[0x0-0x12012].com.Growl.GrowlHelperApp[198]	Thu Oct 27 11:32:32 hilary-baumanns-computer.local GrowlHelperApp[198] <Error>: kCGErrorIllegalArgument: CGSSetWindowTransformAtPlacement: Singular matrix [inf nan nan inf]
10/27/11 11:32:32 AM	[0x0-0x12012].com.Growl.GrowlHelperApp[198]	Thu Oct 27 11:32:32 hilary-baumanns-computer.local GrowlHelperApp[198] <Error>: kCGErrorIllegalArgument: CGSSetWindowTransformAtPlacement: Singular matrix [inf nan nan inf]
Last edited on Oct 27, 2011 at 7:55:22 PM by dkocher (previous) (diff)

comment:3 Changed on Oct 27, 2011 at 7:57:50 PM by dkocher

See http://trac.cyberduck.ch/wiki/help/en/howto/growl#HiddenPreference to disable Growl support to see if that makes any difference.

comment:4 Changed on Oct 27, 2011 at 9:29:29 PM by hbaumann

Still a long first open. 5:19pm - 5:22pm Error console no longer shows the growl errors. It simply doesn't show any growl errors during that time frame. I have a jungledisk error and I'm going to remove it because it's just an emergency backup I haven't used in a long long time (and it's not actually running in the background.)

Other ideas on why this is taking so long to load CyberDuck the first time????


10/27/11 5:22:07 PM	[0x0-0x19019].com.google.Chrome[220]	2011-10-27 17:22:07.773 Google Chrome Helper[290:107] __CFServiceControllerBeginPBSLoadForLocalizations received error 1100 from bootstrap_look_up2
10/27/11 5:22:12 PM	com.jungledisk.workgroupservice[50]	Exception on Startup: xSocketTimeout - HTTP connection timed out: connect() timed out!
Last edited on Nov 6, 2011 at 10:24:13 AM by dkocher (previous) (diff)

comment:5 Changed on Oct 27, 2011 at 10:07:34 PM by hbaumann

5:48pm - 5:51pm and no errors

5:55-5:59 no errors (Google Chrome NOT open)

It starting to seem like it's a precise delay, some exact amount of time between 3-4 minutes and I just haven't gone all stopwatch on it yet.

Changed on Oct 27, 2011 at 10:11:53 PM by hbaumann

System profile overview

comment:6 follow-up: Changed on Nov 6, 2011 at 10:25:29 AM by dkocher

Try to run Cyberduck in a guest account (Activate in System Preferences – Accounts) to see if that makes any difference.

comment:7 follow-up: Changed on Nov 6, 2011 at 10:51:06 AM by dkocher

If the issue remains, please enable debug logging and attach the output in Console.app. That will allow us to see where it hangs.

comment:8 Changed on Nov 7, 2011 at 10:38:55 PM by dkocher

  • Milestone set to 4.1.4

comment:9 Changed on Nov 8, 2011 at 4:05:34 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

My last advice would be to reinstall Java for Mac OS X 10.6 Update 5.

comment:10 follow-up: Changed on Nov 12, 2011 at 7:40:24 PM by hbaumann

I had already reinstalled Java before I started this ticket. I actually reinstalled Java at another point after that because I thought maybe something had gone wrong.

I didn't have time to do the debug settings the day you mentioned them and then it pissed me off to get a "closed, worksforme" so I put off working on this again for a week.

comment:11 follow-up: Changed on Nov 12, 2011 at 7:45:28 PM by hbaumann

AND I get a "submission rejected as potential spam" when I try and post my debugging info here. <sarcasm>Awesome.</sarcasm>

And there were no crash reports from today in the ~/Library/Logs/CrashReporter.

comment:12 in reply to: ↑ 11 Changed on Nov 13, 2011 at 1:31:09 PM by dkocher

Replying to hbaumann:

AND I get a "submission rejected as potential spam" when I try and post my debugging info here. <sarcasm>Awesome.</sarcasm>

And there were no crash reports from today in the ~/Library/Logs/CrashReporter.

You can send log files to feedback@….

comment:13 in reply to: ↑ 10 Changed on Nov 13, 2011 at 1:31:56 PM by dkocher

Replying to hbaumann:

I had already reinstalled Java before I started this ticket. I actually reinstalled Java at another point after that because I thought maybe something had gone wrong.

I didn't have time to do the debug settings the day you mentioned them and then it pissed me off to get a "closed, worksforme" so I put off working on this again for a week.

I tend to close tickets with no immediate response because otherwise we have hundreds of unconfirmed open bug reports.

comment:14 in reply to: ↑ 6 Changed on Nov 13, 2011 at 1:32:31 PM by dkocher

Replying to dkocher:

Try to run Cyberduck in a guest account (Activate in System Preferences – Accounts) to see if that makes any difference.

Please try this advise, it will give us a a clue if something is wrong with your account.

comment:15 Changed on Nov 21, 2011 at 5:23:18 AM by hbaumann

As I said "there were no crash reports from today in the ~/Library/Logs/CrashReporter."

I logged in as a guest and tried Cyberduck - still 3 minutes to first load so the login user isn't the problem.

comment:16 in reply to: ↑ 7 Changed on Nov 21, 2011 at 6:09:01 AM by dkocher

Replying to dkocher:

If the issue remains, please enable debug logging and attach the output in Console.app. That will allow us to see where it hangs.

Please try this then which will allow us to narrow down the culprit.

comment:17 Changed on Nov 22, 2011 at 12:45:35 PM by dkocher

The log files sent show that there is no issue with Cyberduck itself. But it looks like it is taking that long to the the virtual machine ready to launch. Can you try to reinstall Java for Mac OS X 10.6 Update 6.

comment:18 Changed on Nov 23, 2011 at 5:05:42 PM by hbaumann

How many times have I reinstalled Java? That link? Yup ... at least 3 now. But I'll try it again...

comment:19 Changed on Nov 28, 2011 at 8:45:21 PM by hbaumann

Reinstalled - no change in the problem and load time.

Note: See TracTickets for help on using tickets.
swiss made software