Cyberduck Mountain Duck CLI

#6345 closed defect (fixed)

AWS permissions used for Google Cloud Storage

Reported by: roggg Owned by: dkocher
Priority: normal Milestone: 4.2
Component: google-storage Version: 4.1.3
Severity: normal Keywords: Permissions
Cc: Architecture: Intel
Platform: Mac OS X 10.7

Description (last modified by dkocher)

I have connected to GCS, uploaded a file and try to change permissions for 'everyone' in the info pane.

I click everyone. Change access to read (or full access - bug same for both). Following error occurs:

S3 Error Message. Bad Request. The XML you provided was not well-formed or did not validate against our published schema. Invalid Google Storage Id: http://acs.amazonaws.com/groups/global/AllUsers.

Implication is that stored defaults (unchangeable by user?) are set for AWS instead of GCS. I'm surprised this hasn't been raised already - perhaps I'm doing something wrong? I def. registered this as a google account and it works to upload / dl.

_

New snapshot does not solve problem. I found that the storage manager on the google site interface is a good work around, but cyberduck still can't change permissions and shows the same error. It does seem to work ok with a couple of small images I uploaded to test, but when I deleted and reuploaded the large (3.5GB) file I am doing all this for, I could still not change permissions with cyberduck. One of the images uploaded with 'everyone' able to read..

Change History (6)

comment:1 Changed on Nov 3, 2011 at 3:21:25 PM by dkocher

  • Milestone set to 4.1.4
  • Resolution set to fixed
  • Status changed from new to closed

Please update to the latest snapshot build available which should fix this issue and bring more interoperability fixes with Google Cloud Storage. Please reopen this issue if you do not suceed with the snapshot build.

comment:2 Changed on Nov 3, 2011 at 8:07:07 PM by roggg

  • Description modified (diff)
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:3 Changed on Nov 4, 2011 at 9:01:40 AM by dkocher

  • Description modified (diff)
  • Status changed from reopened to new

comment:4 Changed on Nov 4, 2011 at 9:14:16 AM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

In r9108. Thanks for the bug report.

comment:5 Changed on Nov 4, 2011 at 10:50:06 AM by dkocher

A new snapshot build is available.

comment:6 Changed on Nov 4, 2011 at 10:54:48 AM by dkocher

Additional fix for default ACL for uploaded files in r9109.

Note: See TracTickets for help on using tickets.