Cyberduck Mountain Duck CLI

#6361 closed defect (worksforme)

"Unknown host key" warning even though "Always" is chosen

Reported by: cyperpopyber Owned by: dkocher
Priority: high Milestone:
Component: sftp Version: 4.2.1
Severity: normal Keywords:
Cc: Daps0l Architecture: Intel
Platform: Mac OS X 10.7

Description (last modified by dkocher)

hi,

i'm having the same problem as here #1671, but deleting the known_hosts did not help.

further more, i see, that with every "yes, store the key forever" klick, the key of the ftp server is added known_hosts again. so i have a known_hosts with a lot of identical entries now.

any suggestions?

those are the only errors i see in the console:

11.11.11 22:44:48,081 Cyberduck: Error loading /Users/user/Library/Contextual Menu Items/Disk Inventory X Finder CM.plugin/Contents/MacOS/Disk Inventory X Finder CM:  dlopen(/Users/user/Library/Contextual Menu Items/Disk Inventory X Finder CM.plugin/Contents/MacOS/Disk Inventory X Finder CM, 262): no suitable image found.  Did find:
	/Users/user/Library/Contextual Menu Items/Disk Inventory X Finder CM.plugin/Contents/MacOS/Disk Inventory X Finder CM: mach-o, but wrong architecture
11.11.11 22:44:48,081 Cyberduck: Cannot find function pointer AbstractCMPluginFactory for factory 29E65FF2-4AAE-11D9-A8A3-000393B64A0C in CFBundle/CFPlugIn 0x1ac090 </Users/user/Library/Contextual Menu Items/Disk Inventory X Finder CM.plugin> (bundle, not loaded)

i'm running lion 10.7.2 and cyberduck Version 4.1.3 (9045)

i remember, having this "trouble" with snow leopard too. that was an earlier version of cyberduck.

the ftp-server shows: 220 NASFTPD Turbo station 2.x 1.3.2e Server (ProFTPD) (its a qnap nas)

Change History (12)

comment:1 Changed on Nov 13, 2011 at 1:39:36 PM by dkocher

  • Component changed from core to sftp
  • Description modified (diff)
  • Owner set to dkocher

comment:2 Changed on Nov 13, 2011 at 1:42:30 PM by dkocher

  • Summary changed from me too: "Unknown host key" warning every time for SFTP, even though "Always" is chosen to "Unknown host key" warning even though "Always" is chosen

comment:3 Changed on Nov 15, 2011 at 8:56:22 PM by dkocher

Can you login to a guest account in OS X and test if you get the same trouble.

comment:4 Changed on Nov 16, 2011 at 9:42:43 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

comment:5 follow-up: Changed on Nov 20, 2011 at 6:49:03 PM by cyperpopyber

Thanks for the hint. "Works for me" too. Now I have to fiddle out, whats the problem on *my* Systems. Cheers,

comment:6 in reply to: ↑ 5 Changed on Nov 20, 2011 at 10:03:53 PM by dkocher

Replying to cyperpopyber:

Thanks for the hint. "Works for me" too. Now I have to fiddle out, whats the problem on *my* Systems. Cheers,

Please reopen the ticket if you can provide more information. I actively close tickets that miss a timely response as it is unlikely to find a resolution then. In this case I just have no idea what might be going on and can only do wild guesses not much educated. We have to narrow down the possible causes and the first step is to try it with another account.

comment:7 Changed on Apr 3, 2012 at 10:20:44 AM by Daps0l

  • Cc Daps0l added
  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version changed from 4.1.3 to 4.2.1

Hello, i have exactly the same problem; The problem seems to occur when the SSH server is running on a non-default port. For example my SSH server is running on port 11111 instead of 22.

Steps to reproduce:

  • Delete ~/.ssh/known_hosts
  • Connect to mypc.homeip.net:11111
  • Unknown host key -> check 'always' -> allow
  • 1 line added to ~/.ssh/known_hosts
  • Disconnect
  • Connect to mypc.homeip.net:11111
  • Unknown host key -> check 'always' -> allow
  • 1 line added to ~/.ssh/known_hosts (total = 2 lines now)
  • Disconnect

This continues forever, always adding another new line to the known_hosts.

So my guess is the problem probably has got something to do with the hashing of:

[mypc.homeip.net]:11111 ssh-rsa <hostkey>

for hosts with non default ports, versus:

mypc.homeip.net ssh-rsa <hostkey>

for default ports.

comment:8 Changed on Apr 3, 2012 at 12:39:46 PM by dkocher

  • Milestone set to 4.3
  • Status changed from reopened to new

comment:9 Changed on Apr 3, 2012 at 12:43:55 PM by dkocher

We do not take the server port number into account when verifying or adding keys, though.

comment:10 Changed on Apr 4, 2012 at 9:33:40 AM by dkocher

Added test in r9502.

comment:11 Changed on Jun 12, 2012 at 4:19:50 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I have tested here with running OpenSSH on port 222 on localhost with an empty known_hosts but cannot reproduce.

comment:12 Changed on Mar 22, 2013 at 10:26:58 AM by dkocher

  • Milestone 4.4 deleted
Note: See TracTickets for help on using tickets.
swiss made software