Cyberduck Mountain Duck CLI

#6365 closed defect (fixed)

The Encryption request you specified is not valid. Supported value: AES256.

Reported by: mikk Owned by: dkocher
Priority: normal Milestone: 4.2
Component: s3 Version: Nightly Build
Severity: critical Keywords:
Cc: Architecture: Intel
Platform: Windows 7

Description

Hi!

Official v4.1.3.9045 version is works correctly.

But with this snapshot build (downloaded with built in updater): v4.1.4 9177, if I upload any file to Amazon S3, I get error message: "The Encryption request you specified is not valid. Supported value: AES256."

And my suggest: Good idea, if Amazon S3 server side encryption selectable in options (preferences/S3)

Log:

GET /?delimiter=%2F&max-keys=1000&prefix HTTP/1.1
Date: Mon, 14 Nov 2011 12:34:10 GMT
Authorization: ***
Host: my.test.eu.s3.amazonaws.com:443
Connection: Keep-Alive
User-Agent: Cyberduck/4.1.4 (9177) (Windows 7/6.1) (x86)
HTTP/1.1 200 OK
x-amz-id-2: ***
x-amz-request-id: ***
Date: Mon, 14 Nov 2011 12:34:11 GMT
Content-Type: application/xml
Transfer-Encoding: chunked

Thanks.

Change History (3)

comment:1 Changed on Nov 14, 2011 at 1:12:51 PM by dkocher

  • Milestone set to 4.1.4
  • Status changed from new to assigned

comment:2 follow-up: Changed on Nov 14, 2011 at 1:16:37 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r9229.

comment:3 in reply to: ↑ 2 Changed on Nov 16, 2011 at 4:33:05 AM by mikk

Replying to dkocher:

In r9229.

I see 9241 version, this is works, problem is solved, thank you.

Note: See TracTickets for help on using tickets.
swiss made software