Cyberduck Mountain Duck CLI

#6439 closed defect (duplicate)

Cyberduck will not launch after updating to Cyberduck 4.2.1 on Mac OSX 10.6.2

Reported by: meganf Owned by:
Priority: high Milestone:
Component: core Version: 4.2
Severity: major Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description

Hi, I recently upgraded from 4.0.2 to the latest version (4.2.1) on Mac OSX 10.6.2. After hitting "Install and Relaunch", the duck icon bounced in my dock but never actually launched. I tried to go back to the old version that worked before I updated, but it didn't launch either. I tried downloading the zipped version of 4.2.1 from the website and installing that, no luck. I tried deleting the .plist file and application support files, no luck. I tried trashing / uninstalling the app, restarting the computer, and re-installing 4.2.1, no luck. Then I tried my boss's suggestion of restarting while holding down command-option-p-r to reset the PRAM / NVRAM, uninstalled the app, reinstalled the app, no luck.

This is what was in the console utility's logs from my most recent attempt:

12/12/11 4:36:59 PM	[0x0-0x20020].ch.sudo.cyberduck[166]	[LaunchRunner Error] ch.cyberduck.ui.cocoa.MainApplication.main(String[]) threw an exception:
12/12/11 4:36:59 PM	[0x0-0x20020].ch.sudo.cyberduck[166]	java.lang.UnsatisfiedLinkError: no jnidispatch in java.library.path
12/12/11 4:36:59 PM	[0x0-0x20020].ch.sudo.cyberduck[166]		at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1809)
12/12/11 4:36:59 PM	[0x0-0x20020].ch.sudo.cyberduck[166]		at java.lang.Runtime.loadLibrary0(Runtime.java:823)
12/12/11 4:36:59 PM	[0x0-0x20020].ch.sudo.cyberduck[166]		at java.lang.System.loadLibrary(System.java:1045)
12/12/11 4:36:59 PM	[0x0-0x20020].ch.sudo.cyberduck[166]		at com.sun.jna.Native.loadNativeLibrary(Native.java:669)
12/12/11 4:36:59 PM	[0x0-0x20020].ch.sudo.cyberduck[166]		at com.sun.jna.Native.<clinit>(Native.java:118)
12/12/11 4:36:59 PM	[0x0-0x20020].ch.sudo.cyberduck[166]		at org.rococoa.Foundation.<clinit>(Foundation.java:73)
12/12/11 4:36:59 PM	[0x0-0x20020].ch.sudo.cyberduck[166]		at org.rococoa.Rococoa.createClass(Rococoa.java:49)
12/12/11 4:36:59 PM	[0x0-0x20020].ch.sudo.cyberduck[166]		at org.rococoa.cocoa.foundation.NSObject.<clinit>(NSObject.java:28)
12/12/11 4:36:59 PM	[0x0-0x20020].ch.sudo.cyberduck[166]		at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:46)
12/12/11 4:36:59 PM	[0x0-0x20020].ch.sudo.cyberduck[166]		at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
12/12/11 4:36:59 PM	[0x0-0x20020].ch.sudo.cyberduck[166]		at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
12/12/11 4:36:59 PM	[0x0-0x20020].ch.sudo.cyberduck[166]		at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
12/12/11 4:36:59 PM	[0x0-0x20020].ch.sudo.cyberduck[166]		at java.lang.reflect.Method.invoke(Method.java:597)
12/12/11 4:36:59 PM	[0x0-0x20020].ch.sudo.cyberduck[166]		at apple.launcher.LaunchRunner.run(LaunchRunner.java:115)
12/12/11 4:36:59 PM	[0x0-0x20020].ch.sudo.cyberduck[166]		at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:50)
12/12/11 4:36:59 PM	[0x0-0x20020].ch.sudo.cyberduck[166]		at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)

By the way, none of the previous versions on your changelog page are downloadable, they just go to a broken page, in case you didn't know.

Change History (2)

comment:1 Changed on Dec 13, 2011 at 8:57:50 AM by dkocher

  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 Changed on Dec 13, 2011 at 2:35:26 PM by meganf

But it says "This release is only for Mac OS X v10.6.8." and I only have 10.6.2

Note: See TracTickets for help on using tickets.
swiss made software