Cyberduck Mountain Duck CLI

#6492 closed defect (thirdparty)

Firewall allow/deny incoming connections prompt

Reported by: paulg Owned by: dkocher
Priority: normal Milestone:
Component: core Version: 4.2.1
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.7

Description

Environment:

  • Mac OS X 10.7.2
  • Cyberduck 4.2.1 (9350)
  • OS X Firewall is turned on and cyberduck is not listed in the allowed applications list.

Problem: The first time you attempt to login to any service after cyberduck is started a dialogue is shown then dismissed again far too fast to read it. I resorted to taking a video of the screen (which can be done using Quicktime Player and choosing 'New Screen Recording' in recent versions of OS X). Having taken the video and freeze framing it the dialogue box turned out to be firewall allow/deny incoming connections box.

I have not including any transcript as this happens on login and nothing has been printed in the log window at that point.

Workaround: I imagine this problem can be worked around by configuring the firewall manually to accept, or deny, connections to cyberduck but I have not tried it.

Change History (4)

comment:1 Changed on Jan 23, 2012 at 9:28:56 AM by dkocher

  • Milestone set to 4.3
  • Owner set to dkocher
  • Status changed from new to assigned
  • Summary changed from If firewall is on and cyberduck is not already allowed a dialogue is shown which disappears before it can be interacted with to Firewall allow/deny incoming connections prompt

That is annoying. We have to find out if we cause this (which we should not as we are never accepting incoming connections but when active FTP connections are used) or this is a generic issue out of our control.

comment:2 Changed on Oct 6, 2012 at 10:25:59 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from assigned to closed

I cannot find the cause of this issue and it seems it is out of our control.

comment:3 Changed on Oct 10, 2012 at 6:01:41 PM by Matt Clare

Other sites suggest that it's only displayed while the socket is open. So if Cyberduck concludes that a host is unreachable and closes the socket the prompt will go away. -- I've never seen a single line of Cyberduck's code though.

comment:4 Changed on Mar 22, 2013 at 10:11:11 AM by dkocher

  • Milestone 4.4 deleted
Note: See TracTickets for help on using tickets.