Cyberduck Mountain Duck CLI

#6521 closed enhancement (fixed)

Update client library

Reported by: Juhieta Owned by: dkocher
Priority: normal Milestone: 4.5
Component: azure Version: 4.2.1
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

Hi,

I purchased the application from Mac App Store to connect Windows Azure Storage (blob storage).

The Mac App Store version had some problems to connect to Windows Azure, so I installed the latest version from the website (4.2.1).

However, even with this version, when I enter my credentials correctly and try to connect, I get the following error:

##
DNS Error: Connection failed
blob.core.windows.net
##

The problem seems to be that Cyberduck formulates the Azure Storage URL as follows (where MYACCOUNT is my account name):

https://MYACCOUNT@blob.core.windows.net

While it should be:

https://MYACCOUNT.blob.core.windows.net

This completely breaks Azure compatibility of Cyberduck.

Change History (25)

comment:1 Changed on Jan 31, 2012 at 7:06:50 PM by Juhieta

  • Description modified (diff)

comment:2 Changed on Feb 1, 2012 at 12:41:47 PM by dkocher

  • Description modified (diff)
  • Milestone set to 4.3

comment:3 Changed on Feb 1, 2012 at 2:13:11 PM by dkocher

The other issue refers to #6468.

comment:4 Changed on Feb 1, 2012 at 2:14:23 PM by dkocher

This is very much a duplicate of #6246 although the default hostname should possibly be changed. I will have to read up on the Azure documentation.

comment:5 follow-up: Changed on Feb 1, 2012 at 7:05:24 PM by Juhieta

Ok, hopefully this can be fixed soon!

comment:6 in reply to: ↑ 5 ; follow-up: Changed on Feb 2, 2012 at 8:30:31 AM by dkocher

Replying to Juhieta:

Ok, hopefully this can be fixed soon!

Until then the workaround described (enter the hostname manually) should work for you.

comment:7 in reply to: ↑ 6 ; follow-up: Changed on Feb 7, 2012 at 8:39:17 AM by Juhieta

Replying to dkocher:

Replying to Juhieta:

Ok, hopefully this can be fixed soon!

Until then the workaround described (enter the hostname manually) should work for you.

That would be nice, but I can't find a way to change the hostname manually (not found from the other ticket either). Can you describe the steps to change the full url manually?

comment:8 in reply to: ↑ 7 ; follow-up: Changed on Feb 14, 2012 at 3:33:25 PM by dkocher

Replying to Juhieta:

Replying to dkocher:

Replying to Juhieta:

Ok, hopefully this can be fixed soon!

Until then the workaround described (enter the hostname manually) should work for you.

That would be nice, but I can't find a way to change the hostname manually (not found from the other ticket either). Can you describe the steps to change the full url manually?

This is possible in both the Connection and Bookmark windows.

comment:9 in reply to: ↑ 8 ; follow-up: Changed on Feb 25, 2012 at 2:27:35 PM by Juhieta

Replying to dkocher:

Replying to Juhieta:

Replying to dkocher:

Replying to Juhieta:

Ok, hopefully this can be fixed soon!

Until then the workaround described (enter the hostname manually) should work for you.

That would be nice, but I can't find a way to change the hostname manually (not found from the other ticket either). Can you describe the steps to change the full url manually?

This is possible in both the Connection and Bookmark windows.

Unfortunately it is not possible (or at least I can't find a way how). I'm only unable to change the "Server" (not the final URL).

The orignal problem was:

If I enter to Server field "blob.core.windows.net" and to Username field my Azure account name, the application formulates the URL as:

ACCOUNTNAME@blob.core.windows.net

While it should be:

ACCOUNTNAME.blob.core.windows.net

If I now enter to Server field "ACCOUNTNAME.blob.core.windows.net" and try to leave Username field empty, the application will not allow to connect until I also give the Username. And that will result to:

ACCOUNTNAME@ACCOUNTNAME.blob.core.windows.net

If you really think it should be possible to fix the result URL, could you please give step by step instructions.

Last edited on Feb 25, 2012 at 2:30:47 PM by Juhieta (previous) (diff)

comment:10 in reply to: ↑ 9 Changed on Mar 2, 2012 at 9:32:09 PM by dkocher

Replying to Juhieta:

I will have to check with my own account. But there should still be a access key that you must use as the username in the login credentials.

comment:11 Changed on Mar 2, 2012 at 9:43:44 PM by dkocher

We will need to update switch our client library implementation to Windows Azure SDK for Java.

comment:12 Changed on Mar 5, 2012 at 9:55:51 PM by Juhieta

Ok, great to hear that something can be done to fix this!

comment:13 Changed on Mar 14, 2012 at 2:14:27 PM by dkocher

#6581 closed as duplicate.

comment:14 follow-up: Changed on Jul 10, 2012 at 3:58:20 PM by Alexey Palazhchenko

Looks like there are no workarounds? Small bugfix release maybe? Please.

comment:15 in reply to: ↑ 14 Changed on Aug 1, 2012 at 3:19:16 PM by stevenrobert

Replying to Alexey Palazhchenko:

Looks like there are no workarounds? Small bugfix release maybe? Please.

Same issue here, would really like to use this tool, but connectivity to Azure not working, will likely have to abandon for something else until fix made available.

comment:16 Changed on Feb 27, 2013 at 5:09:30 PM by g1ngernut

+1 for this to be fixed please.

The issue means it is impossible to connect to Azure. (I have just downloaded the Windows version of Cyberduck 4.2.1 and very disappointed.)

comment:17 Changed on Apr 5, 2013 at 5:32:07 PM by dkocher

  • Milestone 4.4 deleted
  • Owner changed from yla to dkocher
  • Priority changed from highest to normal
  • Status changed from new to assigned
  • Type changed from defect to enhancement

We have removed Azure support completly in r9474 until we reintroduce support using new API.

comment:18 Changed on Apr 15, 2013 at 9:18:47 AM by dkocher

  • Summary changed from Unable to connect to Windows Azure Storage to Update client library

comment:19 Changed on Aug 18, 2013 at 12:23:54 PM by dkocher

Azure protocol support is currently not available.

comment:20 Changed on Nov 22, 2013 at 11:40:09 PM by b e

If you want Azure support brought back to Cyberduck, leave your opinion here.

I definitely want Azure support back.

Last edited on Nov 24, 2013 at 12:14:35 PM by dkocher (previous) (diff)

comment:21 Changed on Jan 24, 2014 at 10:20:37 AM by dkocher

  • Milestone set to 4.5

comment:22 Changed on Jan 28, 2014 at 8:06:16 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r14248.

comment:23 Changed on Jan 30, 2014 at 1:42:29 PM by dkocher

Enable support in current snapshot builds with setting the hidden property connection.protocol.azure.enable to true

defaults write ch.sudo.cyberduck connection.protocol.azure.enable true

Last edited on Jan 30, 2014 at 1:54:19 PM by dkocher (previous) (diff)

comment:24 Changed on Jan 30, 2014 at 1:59:43 PM by dkocher

Download the Azure connection profile to enable Windows Azure Storage support in the current snapshot builds.

comment:25 Changed on Apr 25, 2014 at 12:28:24 PM by dkocher

Enabled by default in r14518.

Note: See TracTickets for help on using tickets.
swiss made software