Cyberduck Mountain Duck CLI

#6538 closed defect (fixed)

No files visible connecting to box.net

Reported by: Mknart Owned by: dkocher
Priority: normal Milestone: 4.3
Component: webdav Version: 4.2.1
Severity: major Keywords: box.net webdav
Cc: Architecture: Intel
Platform: Windows 7

Description

  1. New connection:

Server: www.box.net

Port: 443

User: (user)

Pass: (pass)

Path: /dav/

=> Generated URL: https://(user)@www.box.net:443/dav

  1. Connection complete.

Path is /dav. No files or subdirectories visible.

  1. Click path, go to root (from /dav to /).

Login window pops up that points to www.box.com:443.box.net/dav ???

Fill in (user) and (pass)

/dav root directory visible

  1. Doubleclick subfolder in list.

Path is /dav/subfolder.

No files visible.

Running Windows 7.

Change History (11)

comment:1 Changed on Feb 14, 2012 at 3:22:47 PM by dkocher

  • Milestone set to 4.3
  • Platform set to Windows 7
  • Status changed from new to assigned
  • Summary changed from box.net not working to No files visible connecting to box.net

I can replicate the issue.

comment:2 Changed on Mar 16, 2012 at 8:02:22 AM by dkocher

#6538 closed as duplicate.

comment:3 Changed on May 22, 2012 at 7:53:44 AM by limex

It worked for me after some changes:

  • WebDAV (HTTP/SSL)
  • Server: box.net (ATTENTION: net instead of com)
  • Port: 443
  • give Username & Password
  • Path: <empty>

Pressung Connect shows a warning about an Certificate (maybe because box.net different from box.com). I accepted it.

I saw the dir listing. When I clicked on a folder, he asks me for credentials again. I tell'em and after then, all works fine. I dunno why it works but it does. I didn't do a deeper analysis on it.

Last edited on May 22, 2012 at 7:55:58 AM by limex (previous) (diff)

comment:4 Changed on Jun 5, 2012 at 12:38:31 AM by mself

Hi David,

If you contact me here at Box we can help figure out what's going on here and resolve this. Thanks,

--Matthew

comment:5 Changed on Jul 3, 2012 at 4:37:23 AM by fasuin

I confirm that with the new version it does not work anymore. I used ver 4.0.2 for osx, and it worked like a charm to connect to box.net using webdav. I then upgraded to the latest version (4.2.1) and it doesn't work anymore. It keep asking for username and pwd. Then, once logged in, it pretends to go to https://www.box.net/dav But my files are in https://www.box.net/ [no /dav/ ...] this breaks everything... Switched back to 4.0.2 Hope this helps

comment:6 Changed on Jul 16, 2012 at 10:23:37 AM by dkocher

#6752 closed as duplicate.

comment:7 Changed on Oct 10, 2012 at 8:34:08 PM by dkocher

Another box.com interoperability issue in #6528.

comment:8 Changed on Oct 10, 2012 at 8:34:28 PM by dkocher

Another box.com interoperability issue in #6529.

comment:9 Changed on Oct 10, 2012 at 8:35:14 PM by dkocher

See also #6767.

comment:10 Changed on Apr 8, 2013 at 5:40:50 PM by dkocher

  • Milestone changed from 4.4 to 4.3
  • Resolution set to fixed
  • Status changed from assigned to closed

Changes in authentication handler in r10820 will possibly fix this. Please reopen if still an issue with the current snapshot build.

comment:11 Changed on Apr 8, 2013 at 5:48:13 PM by mself

Box has changed their WebDAV URL to https://dav.box.com/dav. This new version at this URL should have better interoperability that the previous one. Thanks.

Note: See TracTickets for help on using tickets.
swiss made software