Cyberduck Mountain Duck CLI

#6550 closed defect (worksforme)

Run out of window handles

Reported by: southstar Owned by: yla
Priority: high Milestone: 5.0
Component: core Version: 4.2.1
Severity: major Keywords:
Cc: Architecture:
Platform: Windows 7

Description

When I attempt to upload or download a file, Cyberduck crashes. I have attached two crash reports for this problem.

Thank you for your help.

Attachments (2)

Ticket #1.txt (5.4 KB) - added by southstar on Feb 20, 2012 at 4:02:12 PM.
Ticket #2.txt (3.3 KB) - added by southstar on Feb 20, 2012 at 4:02:20 PM.

Download all attachments as: .zip

Change History (24)

Changed on Feb 20, 2012 at 4:02:12 PM by southstar

Changed on Feb 20, 2012 at 4:02:20 PM by southstar

comment:1 Changed on Feb 22, 2012 at 9:03:53 AM by dkocher

  • Milestone set to 4.3
  • Owner changed from Lauren Wilson to yla

comment:2 Changed on Aug 20, 2012 at 2:14:34 PM by yla

Does this always happen or just after some time using Cyberduck?

comment:3 Changed on Aug 21, 2012 at 1:00:47 PM by yla

  • Summary changed from Cyberduck crashes when uploading or downloading to Run out of window handles

comment:4 Changed on Dec 17, 2012 at 2:28:31 PM by yla

  • Resolution set to fixed
  • Status changed from new to closed

In r10663.

comment:5 Changed on Mar 22, 2013 at 10:13:19 AM by dkocher

  • Milestone changed from 4.4 to 4.2.2

comment:6 Changed on Apr 23, 2013 at 10:16:00 AM by dkocher

Additional fixes in r10893, r10894, r10895, r10896.

comment:7 Changed on Oct 16, 2013 at 7:27:43 AM by dkocher

  • Milestone changed from 4.3 to 4.4

Refactor form create/dispose in r13459.

comment:8 Changed on Dec 9, 2014 at 1:40:11 PM by dkocher

  • Milestone changed from 4.4 to 4.7
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:9 Changed on Dec 9, 2014 at 1:40:48 PM by dkocher

#8407 closed as duplicate.

comment:10 Changed on Dec 9, 2014 at 1:41:10 PM by dkocher

#7733 closed as duplicate.

comment:11 Changed on Dec 9, 2014 at 1:41:26 PM by dkocher

Caused by: cli.System.ComponentModel.Win32Exception: Error creating window handle.
2014-12-09 13:24:47,656 [background-3] ERROR AsyncController - Unhandled exception during invoke
cli.System.ComponentModel.Win32Exception: Error creating window handle.
	at cli.System.Windows.Forms.Control.MarshaledInvoke(Unknown Source)
	at cli.System.Windows.Forms.Control.Invoke(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.AsyncController.invoke(Unknown Source)
	at IKVM.Internal.ExceptionHelper.toString(Unknown Source)
	at java.lang.Throwable.toString(map.xml:1315)
	at java.lang.Object.toString(map.xml)
	at java.lang.StringHelper.valueOf(StringHelper.java:2390)
	at java.io.PrintWriter.println(PrintWriter.java:754)
	at java.lang.ThrowableHelper$WrappedPrintWriter.println(ThrowableHelper.java:343)
	at java.lang.ThrowableHelper.printStackTrace(ThrowableHelper.java:231)
	at java.lang.ThrowableHelper.printStackTrace(ThrowableHelper.java:300)
	at java.lang.Throwable.printStackTrace(map.xml:1188)
	at org.apache.log4j.DefaultThrowableRenderer.render(DefaultThrowableRenderer.java:60)
	at org.apache.log4j.spi.ThrowableInformation.getThrowableStrRep(ThrowableInformation.java:87)
	at org.apache.log4j.spi.LoggingEvent.getThrowableStrRep(LoggingEvent.java:413)
	at org.apache.log4j.WriterAppender.subAppend(WriterAppender.java:313)
	at org.apache.log4j.RollingFileAppender.subAppend(RollingFileAppender.java:277)
	at org.apache.log4j.WriterAppender.append(WriterAppender.java:163)
	at org.apache.log4j.AppenderSkeleton.doAppend(AppenderSkeleton.java:252)
	at org.apache.log4j.helpers.AppenderAttachableImpl.appendLoopOnAppenders(AppenderAttachableImpl.java:64)
	at org.apache.log4j.Category.callAppenders(Category.java:206)
	at org.apache.log4j.Category.forcedLog(Category.java:392)
	at org.apache.log4j.Category.error(Category.java:324)
	at cli.Ch.Cyberduck.Ui.Controller.AsyncController.invoke(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.WindowController.invoke(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.MainController.<ApplicationDidFinishLaunching>b__e(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.AsyncDelegateBackgroundAction.cleanup(Unknown Source)
	at ch.cyberduck.ui.AbstractController$BackgroundCallable$1.run(AbstractController.java:206)
	at cli.Ch.Cyberduck.Ui.Controller.BaseController.invoke(Unknown Source)
	at ch.cyberduck.ui.AbstractController.invoke(AbstractController.java:64)
	at ch.cyberduck.ui.AbstractController$BackgroundCallable.call(AbstractController.java:202)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:167)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:604)
	at ch.cyberduck.core.threading.NamedThreadFactory$1.run(NamedThreadFactory.java:58)
	at java.lang.Thread.run(Thread.java:937)

comment:12 Changed on Dec 9, 2014 at 1:51:35 PM by dkocher

#8334 closed as duplicate.

comment:13 follow-up: Changed on Dec 9, 2014 at 2:21:37 PM by nick-necgroup

Hi Ticket 8407 that has been marked as duplicate and added to this. Has a fix actually been found as I am no clearer to what the issue is or how to fix it.

Thanks

comment:14 in reply to: ↑ 13 Changed on Dec 9, 2014 at 2:34:15 PM by dkocher

Replying to nick-necgroup:

Hi Ticket 8407 that has been marked as duplicate and added to this. Has a fix actually been found as I am no clearer to what the issue is or how to fix it.

Thanks

No, we have no resolution yet for this.

comment:15 Changed on Apr 14, 2015 at 8:41:20 PM by dkocher

#8744 closed as duplicate.

comment:16 Changed on Apr 17, 2015 at 2:05:59 PM by dkocher

#8747 closed as duplicate.

comment:17 Changed on Aug 21, 2015 at 12:29:44 PM by dkocher

#8972 closed as duplicate.

comment:18 Changed on Sep 11, 2015 at 11:16:39 AM by dkocher

  • Milestone set to 4.8

#9008 closed as duplicate.

comment:19 Changed on Sep 14, 2015 at 9:00:14 AM by dkocher

Try to remove all items from the transfer window. If you cannot open the Transfers window, remove the directory Transfers in the application support directory and restart Cyberduck.

comment:20 Changed on Oct 30, 2015 at 8:11:06 AM by dkocher

#9084 closed as duplicate.

comment:21 Changed on May 18, 2016 at 3:29:03 PM by dkocher

  • Milestone 5.0 deleted

comment:22 Changed on May 24, 2016 at 7:48:43 PM by dkocher

  • Milestone set to 5.0
  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.
swiss made software