Cyberduck Mountain Duck CLI

#6573 closed defect (fixed)

Cannot crete folder on Webdav: I/O error unsupported file type

Reported by: Daggerquill Owned by: dkocher
Priority: normal Milestone: 4.3
Component: webdav Version: 4.2.1
Severity: normal Keywords: webdav xythos folder
Cc: Architecture: Intel
Platform: Mac OS X 10.7

Description (last modified by Daggerquill)

When attempting to create folder 'testfolder1' on WebDAV server via https, I get error:

I/O Error: cannot create folder testfolder1
Unsupported Media Type

Other WebDAV functions (authentication, file upload/download, etc.) appear to work normally.

I first noticed when attempting to connect to a Xythos WebDAV (Apache Tomcat/Coyote) server on OS X 10.7.3, but it seems server and platform agnostic, and probably related to Ticket #6540

The problem seems to have been introduced at some point in the 4.1.x or 4.2.x tree. I was able to create a Folder as recently as this morning using 4.0.5, but creation fails consistently since upgrading to 4.2.1 around noon today.

Log snippet:

MKCOL /users/*****/testfolder1/ HTTP/1.1
Content-Type: text/xml; charset=utf-8
Content-Length: 0
Host: ***.***.edu
Connection: Keep-Alive
User-Agent: Cyberduck/4.2.1 (Mac OS X/10.7.3) (i386)
Cookie: XythosSessionID1=[B@1361731--2017326351; xyc_XythosGroupDigest1=2CE8CEE95E83148FDAA840036333042790F1D893
Cookie2: $Version=1
Authorization: Basic anNhdmFnZTprYWx5cHNPNTc3NQ==
HTTP/1.1 415 Unsupported Media Type
Server: Apache-Coyote/1.1
Cache-Control: no-cache
Pragma: no-cache
Date: Fri, 02 Mar 2012 17:57:02 GMT
Content-Type: text/html;charset=UTF-8
Content-Length: 63

Full log, from authentication to failure:

PROPFIND /users/*****/ HTTP/1.1
Depth: 1
Content-Type: text/xml; charset=utf-8
Content-Length: 99
Host: ***.***.edu
Connection: Keep-Alive
User-Agent: Cyberduck/4.2.1 (Mac OS X/10.7.3) (i386)
HTTP/1.1 401 Unauthorized
Server: Apache-Coyote/1.1
Date: Fri, 02 Mar 2012 18:13:39 GMT
WWW-Authenticate: BASIC realm="***.***.edu"
Cache-Control: no-cache
Pragma: no-cache
Content-Type: text/html;charset=UTF-8
Content-Length: 182
PROPFIND /users/*****/ HTTP/1.1
Depth: 1
Content-Type: text/xml; charset=utf-8
Content-Length: 99
Host: ***.***.edu
Connection: Keep-Alive
User-Agent: Cyberduck/4.2.1 (Mac OS X/10.7.3) (i386)
Authorization: Basic anNhdmFnZTprYWx5cHNPNTc3NQ==
HTTP/1.1 207 Multi-Status
Server: Apache-Coyote/1.1
Set-Cookie: xyc_XythosGroupDigest1=2CE8CEE95E83148FDAA840036333042790F1D893; Expires=Sat, 03-Mar-2012 18:13:40 GMT; Path=/; Secure
Set-Cookie: XythosSessionID1=[B@1361731--2017326351; Expires=Sat, 03-Mar-2012 18:13:40 GMT; Path=/; Secure
Date: Fri, 02 Mar 2012 18:13:39 GMT
Content-Type: text/xml;charset=UTF-8
Transfer-Encoding: chunked
Content-Encoding: gzip
Vary: Accept-Encoding
MKCOL /users/*****/testfolder1/ HTTP/1.1
Content-Type: text/xml; charset=utf-8
Content-Length: 0
Host: ***.***.edu
Connection: Keep-Alive
User-Agent: Cyberduck/4.2.1 (Mac OS X/10.7.3) (i386)
Cookie: XythosSessionID1=[B@1361731--2017326351; xyc_XythosGroupDigest1=2CE8CEE95E83148FDAA840036333042790F1D893
Cookie2: $Version=1
Authorization: Basic anNhdmFnZTprYWx5cHNPNTc3NQ==
HTTP/1.1 415 Unsupported Media Type
Server: Apache-Coyote/1.1
Cache-Control: no-cache
Pragma: no-cache
Date: Fri, 02 Mar 2012 18:13:55 GMT
Content-Type: text/html;charset=UTF-8
Content-Length: 63
MKCOL /users/*****/testfolder1/ HTTP/1.1
Content-Type: text/xml; charset=utf-8
Content-Length: 0
Host: ***.***.edu
Connection: Keep-Alive
User-Agent: Cyberduck/4.2.1 (Mac OS X/10.7.3) (i386)
Cookie: XythosSessionID1=[B@1361731--2017326351; xyc_XythosGroupDigest1=2CE8CEE95E83148FDAA840036333042790F1D893
Cookie2: $Version=1
Authorization: Basic anNhdmFnZTprYWx5cHNPNTc3NQ==
HTTP/1.1 415 Unsupported Media Type
Server: Apache-Coyote/1.1
Cache-Control: no-cache
Pragma: no-cache
Date: Fri, 02 Mar 2012 18:13:59 GMT
Content-Type: text/html;charset=UTF-8
Content-Length: 63

Change History (7)

comment:1 Changed on Mar 2, 2012 at 6:25:12 PM by Daggerquill

  • Description modified (diff)

comment:2 Changed on Mar 2, 2012 at 6:30:26 PM by dkocher

  • Milestone set to 4.3

comment:3 Changed on Mar 2, 2012 at 6:35:05 PM by Daggerquill

For comparison, this is the log from a successful run on 4.0.2, from login to folder creation.

What immediately stands out is that 4.2.1 appends a trailing slash to the uri in the MKCOL request where 4.0.2 didn't:

PROPFIND /users/***** HTTP/1.1
Content-Type: text/xml; charset=utf-8
User-Agent: Cyberduck/4.0.2 (Mac OS X/10.7.3) (i386)
Host: ***.***.edu
Content-Length: 207
Depth: 0

HTTP/1.1 401 Unauthorized
HTTP/1.1 401 Unauthorized
Server: Apache-Coyote/1.1
Date: Fri, 02 Mar 2012 18:25:51 GMT
WWW-Authenticate: BASIC realm=***.***.edu
Cache-Control: no-cache
Pragma: no-cache
Content-Type: text/html;charset=UTF-8
Content-Length: 182

PROPFIND /users/***** HTTP/1.1
Content-Type: text/xml; charset=utf-8
User-Agent: Cyberduck/4.0.2 (Mac OS X/10.7.3) (i386)
Content-Length: 207
Authorization: Basic anNhdmFnZTprYWx5cHNPNTc3NQ==
Host: ***.***.edu
Depth: 0

HTTP/1.1 207 Multi-Status
HTTP/1.1 207 Multi-Status
Server: Apache-Coyote/1.1
Set-Cookie: xyc_XythosGroupDigest1=2CE8CEE95E83148FDAA840036333042790F1D893; Expires=Sat, 03-Mar-2012 18:25:53 GMT; Path=/; Secure
Set-Cookie: XythosSessionID1=[B@1361731--2017326351; Expires=Sat, 03-Mar-2012 18:25:53 GMT; Path=/; Secure
Date: Fri, 02 Mar 2012 18:25:53 GMT
Content-Type: text/xml;charset=UTF-8
Content-Length: 813

PROPFIND /users/*****/ HTTP/1.1
Authorization: Basic anNhdmFnZTprYWx5cHNPNTc3NQ==
Content-Type: text/xml; charset=utf-8
User-Agent: Cyberduck/4.0.2 (Mac OS X/10.7.3) (i386)
Host: myfiles.fordham.edu
Cookie: $Version=0; xyc_XythosGroupDigest1=2CE8CEE95E83148FDAA840036333042790F1D893; $Path=/
Cookie: $Version=0; XythosSessionID1=[B@1361731--2017326351; $Path=/
Content-Length: 207
Depth: 0

HTTP/1.1 207 Multi-Status
HTTP/1.1 207 Multi-Status
Server: Apache-Coyote/1.1
Date: Fri, 02 Mar 2012 18:25:53 GMT
Content-Type: text/xml;charset=UTF-8
Content-Length: 813

PROPFIND /users/jsavage/ HTTP/1.1
Authorization: Basic anNhdmFnZTprYWx5cHNPNTc3NQ==
Content-Type: text/xml; charset=utf-8
User-Agent: Cyberduck/4.0.2 (Mac OS X/10.7.3) (i386)
Host: myfiles.fordham.edu
Cookie: $Version=0; xyc_XythosGroupDigest1=2CE8CEE95E83148FDAA840036333042790F1D893; $Path=/
Cookie: $Version=0; XythosSessionID1=[B@1361731--2017326351; $Path=/
Content-Length: 207
Depth: 1

HTTP/1.1 207 Multi-Status
HTTP/1.1 207 Multi-Status
Server: Apache-Coyote/1.1
Date: Fri, 02 Mar 2012 18:25:53 GMT
Content-Type: text/xml;charset=UTF-8
Content-Length: 13962

MKCOL /users/*****/testfodler1 HTTP/1.1
Authorization: Basic anNhdmFnZTprYWx5cHNPNTc3NQ==
User-Agent: Cyberduck/4.0.2 (Mac OS X/10.7.3) (i386)
Host: myfiles.fordham.edu
Cookie: $Version=0; xyc_XythosGroupDigest1=2CE8CEE95E83148FDAA840036333042790F1D893; $Path=/
Cookie: $Version=0; XythosSessionID1=[B@1361731--2017326351; $Path=/

HTTP/1.1 201 Created
HTTP/1.1 201 Created
Server: Apache-Coyote/1.1
Cache-Control: no-cache
Pragma: no-cache
Date: Fri, 02 Mar 2012 18:26:08 GMT
Content-Type: text/html;charset=UTF-8
Content-Length: 0

PROPFIND /users/*****/ HTTP/1.1
Authorization: Basic anNhdmFnZTprYWx5cHNPNTc3NQ==
Content-Type: text/xml; charset=utf-8
User-Agent: Cyberduck/4.0.2 (Mac OS X/10.7.3) (i386)
Host: ***.***.edu
Cookie: $Version=0; xyc_XythosGroupDigest1=2CE8CEE95E83148FDAA840036333042790F1D893; $Path=/
Cookie: $Version=0; XythosSessionID1=[B@1361731--2017326351; $Path=/
Content-Length: 207
Depth: 0

HTTP/1.1 207 Multi-Status
HTTP/1.1 207 Multi-Status
Server: Apache-Coyote/1.1
Date: Fri, 02 Mar 2012 18:26:08 GMT
Content-Type: text/xml;charset=UTF-8
Content-Length: 813

PROPFIND /users/*****/ HTTP/1.1
Authorization: Basic anNhdmFnZTprYWx5cHNPNTc3NQ==
Content-Type: text/xml; charset=utf-8
User-Agent: Cyberduck/4.0.2 (Mac OS X/10.7.3) (i386)
Host: ***.***.edu
Cookie: $Version=0; xyc_XythosGroupDigest1=2CE8CEE95E83148FDAA840036333042790F1D893; $Path=/
Cookie: $Version=0; XythosSessionID1=[B@1361731--2017326351; $Path=/
Content-Length: 207
Depth: 1

HTTP/1.1 207 Multi-Status
HTTP/1.1 207 Multi-Status
Server: Apache-Coyote/1.1
Date: Fri, 02 Mar 2012 18:26:09 GMT
Content-Type: text/xml;charset=UTF-8
Content-Length: 14546
Version 0, edited on Mar 2, 2012 at 6:35:05 PM by Daggerquill (next)

comment:4 Changed on Mar 2, 2012 at 9:22:01 PM by dkocher

  • Status changed from new to assigned

This is most possibly caused by the Content-Type: text/xml; charset=utf-8 header in the MKCOL request.

comment:5 Changed on Apr 1, 2012 at 1:38:36 AM by dkocher

Fixed in Sardine.

comment:6 Changed on Apr 1, 2012 at 1:46:37 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r9495.

comment:7 Changed on Sep 26, 2012 at 4:49:00 PM by dkocher

  • Milestone changed from 4.3 to 4.2.2
Note: See TracTickets for help on using tickets.