Cyberduck Mountain Duck CLI

#6578 closed enhancement (fixed)

Edit in Textwrangler: new useless empty file opened too

Reported by: cy-ghi-my Owned by:
Priority: normal Milestone: 4.3
Component: core Version: 4.2.1
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

  • Start Textwrangler, close all windows OR close all windows and then exit from TW (in case TW is set to reopen windows from last time)
  • in Cyberduck give the command to edit a file in TW
  • in TW now I see an "untitled file" and the file I wanted to edit

Expected: only the file I wanted to edit.

How to avoid: having a file already open in TW does not present the problem of the unwanted empty files.

When I give the "edit file.txt" command in a bash prompt TW correctly opens only the file I provided, it does not open an empty one too.

Change History (5)

comment:1 Changed on Mar 16, 2012 at 2:48:54 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed

This is an issue that has to be fixed in TextWrangler.

comment:2 Changed on Mar 19, 2012 at 9:00:27 AM by cy-ghi-my

  • Resolution thirdparty deleted
  • Status changed from closed to reopened

Hello, I contacted BareBones in order to ask them to solve the issue, this is the answer:

I believe this is happening because Cyberduck tells the system to activate TextWrangler *before* sending it the event to open the document. When you have TextWrangler set to "New Text Document" at startup (which also affects its activation behavior), it will make a new window if no documents are open when it's activated. You can set this to "Do nothing" to work around the problem for now. On the Cyberduck side, if it can be changed to send the Open Document event to TextWrangler *before* asking the system to make it the active application, this should solve the problem, as well.

It seems that the issue is is caused by both my TextWrangler settings (that however make sense in most cases) and by a small issue in Cyberduck. Could you please try to correct it, as suggested by Barebones' developers?

Last edited on Mar 27, 2012 at 12:06:07 PM by dkocher (previous) (diff)

comment:3 Changed on Mar 27, 2012 at 12:11:02 PM by dkocher

  • Milestone set to 4.3
  • Type changed from defect to enhancement

comment:4 Changed on Jan 31, 2013 at 8:45:50 AM by W Breuer

In my case:

  • Textwrangler (4.0.1 from appstore) opens with a new file, but without the file I want to edit.
  • Cyberduck (4.2.1 from download) 'halts' for moments with the message it is calculating the MD5 hash.

Spindump available on request.

comment:5 Changed on Apr 8, 2013 at 5:48:10 PM by dkocher

  • Milestone changed from 4.4 to 4.3
  • Resolution set to fixed
  • Status changed from reopened to closed

I cannot replicate this in the latest snapshot build available. Please reopen if this is still an issue for you.

Note: See TracTickets for help on using tickets.
swiss made software