Cyberduck Mountain Duck CLI

#6592 closed defect (worksforme)

Cannot delete file due to special characters.

Reported by: deemerman Owned by: dkocher
Priority: normal Milestone:
Component: ftp Version: 4.2.1
Severity: normal Keywords: special characters
Cc: Architecture: Intel
Platform: Mac OS X 10.5

Description

Hi there,

I seem to have a problem with some very old files that are on my webspace and I was wondering if perhaps you could help me out.

The files in question date from back in 2005 and are some photos that have a special character in them. This is the character: ² .

All files in the folder that are unable to be removed have said character at the end, they're all .jpg's.

Trying to edit the name or delete the folder or files ends up in the same error: "550 (path) No such file or directory." Also it might be worth noting that the special character, ² , is not being displayed by cyberduck. Instead I see a black square with a question mark.

Now I've tried some other ftp clients just to delete these files but some of them don't even show the files in question. All I see is the folder and when I open it, it's supposedly empty. However, directly accessing the folder via my browser (not via ftp but just typing in their path as is) shows me the files are still online.

So I'm a bit stuck and I'm positive it's because of the special character, but I can't seem to find a solution to get rid of the folder with these files in them.

Is there anything I can do? I've been trying to solve this for hours.

Thanks so much!

Lorenzo

Change History (1)

comment:1 Changed on Mar 27, 2012 at 12:05:19 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Try to change the character encoding used. See 'View' → 'Text Encoding'. Try UTF-8 (the default), ISO-8859-1 and Windows-1252. Refer to help/en/howto/ftp.

Note: See TracTickets for help on using tickets.
swiss made software