Cyberduck Mountain Duck CLI

#6598 closed defect (fixed)

Cannot delete files with S3 protocol (GreenQloud)

Reported by: greenqloud Owned by: dkocher
Priority: high Milestone: 4.3
Component: s3 Version: Nightly Build
Severity: blocker Keywords: delete, snapshot, 9483, mac
Cc: Architecture: Intel
Platform: Mac OS X 10.7

Description (last modified by dkocher)

It worked fine to delete files in 4.2.1 but is broken in the latest snapshot release (9483). I get a "forbidden" error message. The test I did was to upload a file with no special characters to a bucket with no special characters and then I tried deleting it again. I have a feeling the command is trying to delete the wrong path or something has changed in the delete method for S3 protocol in this release.

POST /?delete HTTP/1.1
Date: Fri, 23 Mar 2012 15:29:53 GMT
Content-MD5: ygJzdhZmyIr1E/wSYW6dhA==
Content-Type: text/plain
Authorization: AWS VnFMV2s4YXlyVnlUS2FVeUlrNnh2OTVXcURWOW9v:D6N7UFysBXrX6xsDQTpoJb8V9C8=
Content-Length: 120
Host: permissionstest.s.greenqloud.com:443
Connection: Keep-Alive
User-Agent: Cyberduck/4.2.1 (Mac OS X/10.7.3) (i386)
Expect: 100-continue
HTTP/1.1 403 Forbidden
Date: Fri, 23 Mar 2012 15:29:50 GMT
Server: RestServer/1.0
Content-Length: 110
Content-Type: application/xml
Cache-Control: no-cache
Connection: close

Change History (11)

comment:1 Changed on Mar 23, 2012 at 3:41:37 PM by dkocher

  • Component changed from core to s3
  • Description modified (diff)
  • Milestone set to 4.3
  • Owner set to dkocher

comment:2 follow-ups: Changed on Mar 23, 2012 at 3:42:59 PM by greenqloud

As suggested: "That is most possibly related to #6438 implementing the new Multiple File Delete from AWS."

GreenQloud doesn't support versioning or multi factor authentication (yet and possibly won't). If it's simply a matter of not having the service implemented on our end and not a bug I suggest the delete method tries this method first (for the first file to delete) and if that fails to switch to the old method for the remainder of the session.

cheers Eiki

comment:3 in reply to: ↑ 2 Changed on Mar 23, 2012 at 3:50:39 PM by dkocher

Replying to greenqloud:

As suggested: "That is most possibly related to #6438 implementing the new Multiple File Delete from AWS."

GreenQloud doesn't support versioning or multi factor authentication (yet and possibly won't). If it's simply a matter of not having the service implemented on our end and not a bug I suggest the delete method tries this method first (for the first file to delete) and if that fails to switch to the old method for the remainder of the session.

cheers Eiki

This is not per se a feature related to versioning or MFA we support. Refer to S3 API documentation.

The Multi-Object Delete operation enables you to delete multiple objects from a bucket using a single HTTP request

This was introduced by AWS in the 07 December 2011 release.

comment:4 in reply to: ↑ 2 Changed on Mar 23, 2012 at 3:52:07 PM by dkocher

Replying to greenqloud:

…if that fails to switch to the old method for the remainder of the session.

I don't think I will support multiple paths here. You will have to bite the bullet and try to catch up on AWS here.

comment:5 Changed on Mar 23, 2012 at 3:52:17 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed

comment:6 follow-up: Changed on Mar 23, 2012 at 4:03:44 PM by greenqloud

I see...my mistake. We will definately add that method but can the next release however have the fallback until we do catch up, I suspect some other S3 compatible services will fail as well.

When is the next release scheduled anyway?

Also do you plan to support the standardised SNIA CDMI storage protocol? http://www.snia.org/cdmi

cheers eiki

comment:7 in reply to: ↑ 6 Changed on Mar 24, 2012 at 8:16:31 PM by dkocher

Replying to greenqloud:

I see...my mistake. We will definately add that method but can the next release however have the fallback until we do catch up, I suspect some other S3 compatible services will fail as well.

When is the next release scheduled anyway?

Will take another month.

Also do you plan to support the standardised SNIA CDMI storage protocol? http://www.snia.org/cdmi

Admittedly I haven't looked into this yet. I heard about Scality supporting this but don't know about anyone else. You might want to open an enhancement request so we can track this.

cheers eiki

comment:8 Changed on Jun 12, 2012 at 5:38:28 PM by dkocher

Fixed in r9565.

comment:9 Changed on Mar 22, 2013 at 10:10:56 AM by dkocher

  • Milestone changed from 4.4 to 4.2.2

comment:10 Changed on Mar 22, 2013 at 10:12:26 AM by dkocher

  • Resolution thirdparty deleted
  • Status changed from closed to reopened

comment:11 Changed on Mar 22, 2013 at 10:12:31 AM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.
swiss made software